All Forums Viewpoint
Cesco 13 posts Joined 02/13
11 Feb 2014
Session expiration time

Hello.
I need to set my viewpoint session never timeout.
In the "Teradata Viewpoint Configuration Guide" i find this metod:
1>Stop the Teradata Viewpoint portal
2>Open the file : /opt/teradata/viewpoint/webapps/ROOT/WEB-INF/web.xml and change this value :
 

<session-config> 

 <session-timeout>90</session-timeout> 

</session-config>

 

( If you want the sessions to never timeout, set the value to 0. )

 

3>Start the Teradata Viewpoint portal.

 

I do everything, but after some time after my login the session expire.

Anyone have any suggestions?

 

thanks for the help, bye!

Adeel Chaudhry 773 posts Joined 04/08
15 Feb 2014

Can you share how you stopped/started the viewpoint portal?

-- If you are stuck at something .... consider it an opportunity to think anew.

Cesco 13 posts Joined 02/13
17 Feb 2014

Hello Adeel, for stopping the portal, I use
viewpoint stop
and for start it
viewpoint start
 

krishaneesh 140 posts Joined 04/13
03 Mar 2014

On viewpoint under Admin>>viewpoint config>>General you have Session Timeout where you can set the session timeout.

Cesco 13 posts Joined 02/13
05 Mar 2014

On Teradata Viewpoint V14.00.00.03-b40 , I can't see "viewpoint config" in the Admin menu, the sub-menu are only:
Alert setup
Backup
LDAP Servers
Managed Servers
Portlet Library
Query group setup
Roles Manager
Shared Pages
Teradata Systems
User Manager
 
 

gryback 271 posts Joined 12/08
06 Mar 2014

Your Teradata Viewpoint version is getting old and moldy ... Viewpoint 14.00 was released in December 2011. The "General" tab and system timeout setting was introduced with Viewpoint 14.01:
 
http://developer.teradata.com/viewpoint/articles/teradata-viewpoint-14-01-release
 
So you need to upgrade but we would suggest upgrading to the latest available version being Viewpoint 14.10. 

Cesco 13 posts Joined 02/13
07 Mar 2014

Tnx gryback, but it's not my choise ... I must follow the directives of my company ( unfortunately )

You must sign in to leave a comment.