All Forums

Covers the world of Teradata Tools & Utilities. This includes topics such as SQL Assistant, BTEQ, TPump, FastLoad, TPT, etc. For articles, blogs and more, see the Tools section of the site.

You must login to post to the forums.
Calling BTEQ with file within PowerShell Topic by JamieH89 21 Jul 2015 bteq, powershell, cmd, operator, <

Hi,
Currently, I execute BTEQ scripts via a generated .Bat file with each script having a call to BTEQ similar to below:
bteq <Bteq\"File_1.btq" >> bteq_output.txt 2>&1

856 views
1 reply, 3 years ago
Teradata Metadata Manager Topic by Kishore_1 11 Mar 2016 Teradata Metadata Manager

Has the Teradata Metadata Services been discontinued since TD 14.10?
Where can I download it , if its available?
 

125 views
0 replies
Errorcode 3798 Topic by gera_g 09 Mar 2016 teradata, fast export, 3798

Hi All,
 

204 views
1 reply, 3 years ago
Teradata ODBC Driver For Linux - Urgent Help Requested Topic by shubhendu.pyne 08 Mar 2016 [ODBC Teradata Driver][Not enough information to log on Database driver error]

Hi Team,
I am facing issue after installing the TD 14.10 ODBC Driver.
Installation Sequesnce :-

rpm -ivh tdicu/tdicu-14.10.00.04-1.noarch.rpm

rpm -ivh TeraGSS/TeraGSS_linux_x64-14.10.07.01-1.noarch.rpm

rpm -ivh tdodbc/tdodbc-14.10.00.09-1.noarch.rpm

 

My .Profile :-

 

#For TD Driver

380 views
3 replies, 3 years ago
How to archive in ARCmain. Topic by wa255015 25 Jan 2016 arcmain

Hi,
I am new to arcmain. i have witten a simple archive arcmain script but now i have following requirement while archiving a teradata database:
·         How to archive file to particular location (e.g C:\user\backup)
·         How to divide archive file into chunks (like 100mb per file)
·         How to apply compression on archive file

392 views
5 replies, 3 years ago
Mload failing when trying to load file with þ (thorn) as delimiter Topic by tonez01 27 Feb 2016 multiload mload failing delimited

Hi All,
Not sure what I'm doing wrong but I'm trying to load a thorn (þ) delimited file.  Here is a sample record 

"field1"þ"field2"þ"field3"þ"field4"þ"field5"þ"field6"þ"field7"þ"field8"þ"field9"þ"field10"þ"field11"þ"field12"þ"field13"þ"field14"þ"field15"

Multiload script follows :

439 views
9 replies, 3 years ago
how to load different files using multiload into different tables. Topic by vuyyuru 01 Sep 2015

hi,
how to load different files using multiload into different tables.
File name will contain target table to load  ex: 'target_tablename_timestamp.dat, each file has header.
This header row should correspond to the column names that need to be loaded in the target table. We need to perform upserts on each target table.
Please advic me on this.

701 views
5 replies, 3 years ago
Teradata SQL Assistant 14 - History Window keeps moving Topic by bhupesh_mistry9 04 Mar 2016

Is there a way to lock the history window in SQL assistant to the right bottom corner of the application just like in the older versions if Queryman?

314 views
1 reply, 3 years ago
Casting Zoned decimal into readable decimal Topic by jjob 15 Jan 2008

Hi,I am migrating a file from a mainframe box to teradata. On the mainframe the field is stored as S9(9)V99. I need to convert it to decimal format on the teradata box. In the S9(9)V99 format the sign is superimposed with the least significant number, and thus converting it to a text format.Eg:- -123 would be represented in ZD as 12LWhen i use a query to read this field and attempt at casting it into a decimal format it gives me an error(3527) saying "Format string 'S9(9)V99' has combination of numeric , character and graphic values.The query i am using is:-select CAST((Field1 (FORMAT 'S9(9)v9(2)')) AS Decimal(11,2))also triedselect CAST(CAST(Field1 AS FORMAT 'S9(9)v9(2)') AS Decimal(11,2))Can anyone tell me if there is a valid data type to capture ZD usage.

35809 views
5 replies, 3 years ago
How to extract the count for the odbc source records in TPT Topic by rnekkanti 02 Mar 2016

I am trying to provide some assertions to users based on the number of records read from the source and number of records loaded into TD.
Is there any diagnostics functions present in TPT to extract the count of source records processed and number of records loaded into TD.
I have some details in the log file like these below .

94 views
2 replies, 3 years ago
TeraGSS Security Library [115022] Exception occured in TERAGSS layer. See inner exception Topic by KQ1024 03 Mar 2016 TeraGSS Security Library Exception, Teradata.Client.Provider.Tdexception

Gettting this exception whenever try to open the connection.
 

505 views
0 replies
Need help on arcmain Topic by Rags2Riches 24 Oct 2007

Hi All,I'm trying to copy an archive file zipped using arcmain sent to me and trying to restore it on my own teradata database. I need to view the contents of the archive before I load it with the copy db script. I need the name of the database name inside the archive and cannot restore the archive without it ?

28686 views
4 replies, 3 years ago
Transfering data from one server to another Topic by jking108 01 Mar 2016 #ETL #transfer #multipleservers

Hi,
 
Currently, I am trying to transfer data from one data table in TD(teradata) server1, to another TD server 2.

209 views
3 replies, 3 years ago
TPT Loader and JSON files Topic by pwjones@scj.com 29 Feb 2016 #TPT #JSON

A couple of questions.
 
First, when loading the Teradata Parallel Transport Wizard, I receive the following error message:
Exception in thread "main" java.long.UnsatisfiedLinkError:  C:\Program Files (x86)\Teradata\15.00\Teradata Parallel Transporter\bin\wwhelp.dll: Cant load a IA 32 bit.dll on a AMD 64 bit Platform.
The rest of the error is in the File.
 

114 views
0 replies
TPT installation guide Topic by wallace 21 Nov 2012

I would like to install TPT client on one of my linux server.
May I ask what software do I need to download and where can I find installation document?
 
Linux  2.6.18-238.12.1.el5 #1 SMP Sat May 7 20:18:50 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

Thanks,
Jim
 

4890 views
5 replies, 3 years ago
BTEQ - Cannot write hexa character in output file Topic by dreis 11 Sep 2012 bteq, hexa, hexadecimal characther, run file, output file, generated sql

 

Hi everyone,

 

6291 views
11 replies, 3 years ago
Convert a Field Topic by kparadise 23 Feb 2016

Hello,
I have a CHAR(12) field in a table.  This field is a last 12 month field, so it provides 12 characters representing each of the past 12 month.  Problem is, the 12 characters in this field could be blank.  So when I go to export, it gets all messed up.  Is there a way to look into a field and convert any blanks into a value; say; x ?  

130 views
3 replies, 3 years ago
Date value null Topic by sharma03 09 Oct 2008

Hi All,I have date values null in load_date column and it is represented as '?'I want to to replace '?' values with ' '(space)here is the syntax i am usingselect top 10 case when load_date is null then ' ' else load_date end from cust_prof_fctbut when i run this query i am getting an error 3800:Data type mismatch in THEN/ELSE expression.please help me in resolving this issue.

20339 views
6 replies, 3 years ago
When are secondary indexes required? Topic by aarsh.dave 26 Dec 2013 secondary index

Hi All,
I understand that a Secondary Index is a 2-AMP or an all-AMP operation, and also the subtable that is created and its contents.
However, I am not sure in what scenarios should a secondary index (unique or non-unique) be defined.
I would really appreciate some help here.
 
Thanks,
Aarsh

13033 views
19 replies, 3 years ago
TPT Stream Operator Topic by RAMKUMAR.9298 20 Feb 2016 tpt, tpump

Hi , 
Can anyone explain me whether TPT Stream Operator(TPUMP) can be used to load data from file to table and table to file. If it is possible could you kindly provide the script for the same. 
In my view, TPT Stream Operator is best suitable for mini batch loads. Could you confirm this also please. 
 
Thank you,
Ramkumar

462 views
2 replies, 3 years ago
Oracle Decimal to Teradata integer in TPT script Topic by mitchea5 28 Sep 2015 Teradata TPT, oracle, numeric, integer, decimal

I am writing a PT script which loads from an oracle source to Teradata.
PROBLEM_COL in Oracle is defined as DECIMAL(10,0). In Teradata PROBLEM_COL is defined as Integer.
The load fails, and all rows are inserted into the error table.
Reviewing the logs I believe I see the problem:
Column Name              Offset   Length Type         

677 views
4 replies, 3 years ago
Zip/GZip Support in TTU 14? Topic by ricejfx 22 Jul 2013 ttu 14, tpt, dataconnector, GZIP, ZIP

Hello everyone,

1784 views
7 replies, 3 years ago
TPT Instances - How this works? Topic by EricSantAnna 19 Oct 2012 java, tpt, teradata, teradata parallel transporter, pipe, instance, balance

Hi Teradata gurus,
 
I have developed a process in Java that read some files, add some fields, and load in some pipes to my TPT script.
In my tests I'm loading 6 pipes with 6 separeted Threads.
To load this I have these Producer Operators:

4653 views
6 replies, 3 years ago
Query Grid and Teradata External Table Topic by indranilbosu 18 Feb 2016

I am planning to implement Teradata external table in my project. Could anyone give me some insight on Teradata external table. Planning to connect hive table or HDFS files from that.
Is there any relation between Teradata external table and query grid? It would be nice if you can provide me few details on query grid, it's capability, limitation and performance.
 

108 views
0 replies
TTU Installation Problem Topic by deansiewert 02 Feb 2016

I was just given a new laptop and I'm re-installing software to get everything back as I had it on the old machine.  I have Teradata-Studio working and I'm now trying to get the tools to load.  Running either the TTU_BASE or TTU_DBM, I get the same error message saying ICU-32 and ICU-64 fail during install.

98 views
1 reply, 3 years ago

Pages