All Forums

Covers the world of Teradata Tools & Utilities. This includes topics such as SQL Assistant, BTEQ, TPump, FastLoad, TPT, etc. For articles, blogs and more, see the Tools section of the site.

You must login to post to the forums.
Need of Collect Statistics Topic by Gurunathan 25 Sep 2009

Hi. What is the need of collect statistics in teradata? Can anyone explain with suitable examples? Also, How can we choose the collect statistics columns?

53553 views
11 replies, 3 years ago
Error limit in TPT's STREAM Topic by Naveen_K 26 May 2016

Hi All,
 
I want to capture rows skipped due to Errors from STREAM operator. I see that this is not captured in STREAM in the way it is done for LOAD. I just get the following message.
STREAM_OPERATOR: Rows Inserted: 285

STREAM_OPERATOR: entering Cleanup Phase

165 views
1 reply, 3 years ago
which Teradata Utility is best for deleting records from Big table (2 TB Table) Topic by PallaviSharma 27 May 2016 teradata Utilities;teradata Utility

Hi People,
I have question regarding the Teradata utility. Could you please tell me which Teradata utility would be best to delete the records from Big table like 2 TB tables.

130 views
1 reply, 3 years ago
SQL Assistant key not found error Topic by EdSteck0717 17 Jul 2014

I am currently using SQL Assistant version 14.10.0.02 installed on a MS Windows 7 client and am receiving the following error dialog:
Key Not Found Parameter Name: key
Unexpected Error. Refer to the following file for details:
C:\Users\<username>\AppData\Roaming\Teradata\SQL Assistant\SQLAError.txt

2542 views
8 replies, 3 years ago
Teradata SQL Assistant - Database Explorer Window Topic by Shadyguy904 18 Mar 2013

I am having problems with Teradata Assistant (verion Teradata.Net 13.0.0.14) The Problem is with Database Explorer window becuse it is fixed length and width and I can´t adjust it as with the  answer and history windows. It seems to be docked, with no way of unpinning. I have tried seemingly everything. Any assistance would be greatly appreciated.

4598 views
8 replies, 3 years ago
TTU Trouble Installing from a Remote Resource Topic by Geneo 26 May 2016

When I try to install TTU from a remote resuce such as a Win server share the install will run but each of the setup.exe conflict with each other and prevent the install from completing.  TTU 15.00 install using any of the provided methods, silent, TTU_BASE, TTU_DBM.  The same scripts running from a local resource run fine and complete as expected.

134 views
0 replies
TPT 15.0 Compatibility with Teradata 14.10 Topic by h.r.thejas@gmail.com 26 May 2016 #TPT, #TDCH, #teradata

My main objective is to transfer data from teradata to hadoop. TPT is the fastest way of doing this (eventhough i have confusion between TDCH and TPT which one to go for).  TPT 15.0 onwards supports direct export to hdfs as i read in one of the documentation and also on one of the forums.

176 views
0 replies
Calculate each hour from a month Topic by omerf 24 May 2016 teradata calculate gained customer between eaah hour a month

Hi,
I want to calculate that, how many customer i gain from each hour a month.
For example between (20160401 00:00:00 and 20160401 01:00:00 i gain 5 customer)  
At the and of the month i want to show than frequency of the gained customer fır each hour.
How can i do that on teradata SQL assistant?
 
Thank you !

194 views
2 replies, 3 years ago
Need help on this error Type: 1 (0=TPT err, 1=DBS err, 2=CLI err) Topic by Akkipal 25 May 2016 #DBS, #TPT

Hi,
I have been frequently seeing this error in my jobs failure output:
"Type:1 (0= TPT err, 1= DBS err, 2=CLI err)
(While doing TPT API initiate)"
I looked at the component log file and I could not find any information which would give me a lead.
Can someone help me out in understanding these types and the error that is shown.

174 views
0 replies
BTEQ set width option Topic by sanjaythyagu 23 May 2016 set width, #BTEQ, # teradata

Hi,

 

In my BTEQ statement, I'm selecting two columns of a table and I'm exporting the output to local file. When I check that file only one column is present. I even tried giving the maximum value for .set width option (65531). It was not working. Please help me on this.

 

Thanks in advance,

Sanjay.

175 views
0 replies
Set TimeZoneString value using tdlocaledef or dbscontrol utilities Topic by chandrareddy321 19 May 2016 tdlocaledef TimeZoneString TimeZone

HI,
I want to set TimZone String value using the tdlocaledef utility. Current value is (got using 'dbscontrol' utility with 'display general'):
18. System TimeZone String         = Australia Eastern
I tried as below to set : 
# tdlocaledef -input sdf.txt

6766: Missing entries in SDF

 

261 views
1 reply, 3 years ago
TPT: Target Database different than Working Database with LOAD operator Topic by astocks 30 Jun 2015 tpt

How can I use a different target database (not TdpId) than what I declare in WorkingDatabase?  I want the log and error tables to go to a work database, but the target table is in a different database.
 
For example:
Work.ExampleTable_ET = error table in Work database
Person.ExampleTable = target table in Person database
 

824 views
2 replies, 3 years ago
FEXP_OPERATOR: TPT12108: Output Schema does not match data from SELECT statement Topic by tiiiway 18 May 2016 tpt

Any help will be much appreciated.  Thank you.
 
Teradata Parallel Transporter Version 14.00.00.04
Job log: /apps/tpt/Datos/TDA_DESA/Tptlogs/root-924.out
Job id is root-924, running on TDExpress1403_Sles10
Teradata Parallel Transporter Update Operator Version 14.00.00.04
MLOAD_OPERATOR_150: private log not specified

341 views
6 replies, 3 years ago
MLOAD - UTY4014 Access module error '43' received during 'set position' operation Topic by tiiiway 18 May 2016

Hello,

The script is working fine until i have receive this error.

460 views
3 replies, 3 years ago
TPT error 13 in finalizing the table schema definition(SELECTOR OPERATOR) Topic by tusharzaware1 11 Aug 2015

All,
My Table:
 

show table dba_backup.customer_tbl

 

CREATE MULTISET TABLE dba_backup.customer_tbl ,FALLBACK ,

     NO BEFORE JOURNAL,

     NO AFTER JOURNAL,

     CHECKSUM = DEFAULT

     (

      custno INTEGER,

      custname VARCHAR(20) CHARACTER SET LATIN NOT CASESPECIFIC,

      mob BIGINT)

747 views
6 replies, 3 years ago
TPT issue : not able to open the data file Topic by kusumayella 02 May 2011 tpt, file open error

Anybody has any info related to it.

TPT10517: At least 1 instance could not connect special sessions

I have checked in log,It has the following content

TPT01514: Error: Unable to Open File. Error code 2, Reason code 530, Class code 501

No such file or directory

file is in specified path itself and it has permissions too.

Thanks

8542 views
8 replies, 3 years ago
DATA_Selector: TPT15112: Column #1 in schema is too small to hold 11 bytes of data Topic by tiiiway 17 May 2016 tpt

HI All,
 
I don't know where to look at for this error in my script.  Please help.

246 views
5 replies, 3 years ago
tdwallet not working Topic by rbarbour 17 May 2016 tdwallet, user, password, bteq, logon

Using tdwallet version 15.10.00.02
I can not get $tdwallet to work in any way.  The tdwallet utility works and lets me add entries and delete entries.  But, in a bteq, the value is not substituted and I get a logon error.  For ease, I created an entry u with a value of the username and p with the password. 
Use tdwallet list to show the entries are there...

404 views
1 reply, 3 years ago
Installing Teradata Administrator Topic by MeenakshiM 08 Oct 2015 teradata administrator, install

Hi,
Can anyone please provide some pointers for downloading and installing Teradata Administrator in my system. 
Thanks,
Meenakshi

1250 views
2 replies, 3 years ago
Query Grid 15.0 to 15.10 Topic by KN 16 May 2016 Qrygrid 15.0 to 15.10

Hello All
 
Is it possible to look at system via Qrygrid where one of the 2 versions is running on 15.0 and 15.10 ?
Has anyone encountered any kind of errors when both the version varies?
 
regards
KN

136 views
0 replies
Scheduling stats manager collection jobs outside of Viewpoint? Topic by MarkJBrayshaw 16 May 2016 statistics, schedule

Hi, let me start by saying I love the stats managment facility in Viewpoint.  The only problem I have is in scheduling. My users are running mini batches 24X7 from Informatica and managed by Tivoli Scheduler and I've had to integrate my backups into the schedule to avoid locking/performance issues.

250 views
0 replies
Teradata connector error in datastage 8.5 Topic by arjune 30 Nov 2011

Hi

i am running a parallel job in datastage designer 8.5 to load into teradata table using BULK LOAD OPERATOR (tpt) using teradta connector.I got the following error.Pls, help me out.

ERROR:Teradata_Connector_0,0: Memory allocation failed (CC_TeraAdapter::setConnection, file CC_TeraAdapter.cpp, line 3,159)

8696 views
1 reply, 3 years ago
Better performance than fastexport Topic by archana_2016 16 May 2016

Hi
I would like to know if TPT is faster than Fast export?
As we want to export 180TB data into a file system, currently through Fast eport we are achieving 1TB per day . Can I expedite the process so that I can meet my deadlines.
 
Thanks in advance

81 views
0 replies
fexp data doubt Topic by nishi 23 Nov 2006

Hello,I have experience with SQL but I am new to Teradata and fexp tool, I am given a task to download data from a Teradata database, I have started with a simple query like below:.LOGTABLE cmpdb.lg1;.LOGON db1/nr2876,pwd;.BEGIN EXPORT;.EXPORT OUTFILE tbl1 format text mode record;SELECT trim(transaction_dt) FROM table1;.END EXPORT;.LOGOFF;But I am getting extra characters in the beginning of each record(shown below). What is this character and how I could avoid this character in my data download? Your help will be appreciated. I have tried select statement with CAST too, but I got the same result. I also tried different varchar and integer fields with same result(extra characters in the front).^H20050907^H20050912^H20050917^H20050925^H20050923^H20050923^H20050730^H20050730^H20050730Also I just have this basic question, what tool is better to download huge data(around 30 million records each with 70 int/date/varchar fields) from Teradata, Bteq or fexp or any other tools? My query contains lot of create, insert and select statements.Thank you for your time,nishi

25226 views
4 replies, 3 years ago
How to make use of ARCMAIN utility to take DB backup. Topic by tvn 09 May 2008

I was asked to take database backup using ARCMAIN. But, not sure how to start using this utility. Expecting valuable helps from the group.thanks in advance.

29749 views
11 replies, 3 years ago

Pages