All Forums

Covers the world of Teradata Tools & Utilities. This includes topics such as SQL Assistant, BTEQ, TPump, FastLoad, TPT, etc. For articles, blogs and more, see the Tools section of the site.

You must login to post to the forums.
Float data type export using Fast Export Topic by indra91 19 Jul 2016

Hello everyone,
 
I am trying to export a table with float data type using FastExport utility.As we know Teradata rounds-off any float values where number of digit is greater than 15. For instance  1231231231234585.1111 will be stored as 1,231,231,231,234,590.00.

125 views
2 replies, 3 years ago
TPT Export vs Fast Export Topic by indra91 15 Jul 2016

I need to ingest huge volume of data from Teradata systems to flat files in Unix System.I would to know if TPT would provide better performance over Fast Export utility and also whether TPT Export operator would offer any advantage/disadvantage compared to Fast Export?

343 views
6 replies, 3 years ago
122 views
1 reply, 3 years ago
FOR EACH clause in Teratada SQL Topic by rmrossi 20 Jul 2016

I have the statment below:

INSERT INTO P_WENL.RR_tmpParque2

SELECT

         Prqe.dt_foto_lnha

        ,Pssa.cdCliente

        ,Pssa.cdGrupo

        ,Pssa.nmCliente

        ,Pssa.nmGrupo

        ,Pssa.dsRazaoSocial

        ,Pssa.nmGerenteSenior

        ,Pssa.nmDiretor        

        ,Prqe.id_uf

121 views
1 reply, 3 years ago
In List Blues - How to make large In List Queries More Efficient Topic by JustinS 18 Jul 2016 bteq, business objects, In List

I work for a bit company with a lot of Business Objects users. One of our most popular universes points to a Teradata environment. This universe is by far our best BI resource. It has a ton of data and it delivers it to the users lightning fast. However, some of our users like to utilize a prompt that allows them to input a tremendous amount of data as an "in list" where clause.

264 views
4 replies, 3 years ago
TDCH-TPT Interface--For loading into Hadoop Topic by indra91 18 Jul 2016

I need to ingest volume of data from Teradata to Hadoop using TPT.I saw in the TPT documentation that we can achieve this using TDCH-TPT interface.I would like to know the following about the process:

201 views
1 reply, 3 years ago
Encryted Password File for FastExport Topic by indra91 14 Jul 2016

I wanted to know if there is a way to store the .logon  username/Password in a separate File and include it while calling the Fastexport script.Also is there any option to encrypt the password file which can be read only by the Fastexport script?I tried to set the DataEncryption option to ON but could not find  any difference in the log.?

424 views
11 replies, 3 years ago
TPT read fixed file and convert space to null value Topic by rou_oli 18 Jul 2016

hi,
i search a TPT syntax but i'm not sure if it's possible.
i have an input fixed file's. Two columns as a varchar(15) and a varchar(8) and the second column can contain 8 space caracter wich convert it as null value.
In the block SCHEMA or OPERATOR, is it possible to define the conversion or is it only possible to the APPLY statement with case when syntax ?
 

127 views
2 replies, 3 years ago
Error creating .genuine_TTU file on Ubuntu system Topic by beargiles 14 Jul 2016 ubuntu, .genuine_TTU

I'm trying to install the (Redhat) RPM files on my Ubuntu system. I tried using 'alien' to convert the .rpm to .deb files but, inexplicably, it refuses to convert a i386 package on a x64 platform. No matter - I can convert it to a .tgz file and install it manually.

147 views
1 reply, 3 years ago
TPT deadlock Issue. Topic by achikan01 10 Oct 2014 #TPT

When trying to insreat into log table getting deadlock on TPT script

2745 views
17 replies, 3 years ago
Teradata tpt Topic by akd2k6 14 Dec 2014

Hi All, I am new to this post and in teradata.

I am trying to create one unix script that will do the table sync from one to another for COB sync with tpt utility.

 

I need script to unload from source table and load to target table by tpt and if possible unload file in delimited.But also I need to generate the dml of the unload file and save it for future use.

4809 views
49 replies, 3 years ago
Teradata SQL Assistnat 15.10.1.4: Tab colors Topic by N_Raghu 11 Jul 2016 TDSQLA 15.10 Tab Color

I am using Sql assistant 15.10.1.4. Tab color is not changing to pink while executing a query Also does not change to green after query completion as we use to have in previous versions. I did checked options ->code editor->[Tab] Query Complted . It does have green color seleted.

224 views
4 replies, 3 years ago
Fastload - Error on piom GET ROW: 64 Topic by Martijn 12 Jul 2016 Fastload Undocumented Errors

Hello, I hope some one can help me with the following problem.
I have a .txt file on my windows computer I need to import into Teradata. The file is 18 MB in size. It is delimited with comma and every kolom is in between quotes ("). Every record is ended with CR LF.
When I try to import the file I get this error:

330 views
3 replies, 3 years ago
TPT output from ODBC includes Indicator Bytes? Topic by DaveWellman 15 Jul 2013 tpt, load, odbc, indicators mode

Hi,
I'm trying to transfer data from a MySQL table into a Teradata table. The export uses the ODBC operator and the inport uses the LOAD operator.
All records go into the ET table, usually with 2673 (source parcel length incorrect) errors, some of them fail with a 6760 (invalid timestamp field).
 

2222 views
13 replies, 3 years ago
TPT02639 - Conflicting data type error for column Topic by archana_2016 08 Jul 2016

Hi
I am trying to export table data to file using TPT script using encoding UTF8 and the column structure is as follows that contains chinese title ex: zone_num char(6) CHARACTER SET LATIN CASESPECIFIC TITLE '分区编码'  NULL COMPRESS '   ' 
My select statement is simply select * from table1 and the error that i get is as folows:

208 views
2 replies, 3 years ago
tpt conversion from varchar to timestamp(6) DEFINE SCHEMA FILE_SOURCE_SCHEMA ( Main_Id VARCH Topic by mcorsi 07 Jul 2016 tpt, builk loading, data upload

I am having difficulty using tpt and bulk loading dates into a table. My define schema looks like:

385 views
17 replies, 3 years ago
teradata TPT , all rows in error table Topic by dhiraj_dt121 06 Jul 2016 TPT teradata

Hi Folks, I have created TPT script, however when I run it all the rows are errored out. Below is my code and the table structure.

192 views
3 replies, 3 years ago
TPT export to delimited files Error Topic by dhiraj_dt121 06 Jul 2016 teradata, tpt

Error : TPT_INFRA: TPT02638: Error: Conflicting data length for column(5) - STATE. Source column's data length (16) Target column's data length (8).

EXPORT_OPERATOR: TPT12108: Output Schema does not match data from SELECT statement

 

Code : 

247 views
3 replies, 3 years ago
TPT EXPORT OPERATOR job structure Topic by monchomark 06 Jul 2016

Hi guys, can you help me with a basic structure for a TPT EXPORT operator job?
I have good examples on LOAD operator but I'm not sure what to change ar what's needed.
This would be a load operator generic structure:

162 views
5 replies, 3 years ago
SQL Syntax Checker Topic by Ted Colman 04 Sep 2007

Does Teradata offer any tool to check sql syntax before compilation or execution? For example, Microsoft SQL Server has the sql check button to validate that a sql statement's syntax is correct - does Teradata have a similar tool to do this? If not does anyone have a best known method to accomplish this?

23058 views
3 replies, 3 years ago
TPT load failure on Interval datatype - Error code 7452 Topic by ssavoye 28 Jun 2016 tpt, bteq, interval

Any assistance would be welcomed.  I cannot seem to put the Interval in a format that Teradata likes.  The column data looks like "00 02:00:00.000000".  We are extracting it from ORacle and loading to Teradata version 15.10.  I am able to load most other data types no problem, but I cannot find the format needed to make this happy.

258 views
4 replies, 3 years ago
326 views
1 reply, 3 years ago
<Internal Session> blocking users and causing deadlock Topic by Marcus Connolly 23 Aug 2010 internal session blocking arcmain multiload fastload deadlock

Hi there,
We are having a problem here at our site for some time and we are wondering if anybody else has had a similiar problem.
The problem is a locking issue we are having where the system deadlocks where the only remedy seems to be a database restart or by a manual job abort.

Here are some instances where it has occured:

-Arcmain acquires locks on dictionary tables triggering deadlock with any user action needing access to the same tables. The system hangs until restarted or one of the jobs holding a lock is aborted.

17734 views
10 replies, 3 years ago
online archive feature in Teradata 13 Topic by SPOLISETTI 21 Jul 2011 online archive, cluster online, multistream online, online backup

Has anyone tried this feature in TD12 or TD13?

I would like to know how it does online backup. Do the inserts/updates are commited while the backup is in progress?
Does it use Transient Journal? Teradata manual on backup has below information.
I am looking for more technical information on how online backup is done.

"When online archive is initiated on either a table or a database, the
system creates and maintains either a log for the specified table or a
separate log for each table in the specified database. All changes to a

7522 views
4 replies, 3 years ago
2555:TABLE DOES NOT BELONG TO THE MLOAD JOB. Topic by anilkumar922 29 Jun 2016

Hi all,
When I tried to load the table I got below error
2555:TABLE DOES NOT BELONG TO THE MLOAD JOB.

I defined all required tables to this load
But still I'm getting this error.

Please suggest how I can overcome this issue?

152 views
2 replies, 3 years ago

Pages