All Forums Tools
robinsu 2 posts Joined 06/12
23 May 2014
TTU 15 Installed, SQL Assistant Error

After install TTU 15, The SQL Assistant show Error:
=== Entry Point Not Found ===
The procedure entry point __crtInitializeCriticalSectionEx could not be located in the dynamic link library MSVCR110.dll
 
OS is Windows 7.
Are you have similar experience on TTU 15? Please advise me and thanks a lot.

Tags:
Win 28 posts Joined 03/13
21 Sep 2014

Hi,
I am also having this exact same error using also the same OS and I think that the version of the OS has nothing to do with it. A friend of mine did not have any issues connecting to the database using TD15. So I think that the error lies on the version of the C++ Redistributable (MSVCR110.dll). I am currently researching about this. I will share any information that I will find. Please inform me also if you were able to resolve this.
 
Thank you.

spimr 1 post Joined 09/13
01 Oct 2014

I have the same problem :-(

ITHelper 1 post Joined 10/14
10 Oct 2014

I am working with someone who is receiving the same error.  Has anyone resolved this?

MikeDempsey 94 posts Joined 10/06
10 Oct 2014

That dll is the Visual C runtime for C applications compiled with VS 2012.
SQL Assistant is a .Net app rather than a C app so it doesn't use that dll.
The problem must be originating in one of the components we rely on. (ICU, TeraGSS or ODBC)
Those packages should install their required dlls so something must have gone wrong in the install.
There is a Microsoft article that describes similar issues [but mostly on Windows 8 I think] with other apps. It includes a link that allows you to download the missing file.
http://answers.microsoft.com/en-us/windows/forum/windows_8-winapps/the-program-cant-start-because-msvcr110dll-is/f052d325-3af9-4ae5-990b-b080799724db
 

MikeDempsey 94 posts Joined 10/06
21 Nov 2014

Another option, if the above did not help, is to connect using Teradata.Net rather than ODBC.
You will need to install the .Net Data Provider for Teradata, which can be downloaded from this site. This may avoid the requirement for C runtime files since it contains its own version of TeraGSS. (May still require ICU though)
Also, I would suggest downloading TTU 15.00.03 from the T@YS software server. This contains a newer version of SQLA (15.0.0.4) in addition to updates to the interface products that may have solved this issue.

jan.abramek 1 post Joined 10/14
21 Jan 2015

I have the same problem. Updating VC Redistributable didn't helped me. msvcr110.dll is located here:
C:\Program Files (x86)\Teradata\Teradata GSS\nt-i386\15.00.00.00\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files (x86)\Teradata\Teradata GSS\nt-i386\15.00.00.00\bin\msvcr110.dll
C:\Program Files (x86)\Teradata\Teradata GSS\nt-i386\LCLIENT\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files (x86)\Teradata\Teradata GSS\nt-i386\LCLIENT\bin\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-i386\15.00.00.00\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-i386\15.00.00.00\bin\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-i386\LCLIENT\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-i386\LCLIENT\bin\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-x8664\15.00.00.00\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-x8664\15.00.00.00\bin\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-x8664\LCLIENT\bin\Microsoft.VC110.CRT\msvcr110.dll
C:\Program Files\Teradata\Teradata GSS\nt-x8664\LCLIENT\bin\msvcr110.dll
So, it is definitely Teradata GSS.
How can I download newer version of TTU from this server? 

kneelame 1 post Joined 07/13
01 Apr 2015

was this problem solved. I am facing the same error.. I understand that TTU 15.00.03 may have resovled but I dont see this package for download.. any help is appreciated.

timw 1 post Joined 02/15
15 Jun 2015

hi there! i'm facing the same error when trying to use teradata SQL assistant, may I know where can I get the latest TTU? On teradata developer exchange its not the lastest one. would appreciate your help! ;)

MikeDempsey 94 posts Joined 10/06
26 Aug 2015

Someone did confirm that it works OK if you use Teradata.Net instead of ODBC.
(This is always recommended anyway)
I was also informed that a different user, on the same system, can use the app without incident. That implies that it is somehow an 'environment' issue, such as permissions, and must be related to ICU, TeraGSS or ODBC rather than SQLA itself.

ltsane 1 post Joined 03/15
13 Feb 2016

I simply just tried to run is as SQL assistant as Administrator and it worked. Weird!

You must sign in to leave a comment.