All Forums Tools
archana_2016 16 posts Joined 05/16
08 Jul 2016
TPT02639 - Conflicting data type error for column

I am trying to export table data to file using TPT script using encoding UTF8 and the column structure is as follows that contains chinese title ex: zone_num char(6) CHARACTER SET LATIN CASESPECIFIC TITLE '分区编码'  NULL COMPRESS '   ' 
My select statement is simply select * from table1 and the error that i get is as folows:
 TPT02639: Conflicting data type for column zone_num source (varchar) target column's data type (CHAR)
TPT12108:Output schema does not match data from select statement
Tried removing the USING CHARACTER SET UTF8 from the script still no luck.
Tried the following as mentioned in one of the posts the script had executed but the file output was empty
* Used the Selector operator and  set the ReportMode attribute to 'Y'
In apply we had put selector instance as 2 and writer instance as 1 with maxsession value equal to AMP's.
This issue looks like an encoding format issue because a normal table gets exported without any errors .Could you suggest us with the solution for handling the encoding of chinese characters.
Thanks in advance

feinholz 1234 posts Joined 05/08
08 Jul 2016

Please provide the script and version of TPT.
Did you use VARCHAR in the schema for that column?
If so, then you need to change that to match the source table definition.
And with a character set encoding of UTF8, you need to triple the size  (from 6 to 18).


archana_2016 16 posts Joined 05/16
10 Jul 2016

Hi Steve
Version used is By using cast conversion we were able to solve the issue but the chinese characters are not getting exported appropriately. Is there anything to do with the encoding format?
Thanks in advance

You must sign in to leave a comment.