All Forums Tools
blackrooster 14 posts Joined 02/14
07 Jan 2015
TPT Wizard driver error

When I try to use TPT wizard to connect to SQL Server using odbc DSN I am getting: There was an error initializing the driver for usage.

 

My configuration is the following:

 

Teradata RDBMS version 14.10.03.06

 

64bit Windows Server

 

TTU is patched to 14.10.15.00

 

I am using Microsoft ODBC Driver 11 for SQL Server.

 

Should I get this to work or is my only option to install the latest version of TTU 15 which bundles the DataDirect drivers? 

rafael1028 1 post Joined 06/12
07 Feb 2016

hi i got the same error someone can help me with this thank you in advance 
 
driver error 
     there was an error initializing the driver for usage 

feinholz 1234 posts Joined 05/08
08 Feb 2016

Does this error occur when using the Wizard to set up a job?
Or does this error occur when you are actually running the TPT job.
 

--SteveF

req56338 1 post Joined 05/15
15 Feb 2016

I too and trying to use the Teradata Paralell Transport Wizard to load data from a SQL Server data base to a Teradata database.
I get the same error:  There was an error initializing the driver for usage --> when trying to create an ODBC connection int the TPT Wizard.
ODBC Driver For Teradata - Suite 15.10.04
Teradata Tools and Utilities:  15.0.0
Teradata Database Version:  15
SQL Server Version:  SQL Server 2014 and SQL Server 2008 R2
SQL Server ODBC Versions tested:  SQL Server 6.03.9600.17415  and SQL Server Native Client 11.0    2011.110.3407.00
 
Thanks!
Tim R.

TDHS9 5 posts Joined 04/12
26 Aug 2016

I'm having the same issue on 2 different machines. One with Ver 15.00 and other with 15.10.
I've updated the client software with latest version on one of the machines as below.
Database Version 14.10

TTU 15.10.07

===================

Products Updated in this roll-up:

 

15.10.02.08         Teradata GSS

15.10.01.06         Teradata Wallet

15.10.01.02         Shared ICU Libraries for Teradata

15.10.01.04         Teradata CLIv2

15.10.01.05         Teradata BTEQ

15.10.01.05         Teradata SQL Assistant

15.10.01.03         Teradata C PP2

15.10.01.04         Teradata FastExport

15.10.01.04         Teradata FastLoad

15.10.01.06         Teradata MultiLoad

15.10.01.03         Teradata TPump

15.10.01.04         Teradata OLE DB Access Module

15.10.01.03         Teradata Parallel Transporter Base

15.10.01.03         Teradata Parallel Transporter Stream Operator

 

SQL Server version : 2008 R2

 

 
On other note, we've older version(14.0) installed on one of the server, which was working ok but lately we have issues as it can connect to SQL Server using ODBC DSN and displays list of databases in left pane but It will not allow to select specific table. if we click on + it will not expand table list.
Another observation: If you click on Help -->About in TPT window it will not display any information. only pop window with 'OK button will pop up.

Any help is greatly appreciated.

 

Thanks

 

 

 

You must sign in to leave a comment.