All Forums Tools
toyo2009 2 posts Joined 05/12
28 May 2012
TPT unknown load error

TD DB version: (TD express)

TPT version:

OS: Windows 7


I have 2 files, let's say test1.dat and test2.dat, both containing TAB delimited data. Both files will be loaded to 2 different tables (suppose, table1 and table2)

My 1st run for test1.dat was a success. Then, copy the same script and edited the following: operator name for the 'type load' and 'type dataconnector producer', the 'targettable' attribute, the logtable attribute, and also the JOB name

DEFINE OPERATOR file_reader_2




VARCHAR FileName = 'test2.dat'

, VARCHAR DirectoryPath = 'C:\folder'

, VARCHAR OpenMode = 'read'

, VARCHAR Format = 'Delimited'

, VARCHAR TextDelimiter = 'TAB'


 JOB name


 When I try to run the 2nd script it's throwing a weird error:


Load_t: connecting sessions
Load_t: preparing target table
Load_t: entering Acquisition Phase
file_reader_2 Operator instance 1 processing file 'C:\folder\test1.dat'

 The test1.dat is no longer in the script, but TPT is still processing the test1.dat and I don't know why. I'm not sure if this is stored in the DD or cache, i tried restarting the teradata DB (same issue), and rebooting my computer but still having the same issue.

My 1st script containg test1.dat(success), my 2nd script contains test2.dat (failed) but still when I run the 2nd script it is still processing test1.dat.


Is this a known bug? Any idea on this?

Thanks in advance.


feinholz 1234 posts Joined 05/08
06 Jun 2012

Ok, well I would like to say "that could never happen" and "we only process what is in the script".

But clearly you are seeing different behavior than what "should" happen.

Therefore, I would need for you to post the entire script, and the command that you are running and the entire console output.

I also need to know whether the job using test1.dat (that succeeded) indeed did complete correctly and did not have any error, such that the job with test2.dat is picking up an old unfinished job by accident.

The other thing I need you to do is to upgrade to the latest and greatest 13.00.00 patches for the entire product. You are using patch level 2 but I know we are a lot higher than that.

We will not try to chase down a problem from an old piece of code (and who knows, maybe we had a glitch somewhere and it was fixed with one of the newer patches).




You must sign in to leave a comment.