All Forums Tools
GNS 5 posts Joined 09/15
30 Sep 2015
TPT 15.00 For Linux and Informatica ETL

Hello,
 
I have installed on linux server the following :
a. Teradata GSS Client (teragss)
b. Shared ICU Libraries for Teradata (tdicu)
c. Teradata Call-Level Interface version 2 (cliv2)
d. Teradata Data Connector API (piom)
e. tptbase1500__linux_indep.15.00.00.05-1.tar.gz
f. tptstream1500__linux_indep.15.00.00.05-1.tar.gz
g. tdodbc__linux_indep.15.00.00.04-1.tar
 
After this i have set the following environment variable on linux:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/INFA/ PowerExchange9.6.1
export LD_LIBRARY_PATH=/opt/teradata/client/15.00/lib: $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=/opt/teradata/client/ODBC_32/lib: $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=/opt/teradata/client/ODBC_64/lib: $LD_LIBRARY_PATH
export LD_LIBRARY_PATH=/opt/INFA/java/bin:/opt/INFA/java/jre/ bin:$LD_LIBRARY_PATH
export COPLIB=/opt/teradata/client/15.00/lib/clispb.dat
export COPERR=/opt/teradata/client/15.00/lib/errmsg.cat
export TD_ICU_DATA=/opt/teradata/client/15.00/tdicu/lib64
export THREADONOFF=1
export TWB_ROOT=/opt/teradata/client/15.00/tbuild/bin
export PATH=${JAVA_HOME}/bin:${JRE_HOME}/bin:${PATH}
export NLSPATH=/opt/teradata/client/15.00/odbc_64/msg:/opt/ teradata/client/15.00/odbc_32/msg:/opt/teradata/ client/15.00/tbuild/msg/%N:/opt/teradata/client/15.00/ tbuild/msg/%N:/opt/teradata/client/15.00/odbc_32/msg/% N
 
When i try to start a workflows a receive the following errors:
 
Message Code: TPTWR_35132
Message: [ERROR] Plug-in failed to load Teradata Parallel Transporter API Library.
Message Code: TPTWR_31301
Message: [ERROR] Plug-in failed to initialize Teradata PT Writer Plug-In.
Message Code: SDKS_38007
Message: Error occurred during [initializing] writer plug-in #315000.
Message Code: SDKS_38003
Message: Plug-in #315000's method PPluginDriver::init() failed.
 
Could you please help me with this errors?

feinholz 1234 posts Joined 05/08
28 Oct 2015

Not sure if this is relevant, but in your export of LD_LIBRARY_PATH, I see a space character before "$LD_LIBRARY_PATH".
Was that intended?
After you have executed the "exports", please provide the output of the LD_LIBRARY_PATH environment variable.
Next, make sure that libtelapi.so is really installed in /opt/teradata/client/15.00/lib.
 

--SteveF

You must sign in to leave a comment.