All Forums Tools
datamo 2 posts Joined 01/14
09 Mar 2014
TPT 14.10 error with fifo input files

Hi everyone!!
I have several tpt scripts (which input is a fifo file) that used to run properly in tpt 13.0, now the system in which I'm working is upgrading to 14.10 and the scripts fails...
the error is:
        "TPT19120 !ERROR! multi-instance read feature requires REGULAR file names."
I've tried to run de tpt sample scripts founded in  
/opt/teradata/client/14.10/tbuild/sample/userguide/02b    (your installation path)  this sample show how to run tpt with an input fifo file, but I get the same error:

"TPT19120 !ERROR! multi-instance read feature requires REGULAR file names. 'data/datapipe' is not a REGULAR file."

 

Anyone know what is happening? Are there any parameter I've to define in order to get input data from a fifo file? 

 

I can't find any differences in paper related to this error... and the scripts in 13.0 runs fine!

 

Thanks in advance for your help!!!
 

datamo 2 posts Joined 01/14
12 Mar 2014

Hi,
Problem solved!!
This appear to be a known problem, JIRA TPT-18991, exposed in version 14.10.00.02-1 and fixed in version 14.10.00.04-1.
So if someone are using TPT 14.10.00.02-1 and have the same problem, can solve it upgrading to the latest TPT version available (as of today TPT 14.10.00.04-1).
 
Good Luck!

feinholz 1234 posts Joined 05/08
12 Mar 2014

what does the "-1" mean in your version numbers (e.g. 14.10.00.04-1)?

--SteveF

You must sign in to leave a comment.