All Forums Tools
Alexander K 22 posts Joined 09/13
24 Oct 2013
Teradata Parallel Transporter Wizard 14.10 Issue

This is nearly the same exception issue reported upon launching TPT 13.10 in the following thread:
http://forums.teradata.com/forum/tools/teradata- parallel-transporter-wizard-13-10-issues
I just installed TPT 14.10 on a Windows 7 x64 machine, and I get a similar error as above upon launch; see the error message at bottom of post. TPT never fully launches but instead stalls on splash screen. I have Java RE version 1.7.0_40, but downgrading to JRE 1.6 did not help. Also, the permissions trick did not work for me, as it did for the colleagues with version 13.10. Any recommended solutions are appreciated.
Thanks,
Alexander.
-----
Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program Files (x86
)\Teradata\Client\14.10\Teradata Parallel Transporter\bin\wwhelp.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary1(Unknown Source)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at com.teradata.jgui.webworks.WWHelp.<clinit>(Unknown Source)
        at com.teradata.jgui.webworks.WebWorksHelp.initialize(Unk nown Source)
        at com.teradata.jgui.framework.TDHelp.getInstance(Unknown Source)
        at com.teradata.jgui.framework.GUIFramework.<init>(Unknow n Source)
        at com.teradata.jgui.framework.GUIFramework.runGUIFramewo rk(Unknown Sour
ce)
        at com.teradata.jgui.twb.TWBGui.main(Unknown Source)

feinholz 1234 posts Joined 05/08
28 Oct 2013

This might be difficult, but try running with JRE 1.5.
The Wizard does not support 1.6 or 1.7.
 

--SteveF

Alexander K 22 posts Joined 09/13
06 Nov 2013

I appreciate the feedback!
In this continuing saga:
a) It was quite an exercise locating on the web a copy of the (far) outdated 1.5 version--without having to register with Oracle. Hint: Try filewatcher.com and enter the desired file name.
b) With JRE 1.6 and 1.7 installed on my Win 7 computer, I installed the 1.5 version, too. I tried it this way, I tried it by leaving only version 1.5 installed, but no matter what Win 7 cannot locate the Java executable. That is, now the problem has shifted to getting JRE 1.5 located by the system. Unfortunately, setting explicitly the environmental variable JAVA_HOME di dnot work either, even after restarting the computer.
At this point, I have put way too much time into this without any reasonable results, and I would strongly recommend that TPT is updated to work with the newer JRE versions.

feinholz 1234 posts Joined 05/08
06 Nov 2013

This product will be discontinued in the not-too-distant future, and so allocating resources for this tool is not currently a high priority.
 

--SteveF

prelunar 1 post Joined 01/14
31 Jan 2014

can you find any solution,i am facing the same issue.
Thanks in advance

veehell 19 posts Joined 07/12
04 Feb 2014

Hi there, 
we tryed TPT Wizard and I see that the *.cmd is relating to such old *.jar files (from 'java\lib' as well from 'jdbc\lib') ... 
So i do not understand why:
1] the script is not taking ORACLE_HOME from windows registry as any other program, why there is hardcoded variable within the *.cmd file?
even seting via env.variables does not solve the issue, you have to put the 'set' command to *.cmd file for tptwizard.
ie: set ORACLE_HOME=c:\app\Administrator\product\11.2.0\client_1
2] the script is relating to Oracle8.jdbc drivers/classes, as I have Oracle11 or Oracle12 client installed i no longer have those classes at all...
so I just replaced few path... and delete those i do not have.
(   java -Xmx100m -Xss1m -DTERADATA_PARALLEL_TRANSPORTER_CONFIG="%CONFIG_PROPS%" -DTWB_CFG="%TPT_CONFIG_PROPS%" -DLOGDIRECTORY="%DEFAULT_LOG_DIR%" -cp jars\tptwizard.jar;jars\terajdbc4.jar;jars\tdgssjava.jar;jars\tdgssconfig.jar;%ORACLE_HOME%\jdbc\lib\ojdbc6.jar;jars com.teradata.jgui.twb.TWBGui

   set TPT_RC=%ERRORLEVEL%

)

 

At that point i can run the wizard, i can generate some script, i can run them. But still facing some issues with Microsoft ODBC provider even if I am using just jdbc connection so far.

 

Anyway, thanks for the info, that this product will be discontinued. 

cheers
-vh-

Alexander K 22 posts Joined 09/13
14 Mar 2014

Issue solved.
 
First, use a command window to:
1) check your Java version:
% java -version

2) check Java environmental variable:
% echo %JAVA_PATH%

3) check your Windows path:
% echo %PATH%

In my case, the latter two were not set to include the Java path, and the first would return nothing. So where did the Java path come from in the TPT wizard?
It turns out my existing Windows PATH has a subpath ;%SystemRoot%\system32 =
= C:\Windows\System32 wherein Java executables had been installed during Java installation and were being selected by default: Keep an eye on future Java updates; the problem might come back! As soon as these were removed and the above variables set, the issue was resolved.

For the following, let us assume you have JRE 7 on your PC, possibly both the x86 and the x64 versions installed. To set the environmental variables accordingly, go to
[Control Panel]\[System]
then launch [Advanced System Settings]\[Environmental Variables]
and set:
JAVA_HOME as C:\Program Files\Java\jre7\bin
Also, edit PATH and append:
;C:\Program Files (x86)\Java\jre7\bin;C:\Program Files\Java\jre7\bin

Log out and back in, or restart for the changes to take effect.
 

N_Raghu 34 posts Joined 12/13
04 Jun 2014

My TPT wizard started working in 64 bit environment after following below steps,
 
1) I have installed latest JRE8 32 bit version 
 
2) Appended "C:\Program Files (x86)\Java\jre8\bin;" to PATH environment variable.
3) Also make sure you have full control access to below folder structure,
     C:\Program Files (x86)\Teradata\Client\13.10\Teradata Parallel Transporter
 
Thank You
Raghu

-Raghu

teradatauser2 236 posts Joined 04/12
02 Feb 2015

Hi,

I have windows vista 32 bit os. I am trying to run tpt wizard but get an error while opening. I can see a command prompt run after i click it with error message - syntax error while parsing etc..

I tried the path,java_path and control methods, but no luck yet. I have TD express 13.0 and JRE 7. Any help ?

 

--Samir

You must sign in to leave a comment.