All Forums Tools
mm185159 21 posts Joined 03/11
27 Apr 2011
Teradata Parallel Transporter Wizard 13.10 Issues

When using TPT Wizard 13.10 I am not able to save a job. When I get to the Finish and Submit dialog screen, I click on "Finish" and nothing happens. Then I click on Cancel and a dialog box asks me if I want to cancel with unsaved job?.

Has anyone run into this issue and how can it be fixed?

mm185159 21 posts Joined 03/11
27 Apr 2011

So, I fixed this problem as it was related to permissions on the directories where the wizard was installed.

Now I have a new issue...I get a script generation error...but the erro code is :UNKNOWN_ERROR
the error description is: An unknown error occured while generating the script (error code: UNKNOWN_ERROR)
Error Context:

I have no way to resolve this error as I am not an XML expert. Seems like in the jobrun directory there is the beginnings of a script, but nothing that tells me why it could not complete.

Any ideas on how to resolve this error message and submit the job succesfully?

dilin.joy 16 posts Joined 03/11
10 Jun 2011

Aye you on Windows 7? For which directory you had the issue?

Re.Furlan 3 posts Joined 08/11
01 Aug 2011

Hi everybody,

I'm getting a strange issue when I try to run the Teradata Parallel Transporter Wizard.
Every time I click in the icon to run it the command prompt that pop up shows the message bellow:

Info: Launching Teradata Parallel Transporter Wizard ...
Keep this window running.
This window will automatically close after exiting
Teradata Parallel Transporter Wizard.

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Teradata\Client\13.10\Teradata Parallel Transporter\bin\wwhelp.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at com.teradata.jgui.webworks.WWHelp.(Unknown Source)
at com.teradata.jgui.webworks.WebWorksHelp.initialize(Unknown Source)
at com.teradata.jgui.framework.TDHelp.getInstance(Unknown Source)
at com.teradata.jgui.framework.GUIFramework.(Unknown Source)
at com.teradata.jgui.framework.GUIFramework.runGUIFramework(Unknown Source)
at com.teradata.jgui.twb.TWBGui.main(Unknown Source)

Would someone have a clue to fix this issue and run the TPT properly?

I'm running through windows 7 64 bits with teradata tools version 13.10]

Appreciate any help!
Thanks in advanced.

Re.Furlan 3 posts Joined 08/11
15 Aug 2011

I figure out i need to install a version 64bits of Teradata Tools, but it's not free to download, only the 32bits version is available to download at Teradata website.
I reckon the 64bit version is only available when you buy the database.
Since I'm only studing the Teradata database I'm not able to have it.
Any way I'm studing and doing all I need through fastload, fast export and multiload.

Thanks all that have read this post and tried to figure out.

manoj.d 2 posts Joined 12/10
24 Aug 2011

You can use the VMWare player to fiddle with the 32/64 bit system issue. I installed the demo version of teradata ( 32 bit ) on my 64 bit system using vmware player.

feinholz 1234 posts Joined 05/08
24 Aug 2011

TPT only runs in 32-bit mode. We do not have a 64-bit version of TPT.
So trying to install a 64-bit version of Teradata Tools will not work.
Checking with development, it looks like the Wizard is only supported with JRE 1.4 and 1.5.
It looks like the problem above is from using 1.6.
Try JRE 1.5 and see if the issue is solved.
(And yes, it looks like we did not document this, and so we need to fix this.)

--SteveF

TDMerle 2 posts Joined 06/11
16 Oct 2011

Had the same problem.  In my case I was able to get it to work using JRE 1.6 given a workaround provided by Teradata support. 

jwh_ws 15 posts Joined 04/11
18 Oct 2011

There are several coding errors in the Wizard that need to be fixed for it to work.  I just uninstalled 13.10 for 14.0 and my tweaked version was removed in the uninstall or I'd post it.

fnylin 2 posts Joined 12/11
18 Jan 2012

Hi,

I have installed TTU TPT 13.10.02 on a Windows 2003 64 bit server.

 

Atfer reading the above I get a bit concerned and have a few questions.

A) "TPT only runs in 32-bit mode. We do not have a 64-bit version of TPT"

B) "Checking with development, it looks like the Wizard is only supported with JRE 1.4 and 1.5."
 

1) Is it supported running TPT on a 64 bit platform?

2) Which Java versions are supported? Is 1.6 supported?

3) Should Java be 32 or 64 bit?

 

Thanks

Frans

 

 

 

 

feinholz 1234 posts Joined 05/08
18 Jan 2012

A) "TPT only runs in 32-bit mode. We do not have a 64-bit version of TPT"

B) "Checking with development, it looks like the Wizard is only supported with JRE 1.4 and 1.5."

Since TPT only runs in 32-bit mode, all dependent products must also be 32-bit.

 

--SteveF

strattok 10 posts Joined 10/09
16 Apr 2012

How do we point the Wizard at the JRE 1.5 environment.  I still need all my other applications to use JDK 6.x.

28 Mar 2013

 Dear,I have exactly the same issue as described above (01 Aug 2011) Any tips to resolve this ? or what exactly I should check ?
Thx Ludo
 

victoriniguez 2 posts Joined 07/11
22 May 2013

Is there a TPT for 64 version now?

optum

TonyL 20 posts Joined 12/09
23 May 2013

There is no 64-bit TPT version on Windows yet.

saraider99 8 posts Joined 05/12
26 Sep 2013

Does anyone know what folders and permissions need to be corrected before the wizard can run successfully?

saraider99 8 posts Joined 05/12
26 Sep 2013

I figured it out by giving full control to EVERYONE to the "C:\Program Files (x86)\Teradata\Client\14.10\Teradata Parallel Transporter" folder. Once i granted full control everything worked fine.

N_Raghu 34 posts Joined 12/13
11 Feb 2014

My issue is also resolved after granting admin access to 
C:\Program Files\Teradata\Client\14.10\Teradata Parallel Transporter\
Thank You Guys

-Raghu

SmarakDas 51 posts Joined 02/12
22 May 2014

Hello All,
 
I have Teradata 14 Version Server (VMWare) & 13.10 Client Version installed. I am getting the exact same error for mentioned by Furlan and I do have a 64-bit OS. 
 
My Questions:
(a) Is it possible to run TPT 13.10 with the error mentioned. Also, I tried giving all permission to the folder, but didn't work.
(b) It will help installing Teradata Client Version 14  also ?
 
Thanks,
Smarak
 

doognek 1 post Joined 03/10
02 Apr 2015

It is simply an issue with the TPT Wizard trying to use the 64-bit instead of the 32-bit Java client. Edit the tptwizard.cmd and add a path to the beginning of PATH environment variable to point to the 32-bit Java bin directory first instead of the 64-bit client:
 @Echo off
[cut]
set PATH=C:\Program Files (x86)\Java\jre1.8.0_31\bin;%PATH%
set TPT_MIN_JAVA_VERSION=1.4.2_06
[cut]
Save the tptwizard.cmd file and TPT Wizard will load when you try it again.

 

You must sign in to leave a comment.