All Forums Tools
nikhilaggarwal 7 posts Joined 03/12
01 Mar 2013
SQL Assistant - Not able to Define ODBC Data Source through Teradata SQL Assistant v 13.11.0.04

I am unable to Define ODBC Data Source in Teradata Sql Assistant.
When I was using Windows xp it was working fine but after i switched to Windows 7 32 bit , I am facing this error.
It show me the following error prompt :
 
File Not Found
Unexpected Error . Refer to the following file for details :
c:\Users\MYUSERNAME\AppData\Roaming\Teradata\SQL Assistant\SQLAError.txt 
 
When I opened this txt file I found following contents in it : 
 

2/27/2013 4:14:19 PM

SQLA Version: 13.11.0.4

Driver Version: ODBC 13.10.00.07

System.Exception: Exception handled in FpSpread.WndProc ---> System.NullReferenceException: Object reference not set to an instance of an object.

   at FarPoint.Win.Spread.SpreadView.a(Int32 A_0, MouseEventArgs A_1)

   at FarPoint.Win.Spread.SpreadView.g(MouseEventArgs A_0)

   at FarPoint.Win.Spread.FpSpread.OnMouseDown(MouseEventArg s e)

   at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)

   at System.Windows.Forms.Control.WndProc(Message& m)

   at FarPoint.Win.Spread.FpSpread.WndProc(Message& m)

   --- End of inner exception stack trace ---

   at FarPoint.Win.Spread.FpSpread.WndProc(Message& m)

   at System.Windows.Forms.Control.ControlNativeWindow.OnMes sage(Message& m)

   at System.Windows.Forms.Control.ControlNativeWindow.WndPr oc(Message& m)

   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

****************************************************** *

2/27/2013 4:31:24 PM

SQLA Version: 13.11.0.4

Driver Version: ODBC 13.10.00.07

System.IO.FileNotFoundException: File not found.

   at Microsoft.VisualBasic.Interaction.Shell(String PathName, AppWinStyle Style, Boolean Wait, Int32 Timeout)

   at Teradata.SQLA.MainFrm.ToolbarMgr_ToolClick(Object sender, ToolClickEventArgs e) in F:\ttu1311_efix_snap\tdcli\qman\sqla\MainFrm.vb:line 823

****************************************************** *

 

 

 

 

Can anyone help me please how to resolve this problem.

I am currently using odbcad32.exe file to define my ODBC Data Source.

Adeel Chaudhry 773 posts Joined 04/08
02 Mar 2013

Can you try re-installing ODBC driver?

-- If you are stuck at something .... consider it an opportunity to think anew.

nikhilaggarwal 7 posts Joined 03/12
02 Mar 2013

yes I did that , but still getting the same error. Even after formatting of windows i am facing the same issue.

Adeel Chaudhry 773 posts Joined 04/08
03 Mar 2013

Can you share more details .... like if you are using VMWare, or its a local server or on a network .... etc?

-- If you are stuck at something .... consider it an opportunity to think anew.

MikeDempsey 94 posts Joined 10/06
04 Mar 2013

I know there is a problem with Windows 8 and the VB6 Shell command (Teradata Administrator uses VB6) but I wasn't aware that there was any problem with Windows 7, or .Net.

I could maybe undestand if it got confused on a 64bit system but you say yours is 32bit.
Do you have Teradata Administrator? If so could you please try defining an ODBC DSN through its File, Define Data Source menu. Does that one work?
Please email reply to mike.dempsey@Teradata.com

Thanks

nikhilaggarwal 7 posts Joined 03/12
05 Mar 2013

No , i am not using VMWare . I installed it on my system.

nikhilaggarwal 7 posts Joined 03/12
05 Mar 2013

and I dont have Teradata Administrator .

gryback 271 posts Joined 12/08
05 Mar 2013

I think you should submit a GSC incident at this point for further analysis and resolution.

Kawish_Siddiqui 37 posts Joined 03/07
26 Mar 2013

Have you tried connecting SQLA using Teradata .Net Provider? Is that working? I remember I faced similar issue and the only workaround at that I found was to use .Net Provider connection instead of ODBC.

Kawish Siddiqui -

balu_td 22 posts Joined 03/13
29 Jan 2014

@kawish
Do i need to Uninstall the .Net provider and then Install it again.. or I can just Install it ..

You must sign in to leave a comment.