All Forums Tools
pcapazzi 2 posts Joined 02/13
27 Jun 2014
SQL Assistant Import Data function giving DDL errors

I've recently upgraded to SQL Assistant v14.0. In v13.10 I had no trouble running the following query (statement by statment). Now I'm having trouble because I get an error that says "Error executing query for record 1: 3706: Syntax error: expected something between ')' and the integer '1'.
Here is the sql:

drop table tempdb.pc_testimport;


create table tempdb.pc_testimport

(TestKey varchar(12), TestS int, TestPriority int);


insert into tempdb.pc_comp_res_close_cbg



Here are lines from the input file:

482013113003 482 1

482013113002 482 1

482013115002 482 1


Although there are spaces showing between the values it's actually tab delimited. I checked the Import/Export settings and Tab as a delimiter is set. I also verified that the option to submit only the highlighted text is set as well. 


To me, it seem as if it's try to execute the import file rather than reading from it. Any advice regaridng this would be greatly appreciated. 





AEReeves 1 post Joined 06/14
30 Jun 2014

Hi Peter,
I was just having the same issue and even tried the option to enclose column data in single/double quotes and neither worked.  I had just imported the file 15 mins earlier but noticed a small error so I dropped it and tried to reload but kept getting this error.
Eventually I was able to solve it by moving the "Insert" statement into a new query window "Ctrl + N".  Apparently SQLA doesn't like having the Import statement mixed in with other SQL statements even if you have "submit only the highlighted text" option set.  The first time I had imported it was in a different window then I moved it over to one with other statements and kept getting errors.  Once I moved it back into it's own window it ran perfectly fine.  Not sure why this happens, must be something related to the way it functions when set to Import mode.
Hope this helps.

Agilan 1 post Joined 04/13
23 Apr 2015

Hi All,
I have faced similar kind of error.
While importing data from SQL Assistance, RDBS error has been encountered.
Error:- Error executing query for record 1: 3706:  Syntax error: expected something between ')' and
But when i opened new window and ran the same import statement, it went fine. 
Can anyone have an idea on this?

You must sign in to leave a comment.