All Forums Tools
31_resu 38 posts Joined 07/13
01 Sep 2016
SQL Assistant 15.00 TD Doesn't Properly read first Parameter Key

Hi TD Forum,
I am running on TD Ver 14, and have SQL Assistant 15.00, and when I run a query that has a prompt for two dates to be inout bythe user, the paramter promts of something like:
where date_col between '?date1' and '?date2'
The 2nd date prompt is read, but the 1st one is not and always errors (it even highlights oddly), I have to hard code to get around. I try to re-type it in case a strange font is not being recognized, but nothing works.
In my SQLA Tools, Options, Query, I have the 'Allow Named Paramters' checked.
Any work arounds for this issue?

31_resu 38 posts Joined 07/13
08 Sep 2016

Bump - No one has seen or heard of this?  Update, seems to random, some queires it not an issue, others it is. I have tried things like retype it, but also copy/pate into Notepad to strip off any weirdness, and then copy/paste back, plus doing that in Word and giving it a generic standard font, but that doesn't get around SQLA not reading the prompt correctly.

Fred 1096 posts Joined 08/04
08 Sep 2016

Which patch level of SQL Assistant? There was a fix related to quoted named parameters included in

You must sign in to leave a comment.