All Forums Tools
JustMe 76 posts Joined 03/07
12 Sep 2012
Special Characters in Columnnames in FastExport

I have a table with a couple of fields that contain '$_37'.  FastExport is dropping the '$_' and replacing it with nothing.  So, during the execution of the FastExport, a 'field not found on database' error.   I recreated the table and removed the underscore so the columnname contained '$37'.  Now it seems as if FastExport drops the $ and the character immediately following.

Is FastExport not able to recognize the '$' in column names?

feinholz 1234 posts Joined 05/08
12 Sep 2012

I just tried created a table with a CHAR(10) column and populated it with the string "$_abc".

I then exported the data from that table to a file and the contents of that column were written to the file correctly.

The "$_" were not removed.

In general FastExport does not look at the data.

It issues the SELECT statement to the DBS, retrieves the data and writes out what it receives to the file.

Thus, in order to better help you, I would need to see the script, a sample of the data, and the resulting data file.



Qaisar Kiani 337 posts Joined 11/05
13 Sep 2012

I tried by creating a table with columnname '$_id', and inserted couple of rows in the table.

The fastexport script to export the content of the table was executed succesfully without any issue. All the data was exported to the file.

Even if the column contains the data something like '$_132' - the script runs fine without any error.

Not sure why you are getting the error!

Howerver, as suggested by fwinholz, share the script - DDLs and sample data to see the exact issue.


You must sign in to leave a comment.