All Forums Tools
mtlrsk 30 posts Joined 06/08
06 Nov 2008
Release Lock - LOAD Operator - TPT

Hi All,I am running a TPT script using LOAD Operator.My Job has failed and my target table is in Fastload Paused State.2652 -- Operation not allowed , table is being loaded.Is thier any way i can realease the lock from this table using TPT as we do in Fastload.?In Fastload we submit -- Begin loading .... end loading;Please can anyone advise if any such way in TPT as well..Regards,MTLRSK...

mtlrsk 30 posts Joined 06/08
13 Nov 2008

Hi ,Can any one advise if it is possible to release LOAD operator locks in TPTthe way we do in Fastload.Begin Loading ...End LoadingRegards,mtlrsk.

rgs 106 posts Joined 02/07
13 Nov 2008

It sounds like you have been playing around with your demo system (from previous post). I think it is your fastload job that did not end. TPT does not place any locks like that. But it won’t insert into a table that has a fastload lock. So you need to fix up your fastload job first and then you can restart your TPT job.

mtlrsk 30 posts Joined 06/08
13 Nov 2008

Hi Rgs,I am not running any fastload jobs, nor my any of the previous fastload job is in abend.I have a tpt script in which i have a load operator , and it has failed in the middle .Now it tell 2652 - Operation not allowed , table is being loaded.Please advise.Rgds,mtlrsk.

rgs 106 posts Joined 02/07
14 Nov 2008

Yes, it failed in the middle because your table is in a Fastload state. You have to finish the Fastload job first (read the manual). The whole point of TPT is to place ordinary locks so that you can be doing other things with the table. But if you run TPT while it is in a Fastload mode you will get that error. Try just a regular update to a row in that table and you will see that you get the same message. From the message manual: 2652 Operation not allowed: %DBID.%TVMID isbeing Loaded.Explanation: This error occurs only when a userissues a request for a table that is being Fast/MultiLoaded.Generated By: AMP Steps.For Whom: End User.Notes: The table does exist, but it is not in a form inwhich it may be accessed.Remedy: Wait until the Fast/Multi Load is finished,then resubmit the request.

Fred 1096 posts Joined 08/04
15 Nov 2008

Use the same LOAD definition but change the data producer (e.g. Data Connector operator) to send an empty file to the LOAD operator.

lazycat 3 posts Joined 05/10
26 May 2010

Hi, I have the same error if I disconnect the network. I need to move 9 Tera one huge table. My aim is to proove that it can handle any kind of failure nefore I start to move it. RDBMS, connection lose, run out of room, etc.
How can I restart an EXPORT - LOAD operator TPT which failed in the middle. I didn't delete the error tables, checkpoint file, etc.

How can I restart it to avoid to run the all again from the begining?

feinholz 1234 posts Joined 05/08
02 Jul 2010

The Load operator in TPT works the exact same way as FastLoad, and TPT can recover from the same errors as FastLoad, in the same fashion.

When there is an error and you do not want to, or cannot, restart the job, and you want to issue the BEGIN LOADING and END LOADING commands like FastLoad, there are 2 choices:

1. have the DataConnector operator process an empty file
2. beginning in TPT 13.10 the Load operator has been enhanced (and the script language enhanced too) to be able to send just the BEGIN LOADING and END LOADING without the need to process any files. Refer to the TPT Reference manual (13.10) for details.


rahul.nityanand 2 posts Joined 04/11
06 Apr 2011


Even I am facing the problem that "mtlrsk" has mentioned.

I have an emplty table which I load using the TPT load operator. The input file to TPT is supposed to have 'X' columns but in some case, there might me 'X+1' or 'X-1' column. In such case, TPT fails and also locks the table. Now when I try to run a simple select on the table, I get the error --- '2652 -- Operation not allowed , table is being loaded.'

One method to release the lock on the table is to fix the error in the file and rerun TPT with the fixed file as the input. TPT will continue loading from where it left off (the log table that TPT load operator creates is for this reason).

I am trying to find a way that TPT ignores the rows with errors (puts them in a seperate table) in the file and load the rest of the data and release the locks on the table. I would appreciate if anyone could help me with this.

feinholz 1234 posts Joined 05/08
13 Apr 2011

What version of TPT are you using?
What record format are you using? Delimited?
If you are using delimited, I believe the DataConnector operator (the file reader) has an attribute called RowErrFileName. Provide a file name and the error rows will be placed into that file. I believe if you specify that attribute and provide a file name, then the DC operator will not terminate with an error, but would continue the job.
In TTU14.0, we are adding features that would allow for "short" rows to be extended out (padd with NULL fields) and "long" rows (truncate extra fields), but this RowErrFileName feature should work for you.


BLaughner 10 posts Joined 08/11
27 Aug 2011

To recover from a TPT Update operator that failed in acquisition phase can I simply use an empty file to fool into thinking it loaded fine?


feinholz 1234 posts Joined 05/08
31 Aug 2011

I suppose it depends on the reason for the original failure.


ftshtl 3 posts Joined 10/11
27 Feb 2013

I got this error too when used TPT load table.
2652 -- Operation not allowed , gdev1t_stg.stg_custis being loaded.
I run below script to fix this error used Fastload tool:

LOGON hostname/usr,pwd ;

DROP TABLE gdev1t_stg.stg_cust ;

DROP TABLE gdev1t_wrk.stg_cust_et ;

DROP TABLE gdev1t_wrk.stg_cust_uv ;



You must sign in to leave a comment.