All Forums Tools
Prashant_20986 6 posts Joined 03/16
10 Mar 2016
Receive an error message while trying to use fast load

Hi, I receive error message 8017: The UserId, Password or account is invalid while trying to load data using fast load. All the files are saved in Desktop.
 
********** Fast Load Script**************
 

logon 10.61.59.93/796207,Wpwp123;

 

drop table DATAMDL_SNDBX.QA_FL_PD;

drop table DATAMDL_SNDBX.ERROR_TABLE_ucv;

drop table DATAMDL_SNDBX.ERROR_TABLE_TV;

 

CREATE SET TABLE DATAMDL_SNDBX.QA_FL_PD ,NO FALLBACK ,

     NO BEFORE JOURNAL,

     NO AFTER JOURNAL,

     CHECKSUM = DEFAULT,

     DEFAULT MERGEBLOCKRATIO

     (

      NAME VARCHAR(10) CHARACTER SET LATIN NOT CASESPECIFIC,

      INITIAL VARCHAR(10) CHARACTER SET LATIN NOT CASESPECIFIC)

PRIMARY INDEX CRO_FLIGHT_LEG_DEP_NUPI ( NAME );

 

SET RECORD VARTEXT'~';

 

DEFINE

NAME (VARCHAR(10)),

INITIAL (VARCHAR(10))

 

FILE = C:\Users\Scarlet\Desktop\FL_Data.TXT;

 

BEGIN LOADING DATAMDL_SNDBX.QA_FL_PD ERRORFILES teradata fastload.ERROR_TABLE_UCV, teradata fastload.ERROR_TABLE_TV;

 

INSERT INTO DATAMDL_SNDBX.QA_FL_PD

VALUES (:NAME,

        :INITIAL);

 

END LOADING;

LOGOFF;

 

*******End of fast load script***********

 

********File containing data (with only 1 record)**********

NAME~INITIAL

PRASHANT~PD

 

 

 

 

**********Error Message****************

 

 

C:\Windows\system32>cd\

 

C:\>fastload<C:\Users\Scarlet\Desktop\FL_Script.TXT

     ====================================================== =============

     =                                                                 =

     =          FASTLOAD UTILITY     VERSION 14.10.00.03               =

     =          PLATFORM WIN32                                         =

     =                                                                 =

     ====================================================== =============

 

     ====================================================== =============

     =                                                                 =

     =          Copyright 1984-2013, Teradata Corporation.             =

     =          ALL RIGHTS RESERVED.                                   =

     =                                                                 =

     ====================================================== =============

 

**** 14:08:03 Processing starting at: Thu Mar 10 14:08:02 2016

 

     ====================================================== =============

     =                                                                 =

     =          Logon/Connection                                       =

     =                                                                 =

     ====================================================== =============

 

0001 logon 10.61.59.93/796207,

 

**** 14:08:03 RDBMS error 8017: The UserId, Password or Account is

              invalid.

**** 14:08:03 Unable to log on Main SQL Session

**** 14:08:03 FastLoad cannot continue. Exiting.

     ====================================================== =============

     =                                                                 =

     =          Exiting                                                =

     =                                                                 =

     ====================================================== =============

 

**** 14:08:03 Total processor time used = '0.124801 Seconds'

     .        Start : Thu Mar 10 14:08:02 2016

     .        End   : Thu Mar 10 14:08:03 2016

     .        Highest return code encountered = '12'.

**** 14:08:03 FDL4818 FastLoad Terminated

 

C:\>

 

feinholz 1234 posts Joined 05/08
11 Mar 2016

The error explains the problem.
The logon credentials are not correct.
Can you connect to the DBS using BTEQ and those same credentials?
 

--SteveF

ranganna 4 posts Joined 10/15
13 Mar 2016

Hi Prashant,
Please use .  (dot)  before login  i.e 
.logon 10.61.59.93/796207,Wpwp123;
Also check once Username and Password.
Let me know if you facing any issue.

sgarlapa 88 posts Joined 03/13
13 Mar 2016

. (dot) not manditory in fastload. But it is a good practice to keep the dot.
I think you need to check two things.
1) ping the server from your command prompt and see if the server is up or not
  c:\> ping 10.61.59.93
Check the response. if it reply with the packets then good.
2) check your user id through bteq interactive login and verify the credentials
  c:\> bteq
    .logon 10.61.59.93/796207   (type enter)
    password: Wpwp123   (invisible for you. buy type the password and press enter)
Verify if it logs in.  Need to confirm your userid has no problems here and proeed for fasltoad .

Prashant_20986 6 posts Joined 03/16
14 Mar 2016

Hi, 
Credentials are correct. The problem was, I should have mentioned what mechanism I should be using to connect.
Adding below line at the top solved my problem
logmech LDAP;   
Problem solved.. :)
I do not know how to close this.
 
Thanks
Prashant

You must sign in to leave a comment.