All Forums Tools
lucasfilm 10 posts Joined 05/09
26 Apr 2010
Macro problem in SQL Assistant 13.0

I tried out the Macro possibilities inside SQL Assistant. Unfortunately I saved it to the Letter "A". So now the Macro is run everey time I hit this character... Does anyone know how to delete a recorded Macro inside SQL Assistant?

lucasfilm 10 posts Joined 05/09
27 Aug 2010

Teradata says:
For SQLA 13.0 it would be better to delete the entire: HKEY_CURRENT_USER\Software\Teradata\SQLA_CM key from the registry - not just the Macro0 entry. (At a minimum you must delete both the Macro0 and HotKeys values from this key)

For SQLA 12.0 you should delete both the Macro1 and Hotkeys values from:
HKEY_CURRENT_USER\Software\WinMain\CodeMax Editor

In both cases you must delete the key/value while SQL Assistant is not open. If SQLA is open it will simply re-write the macros to the registry when you close the app.

sv185031 3 posts Joined 03/11
23 Mar 2011

Please close the SQL Assistant window and open a new window. This should slove the Problem.

soumyasin 2 posts Joined 11/11
05 Mar 2012

I encountered this problem recently and let me tell you it is hell annoying.

Nothing will work - restarting machine, software. TSA.

It is more annoying if you are working on client network and you do not have any idea how to enable Registry Editor or even CMD.

I worked it out in a silly way.

Try to record a macro and press the exact key to which your macro is saved.

Let's say you have a macro in the name of A. so record a macro by putting A in the text box. and override it with the existing A macro when it prompts for saving.

That way, when you press A, a macro will only play. e.g. a but it will type only A. so your purpose is served.

It is not a permanent solution but handy till someone complains. And who will anyway? :P

- Soumya

- Regards

Soumya

khan538 1 post Joined 07/12
26 Jul 2012

Let's say you have a macro in the name of A. so record a macro by putting A in the text box. and override it with the existing A macro when it prompts for saving.

That way, when you press A, a macro will only play. e.g. a but it will type only A. so your purpose is served.

I tried this and it does not work as when I press the L key which is what my macro is saved to it gives me a space. Any other way of getting rid of this stupid macro?

 

Thanks,

 

Khan538

MikeDempsey 94 posts Joined 10/06
27 Jul 2012

If you are using SQL Assistant 13.11 or higher there is a new tool button that will allow you to delete macros.

If you are using an older version the only way to delete them is to delete the string values 'HotKeys' and 'Macro0' from the registry key:
    HKEY_CURRENT_USER\Software\Teradata\SQLA_CM
(Also delete 'Macro1', 'Macro2', etc. if they exist.)
You must do this when SQL Assistant is NOT open.

If you can not edit your registry the only alternatives are to either have your IT group delete the registry keys for you, or as someone suggested, re-record the macro to type only the key that you used as the hot key.

kurtwz 1 post Joined 06/12
25 Mar 2013

For SQLA 12.0 you should delete both the Macro1 and Hotkeys values from:
HKEY_CURRENT_USER\Software\WinMain\CodeMax Editor

I searched my c-drive for "codemax" and found a file called cmax40.dll.  Is that the file I need to edit?  If so, could you tell me how to edit it?  I opened that file in notepad and searched for "macro" and found several strings including this one:
0]+cmCmdPlayMacro1Wd   \   0^+cmCmdPlayMacro2Wd   ÿÿÿÿ0_+cmCmdPlayMacro3Wd   <  0`+cmCmdPlayMacro4Wd  
  0a+cmCmdPlayMacro5Wd   ÿÿÿÿ0b+cmCmdPlayMacro6Wd   ÿÿÿÿ0c+cmCmdPlayMacro7Wd   ÿÿÿÿ0d+cmCmdPlayMacro8Wd     0e+cmCmdPlayMacro9Wd   <  0…ScmCmdPlayMacro10d
Is that what I need to edit?  If so, how do I do that?
Sorry if I'm TOTALLY on the wrong track here!!  I'm new to SQL :-S       Thanks!!
 

gtmmaj 4 posts Joined 09/15
10 Sep 2015

"Let's say you have a macro in the name of A. so record a macro by putting A in the text box. and override it with the existing A macro when it prompts for saving.
That way, when you press A, a macro will only play. e.g. a but it will type only A. so your purpose is served." - worked fine for me.

Ranjanj4 1 post Joined 06/16
16 Jun 2016

@soumyasin.. thankyou so much .. its working now .. great work :)

You must sign in to leave a comment.