All Forums Tools
sanjay_hyd 6 posts Joined 03/09
15 Sep 2009
Fastload error-Kindly Help!!

Hi Teradata Gurus!I am using Teradata Fastload utility to load data from a file to table. The table is being loaded successfully with all the data in file. But returning the following error: Highest return code encountered = '4'.Kindly Help!!For further information..please follow the loader log details below:**** 18:50:55 Processing starting at: Fri Sep 11 18:50:55 2009 ====================================================== ============= = = = Logon/Connection = = = ====================================================== =============0001 .logon USER_ID/PASSWD,**** 18:50:55 Teradata Database Release: V2R.06.02.02.76**** 18:50:55 Teradata Database Version: 06.02.02.76c**** 18:50:55 Current CLI or RDBMS allows maximum row size: 64K**** 18:50:55 Character set for this job: ASCII**** 18:53:09 CLI Error 301: CLI2: SESSOVER(301): Exceeded max number of sessions allowed.**** 18:53:12 Number of FastLoad sessions connected = 298**** 18:53:12 FDL4808 LOGON successful0002 DROP TABLE utlty_c.Table1 ;**** 18:53:12 RDBMS error 3807: Object 'utlty_c.UV_Table' does not exist.0003 DROP TABLE utlty_c.ET_Table ;**** 18:53:12 RDBMS error 3807: Object 'utlty_c.ETTable' does not exist.0004 DELETE FROM table_name ;**** 18:53:15 Command completed successfully0005 set record unformatted;**** 18:53:15 Now set to read 'UNFORMATTED' records**** 18:53:15 Command completed successfully0006 define File Lay_out file=file_name; **** 18:53:15 FDL4803 DEFINE statement processed0007 show; FILE = file_name description of field_name1 description of field_name2... TOTAL RECORD LENGTH = 3450008 begin loading table_name errorfiles utlty_c.ET_Table, utility.UV_table checkpoint 0 ;**** 18:53:33 Number of AMPs available: 384**** 18:53:33 BEGIN LOADING COMPLETE ====================================================== ============= = = = Insert Phase = = = ====================================================== =============0009 insert into table_name ( field_names ) values ( ) ;**** 18:53:37 Number of recs/msg: 182**** 18:53:37 Starting to send to RDBMS with record 1**** 18:53:38 Starting row 100000**** 18:53:38 Starting row 200000**** 18:53:38 Starting row 300000**** 18:53:39 Starting row 400000**** 18:53:39 Starting row 500000**** 18:53:40 Starting row 600000**** 18:53:40 Starting row 700000**** 18:53:40 Starting row 800000**** 18:53:41 Starting row 900000**** 18:53:41 Starting row 1000000**** 18:53:42 Starting row 1100000**** 18:53:42 Starting row 1200000**** 18:53:43 Starting row 1300000**** 18:53:43 Starting row 1400000**** 18:53:43 Starting row 1500000**** 18:53:44 Starting row 1600000**** 18:53:44 Sending row 1668271**** 18:53:48 Finished sending rows to the RDBMS ====================================================== ============= = = = End Loading Phase = = = ====================================================== =============0010 end loading;**** 18:53:51 END LOADING COMPLETE Total Records Read = 1668271 Total Error Table 1 = 0 ---- Table has been dropped Total Error Table 2 = 0 ---- Table has been dropped Total Inserts Applied = 1668271 Total Duplicate Rows = 0 Start: Fri Sep 11 18:53:49 2009 End : Fri Sep 11 18:53:51 20090011 logoff; ====================================================== ============= = = = Logoff/Disconnect = = = ====================================================== =============**** 18:53:58 Logging off all sessions**** 18:54:38 Total processor time used = '11.2335 Seconds' . Start : Fri Sep 11 18:50:55 2009 . End : Fri Sep 11 18:54:38 2009 . Highest return code encountered = '4'.**** 18:54:38 FDL4818 FastLoad Terminated

Jimm 298 posts Joined 09/07
15 Sep 2009

When the fastload tried to logon, there were too many sessions already logged onto the Teradata. So it logged on as many as it could and ran with this.If no sessions is specified, it will try to go with one session per AMP. On a medium - large system, this is usually too many. For the number of records you loaded, I would go with roughly one session for every two AMPS.Give it a SESSION command to improve setup time in your Fastload, and so you do not impact anyone else trying to Fastload at the same time.This was only a warning - your job ran correctly. Return code 4 is always a warning.

sanjay_hyd 6 posts Joined 03/09
15 Sep 2009

Hi Jim!Thanks for your reply!Actually we are calling this script through a command task in a workflow on Informatica. This workflow is getting failed every time due to this issue. we are trying to eliminate this error so that the workflow runs smooth.Kindly suggest us what to do to stop this error.

Jimm 298 posts Joined 09/07
15 Sep 2009

Take a look at chapter 2 in the Fastload reference manual.You can set up a config file floadcfg.dat with a minimum and maximum number of sessions. Set the max to 50% of the number of AMPS and the min to 25% (but you may need to tune these!)The load should then run OK, without the need to tune individual loads in Informatica.If you have the maximum number of utility jobs set to 15 ("normal" max), you should have the maximum number of sessions on your system set to at least 8 times the number of AMPS. If 15 loads run simultaneously, each with half the AMPS, then they will all run clean. (If you exceed the 15th load, it goes into sleep mode until there is a slot free and the load will run clean eventually.There is probably a way to get Informatica to include a SESSIONS command - see your Informatica support, or maybe there is an Informatica guru out there!

sanjay_hyd 6 posts Joined 03/09
15 Sep 2009

Thanks a lot Jim!I am working on that. Once done I will get back to you.

super25 19 posts Joined 07/11
30 Apr 2012

How can i find maximum allowed sessions on my system. If a fload script doies not mention session number how many sessions it would take to run the load on a 12 node system.

feinholz 1234 posts Joined 05/08
07 May 2012

If you do not provide a session number, then FastLoad will connect one session per available AMP on the system.

--SteveF

Biswa2970 1 post Joined 01/13
17 Apr 2015

Hi all,
I am trying to load a table using FastLoad but my script is halting at the "BEGIN LOADING" step.
Below is a snashot from the log.
Can anybody please suggest what could be the issue? I thought it could be some issue with the versions and I upgraded all TTU clients to 14.10 but still this issue persists!
 
Thanks
Biswa

feinholz 1234 posts Joined 05/08
17 Apr 2015

There is no snapshot visible.
Please cut and paste the information.
 

--SteveF

You must sign in to leave a comment.