All Forums Tools
ayes 24 posts Joined 02/06
19 May 2008

The OUTMOD routine keeps failing with a SOC 4 error with following details. The COBOL program where abend happened is at the below statement part of section “TYPE-3”MOVE OUTPUT-RECORD TO OUT-DATA-AREA. Now, if I insert open statement on the file in this section and try to run it, it runs fine, implying that somehow during the “ENTRY-TYPE” = 1 step the file opened by this module is getting closed before it enters the ENTRY-TYPE=3 step. Could you anyone tell me if I am missing any thing very basic here? Many thanks in advance. The things that were tried are as below. 1. The Cobol program was amended to just display the received record in the section “TYPE-3” and the module executed without any errors. 2. In the Fast export only “EXPORT OUTMOD VP51021E MODE RECORD;” statement was used and still the same error was received. CAIPRINT ERROR **************************** * * S-0C4 * * A B E N D *------------* * * VP51021S * **************************** ****************************************************** *************************** DESCRIPTION: S0C4 - AN INVALID MACHINE ADDRESS WAS CALCULATED * BY THE PROGRAM. * * PROBABLE CAUSES: 1. A SUBSCRIPT OR INDEX CONTAINED AN INVALID VALUE. * 2. A JCL DD STATEMENT WAS EITHER INVALID OR MISSING. * 3. THE BLOCKSIZE AND RECORD SIZE WERE SPECIFIED AS EQUAL * FOR VARIABLE LENGTH RECORDS. * 4. AN ATTEMPT WAS MADE TO READ/WRITE AN UNOPENED DATA SET.* 5. AN ATTEMPT WAS MADE TO READ AFTER END-OF-FILE. * 6. A STOP RUN OCCURRED: * A. BEFORE ALL OPENED DATA SETS WERE CLOSED. * B. IN THE INPUT OR OUTPUT PROCEDURE OF A SORT. * 7. AN ATTEMPT WAS MADE TO REFERENCE AN INPUT/OUTPUT AREA * BUT NO OPEN OR READ HAD OCCURRED FOR THE DATA SET. * 8. INVALID PARAMETERS WERE PASSED THROUGH THE LINKAGE SECT* 9. THE FILE-CONTROL SELECT CLAUSE WAS MISSING * FOR THE DATA SET THAT WAS BEING PROCESSED. ****************************************************** **************************CAPD112W SYMBOLIC INFORMATION NOT FOUND FOR PROGRAM "VP51021S". ITEM: BLW 000 DISP 0004F0 ABENDING INSTRUCTION D2FF 7000 54F0 MOVE JCL://VP5102P1 EXEC PGM=XPORT,PARM='MAXSESS=40' //STEPLIB DD DSN=TERADATA.&TDP..LOAD,DISP=SHR // DD DSN=G774800.CCTM.BUILD.LOAD,DISP=SHR// DD DSN=SYS1.SCEERUN,DISP=SHR // DD DSN=SYSTEM.LIB.JOBLIB,DISP=SHR //SYSPRINT DD SYSOUT=* //SYSOUT DD SYSOUT=* //SYSABEND DD SYSOUT=* //SYSIN DD DSN=&LHLQ..DATALIB(&LOGON),DISP=SHR // DD DSN=&DYNCNFL,DISP=SHR //** FAST OUT IS FIXED BYTE PS OF LENGTH 696//FASTOUT DD DSN=G774800.CCTM.BUILD.OUTPUT.TEST, // DISP=SHR FAST EXPORT:.LOGTABLE CCTM_DEV.CCTM_CUSTEX_LG; .BEGIN EXPORT; .EXPORT OUTFILE FASTOUT OUTMOD VP51021E MODE RECORD ; SELECT * FROM CCTM_DEV.CUST_HEADER_DETAILS; SELECT * FROM CCTM_DEV.V_CCTM_CUST_DELTA ; SELECT * FROM CCTM_DEV.CUST_TRAILER_DETAILS_DELTA; .END EXPORT; .LOGOFF; COBOL: PARAMETERS in the JCL FOR COBOL COMPILING 'APOST,OPT,LIB,NUM,LIST,NODECK'PARAMETERS in the JCL FOR COBOL LINKING// DD * MODE AMODE(24) RMODE(24) ENTRY VP51021S NAME VP51021E(R)

Fred 1096 posts Joined 08/04
19 May 2008

You need to set RTEREUS ("run time environment reuse") option, because the main program is non-COBOL and non-conforming. For example, link-edit with custom CEEUOPT.

You must sign in to leave a comment.