All Forums Tools
BkAZ 8 posts Joined 05/14
26 Aug 2014
Error Starting SQL Assistant v14.10.0.4

I cannot start SQL Assistant, and the error message is:

System.IO.DirectoryNotFoundException: Could not find special directory 'My Documents'.

 

I KNOW my My Documents folder is broken (was re-directed to a network share that is no longer available), but still need to be operational.
How can I "reset" SQL Assistant? or start it w/a different config, clean config, break it's need to find My Documents?

This seems pretty fragile...

nimish_123 15 posts Joined 08/14
27 Aug 2014

We have faced same issue many times and re installation helped us to fix the issue. I am not sure about the cause of issu.

nimish_123 15 posts Joined 08/14
19 Sep 2014

Write click on My documents folder > go to Properties > General tab > Clear check box for READ ONLY > click apply and OK > try to restart SQL assistant 

MikeDempsey 94 posts Joined 10/06
31 Oct 2014

If this still isn't fixed email me at mike.dempsey@Teradata.com.
It is actually a problem with your Windows setup rather than with SQL Assistant, but it is simply a matter of updating your registry to correct the pointer to 'My Documents'. (You will need admin rights to do it so you should probably contact your IT support folks.)

dc358w 1 post Joined 09/15
10 Mar 2016

I received the same error and tried the registry redirection and it works!  Checking the Read Only box does nothing for me.
Here is the reference link to redirecting your registry (essentially just change the HKEY_CURRENT_USER references):
http://answers.microsoft.com/en-us/windows/forum/windows_7-files/redirecting-the-target-of-my-documents-folder/83052359-37db-4500-9518-9ca49fb222dc?auth=1

nimish_123 15 posts Joined 08/14
06 May 2016

dc358w u need to uncheck, not check :)

You must sign in to leave a comment.