All Forums Tools
beargiles 2 posts Joined 05/16
14 Jul 2016
Error creating .genuine_TTU file on Ubuntu system

I'm trying to install the (Redhat) RPM files on my Ubuntu system. I tried using 'alien' to convert the .rpm to .deb files but, inexplicably, it refuses to convert a i386 package on a x64 platform. No matter - I can convert it to a .tgz file and install it manually.
I did that, updated ldconfig to point to the new libraries, etc., and tried running several apps. The apps complain that the .genuine_TTU file does not exist. When I create an empty one it says that it can't find a file that's present in the 'lib' directory.
Is there an easy way to create this file manually? To edit the script so it will create the file on an Ubuntu system?

beargiles 2 posts Joined 05/16
14 Jul 2016

I may have found it.
1. Create /opt/teradata/client/ttu_bash.env file and add one line: NLSPATH=/opt/teradata/client/15.10/lib
2. install and run bteq
I don't know if the key was the .env file, installing additional libraries for bteq, or the fact that bteq launched but the apps now run.

You must sign in to leave a comment.