All Forums Tools
tarunj25 1 post Joined 01/05
31 Jan 2005
Delimited fille using Fastexport

I need to create a delimited file using fastexport. As fast export do not support delimited format, so I have written the following select to get the delimited output:selecttrim(col1) || '|' ||trim(col2) || '|' ||trim(col3) || '|' || ..........................................trim(col50) from tablebut the above script prefix each line with 2 junk characters.I cannot cast the output as char(xxx) as it will increase the size of the output file. I tried using Vartext format in the script, but that too is not supported in the ttu7 version that I have. So I tried using the Outmod, but I am not sure how can I use outmod in teradata.Any kind of suggestions is highly appreciated.Thanks,Tarun

abhijitvyas 51 posts Joined 08/06
10 Oct 2006

Tarunhave u got any concrete solution to the Problem as i am also facing the similar Issue.. Exported file contains two byte of Junk character.. Is Vartext is supported in TTU V 8 and above ?? i am getting an internal error while running through vartext.. any help in that regard is highly appritiableRegardsAbhijit

Fred 1096 posts Joined 08/04
10 Oct 2006

FastExport does not support VARTEXT output. Depending on the size of the file, perhaps using some other utility or tool would work better for you.Or if you concatenate all the fields to a single delimited text string in FastExport (as in the original post in this thread) you can use a simple OUTMOD to strip the leading two-byte length field from each record.

You must sign in to leave a comment.