All Forums Tools
Diecorp 14 posts Joined 06/12
13 Jun 2012
Beginner TPT

Hi, I have a problem when I try to execute a TPT job in command line. The instruction is the following:

12074302@ard090funcap:/data/ds/dwhbar/etl/tmp>tbuild -f TPT_STATS_CLIENTE00.sh
Teradata Parallel Transporter Version 13.10.00.04
Job log: /opt/teradata/client/13.10/tbuild/logs/12074302- 26.out
Job id is 12074302-26, running on ard090funcap

The execution stopped here. I don't know when to see a Log.

Someone can help me??

 

 

feinholz 1234 posts Joined 05/08
13 Jun 2012

First of all, you should always upgrade to the latest and greatest patches.

Next, you need to provide the contents of TPT_STATS_CLIENTE00.sh.

The .out file is in the directory pointed to by $TWB_ROOT/logs.

You need to run the "tlogview" utility to view the contents of the log.

The best command to run is this:

    $ tlogview -l <logfile name> -f "*" -g

Redirect the output to a file and post the contents of that file.

--SteveF

Diecorp 14 posts Joined 06/12
15 Jun 2012

Thank u!

I read the log, the error is the following:

TPT_INFRA: TPT01514: Error: Unable to Open File. Error code 2, Reason code 530, Class code 501

No such file or directory

I have tried many times, but the error is the same. I don't know what can I do?

It isn't a problem with the TPT Installation?

The contents of the Script is the following:

DEFINE JOB Prototipo_125

DESCRIPTION 'Paso del Proceso de CLIENTE00 a TPT - Estadisticas y Borrado RJ'

(

/* ================================================================

Definición del Operador "Bteq"

================================================================ */

 

DEFINE OPERATOR BTEQ_OPERATOR

DESCRIPTION 'TERADATA PARALLEL TRANSPORTER DDL OPERATOR'

TYPE DDL

ATTRIBUTES

(

VARCHAR UserName = 'dbc',

VARCHAR UserPassword = 'dbc',

VARCHAR TdpId = 'TDDESA',

VARCHAR AccountID,

VARCHAR ErrorList = '3807' /* Ignore Error: Table not Found */

);

/* ====================================================================

Estadisticas de las Tablas Destino

==================================================================== */

STEP Bteq_Stats (

APPLY

('Delete PruebaDiego.PruebaT;')

TO OPERATOR ( BTEQ_OPERATOR );

);

);

feinholz 1234 posts Joined 05/08
15 Jun 2012

Yes, it might be an issue with the installation.

Can you post the contents of the directory pointed to by the $TWB_ROOT environment variable?

And make sure you have the proper access rights to the directories (especially the "logs" directory).

 

--SteveF

feinholz 1234 posts Joined 05/08
15 Jun 2012

Can you please provide the command you gave to tlogview?

This error:

 

TPT_INFRA: TPT01514: Error: Unable to Open File. Error code 2, Reason code 530, Class code 501

No such file or directory

 

means the log file was not found.

--SteveF

Diecorp 14 posts Joined 06/12
20 Jun 2012

Feinholz, hi:

TWB_ROOT=/opt/teradata/client/13.10/tbuild

and Yes, the user has access right to the directories, because when I execute the job, it modify the log in $TWB_ROOT/logs.

 

 

Command gave to tlogview:

tlogview -j TPT_STATS_DIEGO-1 -f "*" -g   (In a first question the name's job was 12074302, but modify it by TPT_STATS_DIEGO)

This is the Log:

Public log:

TPT_INFRA: TPT04101: Warning: TMSM failed to initialize
Teradata Parallel Transporter Coordinator Version 13.10.00.04
Teradata Parallel Transporter Executor Version 13.10.00.04

 

Private log PXCRM:

CheckPoint Resource Manager initialized.
Checking whether a valid CheckPoint exists for restart.

 

I'm not sure if TPT does not find the file Log or The Script. Really I don't know if this is error .

Thank you!

 

feinholz 1234 posts Joined 05/08
20 Jun 2012

We have never seen this issue before.

Might be a problem with the installation.

Try to install again, and please go to the patch server and download the latest and greatest patches to TPT 13.10.

 

--SteveF

ratchetandclank 49 posts Joined 01/08
22 Jun 2012

View the contents of the file $TWB_ROOT/twbcfg.ini. There are two entries in there. One is the checkpoint directory and another is the log directory. User should have permission to write in the directories mentioned in these entries. \

Example:

An ideal twbcfg.ini file should look like this:

 

CheckpointDirectory='/opt/teradata/client/<version>/tbuild/checkpoint'

LogDirectory='/opt/teradata/client/<version>/tbuild/logs'

 

If the user does not have writer permission to either  "/opt/teradata/client/<version>/tbuild/checkpoint" or "/opt/teradata/client/<version>/tbuild/logs", you will see these errors. 

 

Whether the above recommendation helps you solve the problem or not, please upgrade to the latest patch version. That is the way to go.

 

Diecorp 14 posts Joined 06/12
26 Jun 2012

Thank you.

Finally we re-install the TTU with the last patches, we configure the Environment variables and TPT is launching correctly.

Now, I had other problem: I'm working with DataStage 8.5, and I'm using the TD Connector, but when I try to execute, the job shows the following error:

Error loading connector library libcctera12.so libtelapi.so.

I found the libtelapi.so. library in two paths and I'm going to set them in the variables: $LD_LIBRARY_PATH and $SHLIB_PATH:

/opt/teradata/client/13.10/tdicu/lib64/gcc_3.x and /opt/teradata/client/13.10/tdicu/lib64

but I don't found the libcctera12.so library

My questions are:

For what is usefull the libcctera12.so library?
What path it must to be?
Why the libtelapi.so library is in two paths?

$LD_LIBRARY_PATH =
/opt/teradata/client:/opt/teradata/client/13.10/odbc_32/lib:/opt/teradata/client/13.10/bin:/opt/teradata/client/13.10/tbuild/lib:/opt/teradata/client/13.10/tbuild/lib64:/opt/teradata/client/13.10/tdicu/lib:/opt/teradata/client/13.10/tdicu/lib64:/opt/teradata/client/13.10/tdicu/lib64/gcc_3.x

$SHLIB_PATH=$LD_LIBRARY_PATH

ratchetandclank 49 posts Joined 01/08
26 Jun 2012

Which version of products did you install ? libtelapi.so should be present in /opt/teradata/client/13.10/tbuild/lib directory, not in tdicu directory, unless this is the path explicitly specified (looks like you did mention tdicu as the path to install TPT, during the installation, so that is fine).

libtelapi.so present in "lib64/gcc_3.x" directory is the binary compiled with gcc 3.x compiler and the libtelapi.so present in "lib64" directory is compiled with later version of gcc compiler.

libcctera12.so, is a part of Datastage I think - not sure..

Did you start the ASB agent ?

 

siguru 1 post Joined 06/12
27 Jun 2012

Am getting the below error when i tried to run the UPSERT scripts using TPT

TPT Script used

******************************************************

DEFINE JOB FILE_UPDATE
DESCRIPTION 'Load TD tables from a file'
(
  DEFINE SCHEMA emp_test_tpt
   (
     empno VARCHAR(4),
     empname VARCHAR(50)
   );
 DEFINE OPERATOR FILE_READER
 TYPE DATACONNECTOR PRODUCER
 SCHEMA emp_test_tpt
 ATTRIBUTES
  (
    VARCHAR PrivateLogName,
    VARCHAR DirectoryPath,
    VARCHAR FileName = 'emptest_tpt_file.txt',
    VARCHAR Format = 'Delimited',
    VARCHAR OpenMode = 'Read',
    VARCHAR TextDelimiter = '|'
  );
 DEFINE OPERATOR UPDATE_OPERATOR
 TYPE UPDATE
 SCHEMA *
 ATTRIBUTES
  (
    VARCHAR PrivateLogName ,
    VARCHAR TdpId = 'xyz',
    VARCHAR UserName = 'xyz',
    VARCHAR UserPassword = 'xyz',
    VARCHAR LogTable = 'db.emptest_tpt_lg',
    VARCHAR TargetTable = 'db.emptest_tpt',
    VARCHAR ErrorTable1 = 'db.emptest_tpt_et',
    VARCHAR ErrorTable2 = 'db.emptest_tpt_uv'
  );
 APPLY
  ('INSERT INTO db.emptest_tpt(empno,empname)VALUES(:empno,:empname);',
  'UPDATE db.emptest_tpt SET empname = :empname WHERE empno = :empno;')
  IGNORE DUPLICATE UPDATE ROWS
  INSERT FOR MISSING UPDATE ROWS
  IGNORE MISSING UPDATE ROWS
  TO OPERATOR (UPDATE_OPERATOR[1])
  SELECT empno,empname FROM OPERATOR (FILE_READER[1]);
);

******************************************************

Teradata Parallel Transporter Version 13.10.00.07
Job log: /opt/teradata/client/13.10/tbuild/logs/dsosit-206.out
Job id is dsosit-206, running on colby
Found CheckPoint file: /opt/teradata/client/13.10/tbuild/checkpoint/dsositLVCP
This is a restart job; it restarts at step MAIN_STEP.
Teradata Parallel Transporter Update Operator Version 13.10.00.04
UPDATE_OPERATOR: private log not specified
Teradata Parallel Transporter DataConnector Version 13.10.00.07
FILE_READER: TPT19008 DataConnector Producer operator Instances: 1
FILE_READER: TPT19003 ECI operator ID: FILE_READER-27199
FILE_READER: TPT19222 Operator instance 1 processing file '/chshttp/dsoweb/group8/test_mload/scripts/loader/emptest_tpt_file.txt'.
UPDATE_OPERATOR: connecting sessions
UPDATE_OPERATOR: preparing target table(s)
UPDATE_OPERATOR: entering DML Phase
UPDATE_OPERATOR: TPT10539: Incorrect use of DML statements for UPSERT
UPDATE_OPERATOR: disconnecting sessions
UPDATE_OPERATOR: Total processor time used = '0.42 Second(s)'
UPDATE_OPERATOR: Start : Wed Jun 27 05:49:32 2012
UPDATE_OPERATOR: End   : Wed Jun 27 05:49:36 2012
FILE_READER: TPT19221 Total files processed: 0.
Job step MAIN_STEP terminated (status 12)
Job dsosit terminated (status 12)
******************************************************

 

Diecorp 14 posts Joined 06/12
27 Jun 2012

ratche...

I did install the followings packags:

1). TeraGSS_suselinux-x8664__linux_x8664.13.10.04.01-1.tar.gz

2). tdicu__linux_indep.13.10.00.02-1.tar.gz

3). cliv2__linux_indep.13.10.00.11-1.tar.gz

4). tdodbc__linux_indep.13.10.00.08-1.tar.gz

5). piom__linux_indep.13.10.00.09-1.tar.gz

6). npaxsmod__linux_i386.13.10.00.02-1.tar

7). mqaxsmod__linux_i386.13.10.00.05-1.tar

8). bteq__linux_i386.13.10.00.07-1.tar.gz

9). fastexp__linux_i386.13.10.00.14-1.tar.gz

10). fastld__linux_i386.13.10.00.11-1.tar.gz

11). mload__linux_i386.13.10.00.09-1.tar.gz

12). tpump__linux_i386.13.10.00.09-1.tar

13). papi_x8664_da00__linux_x8664.13.10.00.07-1.tar.gz

14). pexp_x8664_da00__linux_x8664.13.10.00.05-1.tar.gz

15). plod_x8664_da00__linux_x8664.13.10.00.04-1.tar.gz

16). pstm_x8664_da00__linux_x8664.13.10.00.06-1.tar.gz

17). pupd_x8664_da00__linux_x8664.13.10.00.04-1.tar.gz

And yes, I restart the ASB agent

Diecorp 14 posts Joined 06/12
27 Jun 2012

Hello, I set the variables of this form, and I resolved the problem:

$LD_LIBRARY_PATH =
/opt/teradata/client:/opt/teradata/client/13.10/ odbc_32/lib:/opt/teradata/client/13.10/bin:/opt/ teradata/client/13.10/tbuild/lib:/opt/teradata/client/ 13.10/tbuild/lib64:/opt/teradata/client/13.10/tdicu/ lib:/opt/teradata/client/13.10/tdicu/lib64:/opt/ teradata/client/13.10/tdicu/lib64/gcc_3.x

$SHLIB_PATH=$LD_LIBRARY_PATH

Thanks

feinholz 1234 posts Joined 05/08
27 Jun 2012

According to the documentation for UPSERT:

When using the upsert feature:
• There must be exactly two DML statements in the DML group.
• The first DML statement must be an UPDATE statement that follows all of the
Teradata MultiLoad task rules.
• The second DML statement must be an INSERT statement, and it must reflect
the same primary index specified in the WHERE clause of the UPDATE
statement. This is true for both a single-column primary index and a
compound primary index.
• The value for the partitioning column for an update must be specified if the
target table has PPI.
• Both DML statements must refer to the same table.
• The data length defined for any character fields in the WHERE condition of an
UPDATE statement for an upsert must be less than or equal to the
corresponding field length. Otherwise, the upsert is not processed. For
example:
UPDATE T1 SET c1=:f2 WHERE P1=:f1
If P1 is char(5) and f1 is char(6), the upsert is canceled.

--SteveF

You must sign in to leave a comment.