All Forums Third Party Software
pj.routledge 7 posts Joined 04/08
02 Feb 2009
SQL Assistant - missing or corrupt terada.lng reported during startup

I have two PCs on my desk, both running Windows XP (with updates etc - they should be identical as they're automatically updated by the corporate IT people frequently).I've installed the Teradata SQL Assistant (v7.2.0.06 (English)) on both machines in exactly the same way.On both machines, there is a file called 'terada.lng' in the folder 'C:\Program Files\NCR\Teradata SQL Assistant 7.2'. The terada.lng file is creation dated Tuesday, 18 September 2007, 08:02:00 on one machine and Tuesday, 18 September 2007, 07:02:00 on the other machine. Both files are the same size, ie 19 520 bytes. (I suspect that the time difference is due to daylight saving or something like that.)One of the machines starts up normally, and queries are formatted according to the colour and formatting options set using the Tools | Options Formatting tab.The other machine reports that 'Language file (TERADA.lng) is missing or invalid. The parameter is incorrect.' during start up, and queries are NOT formatted according to the colour and formatting options set using the Tools | Options Formatting tab. SQL Assistant does start up and work, though. Queries run correctly, etc.This has been the situation for some months (since late October 2008).I've tried replacing the terada.lng file and I've tried uninstalling and re-installing SQL Assistant on the faulty machine, all to no avail.I'm assuming that the faulty installation is using the base.lng language file, or no language file at all, but I'd like to get it to use the terada.lng file.Any suggestions/experience?Regards,Peter

pj.routledge 7 posts Joined 04/08
04 Feb 2009

This problem is fixed.Unfortunately I don't know what caused it nor what exactly fixed it.I purged all Teradata software from the PC (except the ODBC driver - couldn't remove it because I'd already deleted the installation .msi file). Went through the registry, the disk, everything I could think of and find.Then re-installed from scratch.Seems to have worked - no more corrupt or missing terada.lng messages and the queries are formatted and coloured as expected.Peter

You must sign in to leave a comment.