All Forums

Topics cover the Teradata Studio product family. This includes Teradata Studio, Teradata Studio Express, and Teradata Plug-in for Eclipse. For articles, blogs and more, see the Tools section of the site.

You must login to post to the forums.
Teradata Studio 14.02 - How can I resort a result set w/o requerying the DB? Topic by RickSRose 26 Aug 2013 sorting, resorting

Is there a way to re-sort the result set returned in Teradata Studio 14.02 without re-querying the Database? 
Another way of putting the question: Is there a way to do a multi-column complex sort (Asc, Desc, Asc, Asc... ) on the existing resultset without requerying the database?
I am querying TD 13.00 but that should not mattter.
Thanks,
Rick

2435 views
5 replies, 5 years ago
ANSI vs TERA auto commit in Studio v14 Topic by Mover 25 Jul 2013

Hi All
I'm experience database/data warehouse developer but new to Teradata.
I'm trying to work out how the behaviour of TERA vs ANSI autocommit in studio.
When using ANSI "BEGIN TRANSACTION;" statement generates an error. Why is this? I always thought ANSI standard allows nested transactions e.g:
BEGIN TRANSACTION --start explicit user transaction

3502 views
3 replies, 5 years ago
How to use all features of Tools Menu. Topic by Glass 29 Aug 2013

I'm just famiilarizing myself with Studio 14.10
After logging on in Tera mode as an admin user, when choosing  Administer  from the Tools Menu,
Roles and Profiles are greyed out. (Create,Modify and Security menus also have some selections greyed out)
What have I missed?
 
thanks, RGlass
 

1575 views
2 replies, 5 years ago
LDAP authentication for Teradata Express Edition 13 Topic by sayaksitex 21 Jun 2013

I have installed Teradata Express edition 13 in windows XP. I have a LDAP server as well. I want to log in to teradata using LDAP authentication.
Please suggest me the steps to achieve the requirement. Appreciate any help.
 
Thanks and Regards,
Sayak Ghosh

2341 views
5 replies, 5 years ago
how to define columns to read decimals like lat and long? Topic by babuamaz 28 Aug 2013

Hi, this is my first post so bear with me if someone may have already asked this Q.
I am trying to load a flat file that includes fields for latitude and longitude. Each of these has 8 decimals with two or 4 leading characters as shown below:
rooftop_lat : 33.98786545
rooftop_long: -118.2559204
My SQL statements within the Crate table script are as follows:
 

1576 views
1 reply, 5 years ago
SQL results in Studio 14.2 don't match results from SQL Assistant 13.10 Topic by levinra 10 Jul 2013 Studio SQL results don't match SQL Assistant

When I execute the code below in Teradata Studio 14.2, I get 0 rows returned.  When I execute it in SQL Assistant 13.10, I get 129 rows, which is correct.  The connections for both applications point to the same destination.  The database is version 13.10.
What have I missed in my setup of Studio?
 

1935 views
3 replies, 6 years ago
Attempting to stop a query or to close connection always hangs Topic by javadba@gmail.com 30 Jul 2013

 
Whenever i request to cancel a query or even to close a TD connection from the GUI they hang.
 
I am using TD Studio Express 14 (downloaded middle of July 2013)
 
(no screenshot ability here??)

2130 views
3 replies, 6 years ago
Date Error in Syntax - Help Topic by sush5777 04 Aug 2013

Folks - I am getting errror in executing this statement....any help?
 
select WeekStartDate
BETWEEN ('5/1/2013' AND '5/15/2013') +1 as period
where WeekStartDate BETWEEN ('5/1/2013' AND '5/15/2013') < 7 

1606 views
1 reply, 6 years ago
Require TERADATA EXPRESS STUDIO for 64bit Windows 7...both Client and Server....plz help Topic by sayaksitex 03 Jul 2013

Hi all,
I want to install TERADATA EXPRESS STUDIO in my personal laptop having 64bit windows 7. 
Can anyone please provide me the same. I want both Client and Server without VMware.
Regards,
Sayak Ghosh

2102 views
4 replies, 6 years ago
Total and Subtotal Aggregate Function not working Topic by sagarsisodia 19 Jul 2013

Teradata Studio not able to run simple aggregation function.
Sample SQL
SELECT department_number AS Dept

,job_code AS Job

,employee_number AS Empl

,salary_amount AS Sal

FROM employee

WHERE department_number IN (401, 501)

WITH SUM (salary_amount) (TITLE 'Job Total') BY Job

1687 views
1 reply, 6 years ago
Unable To Create Stored Procedure Using JDBC !! Topic by rajeev saravanan 29 Jun 2013

Hi All,
I have downloaded and installed the TD-13 express version using VM player
I am able to query the database and everything looks fine, however when i try to create a stored procedure it just doesnt allow

2980 views
4 replies, 6 years ago
2703 views
5 replies, 6 years ago
New connection in my local machine Topic by sunis12 07 Jun 2013

Hi,
 
I am very much new to Teradata. I have installed teradata studio express on my windows 7(64 bit) laptop. Now I need to create database and connection.
1) I do not have a database- is there any sample database
2) When I try to create a new connection, it asks for 
    a) DB Servername    b) User  c) Password  d) Database

2263 views
2 replies, 6 years ago
With Teradata Studio why does a timestamp(0) export with trailing .0 Topic by gpolanch 03 Jun 2013 teradata studio, export, timestamp, trailing .0

Hello,

2510 views
3 replies, 6 years ago
Copy Objects Topic by DannyChin 31 May 2013

I am trying to use Teradata Studio to copy data from one Teradata machine to another. When I clicked on Tools then Copy/Compare Objects, it brings me to the Teradata Compare Objects window. Is the Copy function available in Version: 14.02.0.201302060329? Is there any documentation available?

1543 views
1 reply, 6 years ago
Studio refuses to accept I have Java 1.6 installed Topic by Mark Whitehead 26 May 2013

The installer refuses to see that I have JRE 1.6 and JDK 1.6 installed...
Not sure how it can fail to spot this...never seen this error before...
Windows 7 x64 with Teradata Studio 14.02 32 bit (tried 64 bit as well)...
Have both JRE and JDK 1.6.37 32 and 64 installed.
Can I point Studio to the JRE post installation (like you can with most well designed products)? 

1440 views
3 replies, 6 years ago
TD studio does not reflect DDL changes. Topic by boxerdog 14 May 2013

 
I have a view with 4 columns.  If I select * from the view, I see all 4 columns.
 
If I remove a column from the view and replace it, then select *, I should see 3 columns.  I still see 4.
 
If I log into the DB using BTEQ, my changes are reflected.
 
If I close and re-open Teradata Studio, my changes are reflected.
 

1949 views
7 replies, 6 years ago
Teradata Studio Express Problem Topic by mcetraro 23 May 2013

Hi,
I have downloaded Teradata Studio Express and intalled into my computer.  Everytime that I click on the New Generic JDBC I get the following error:
Could not connect to New Generic JDBC.

1491 views
1 reply, 6 years ago
Move Data does not function Teradata 12 Topic by brettbates 04 Apr 2013 move data

When attempting to use the Move Data functionality after selecting a database and then selecting Move Data, nothing happens, the application freezes up and must be exited by ending the process in Windows

3353 views
17 replies, 6 years ago
Teradata Eclipse Plug-in 14.02 does not load in Mac version of Eclipse EE Juno R2 Topic by hock 08 Apr 2013 Eclipse Java EE IDE, teradata plug-in for eclipse

Hi all, I have a Mac version of Eclipse, Eclipse Java EE IDE for Web Developers, Version: Juno Service Release 2, Build id: 20130225-0426.  I did a web install of Teradata Plug-in 14.02.  Eclipse stuck at "Loading Workbench".  The help document does not mention Mac OS support.  Is this the case?  Thank you.  Hock 

2184 views
6 replies, 6 years ago
Searching SQL History Topic by samsterling 13 Mar 2013

I don't find any way to do a Find in SQL History, like I can in SQL Assistant.

2630 views
2 replies, 6 years ago
Teradata Studio Express Topic by Cvinodh 11 Mar 2013 teradata studio

Hi,
I am using Teradata studio express in Macbook pro.
The Application is abruptly closing every time I try to open it.
It was working for almost a day after upgrading the SQL Client.
I've reinstalled the application and restarted the system. yet it is not working.
I even tried deleting Teradata Express Studio folder in /Applications Folder.

4508 views
7 replies, 6 years ago
Liberties with SQL - minor issue Topic by samsterling 06 Mar 2013

I have a script that generates SQL to COLLECT STATISTICS.
When I highlight the result set and copy it to a scrapbook, it puts " around my commas and makes it unrunnable.  This does NOT happen if I export the result set to a text file, copy it, and then paste it in a scrapbook.
Here's an example:
collect statistics on DEV_P2P_T.P2P_FACT_JU index ( "PO Num "

1842 views
2 replies, 6 years ago
Teradata studio connection to mds : Could not log on user Topic by ak93 09 Mar 2013 plugin, meta data services, interdependency browser, mds, eclipse, ide, are we related

I can see the system loaded as that defined in mds when we use the Test user button. but upon checking for interdependence on object we get the following error
com.teradata.datatools.dependencies.TeradataInterdependenciesException: Could not log on user
at com.teradata.datatools.dependencies.mdsimpl.TeradataInterdependencies.(TeradataInterdependencies.java:134)

2500 views
2 replies, 6 years ago
Space Summary Topic by AceJ357 06 Mar 2013

Is there a way to see a Space Summary and Skew Factor for tables using Teradata Studio similar to what you are able to do in Teradata Administrator?  If so, how?

1726 views
1 reply, 6 years ago

Pages