All Forums Teradata Studio
jlasheras 6 posts Joined 08/12
16 Sep 2015
Unexpected access rights problem when attempting to export table data

Running Studio Express one of our users attempts to export data from a table he has created and populated, clicking the table name in the Data Source Explorer left panel with the right mouse button, but instead of the expected menu including the Data option, he receives the error shown in the attached image.
Please, any help on what could be the root cause of this problem?
Other users sharing same access rights have no problem at all.
Thanks in advance for any assistance.

fgrimmer 553 posts Joined 04/09
16 Sep 2015

Jorge, The error log should have an entry with the access rights exception so you can see what or who did not have access.
One possibility is that the Object Viewer is opened and when an object is selected in the Data Source Explorer, the Object Viewer will attempt to load additional data (such as privileges) for that table. We have made several enhancements in our latest release to avoid loading additional data by the Object Viewer until the user clicks on a tab. You could try to close the Object Viewer so that loading additional data does not occur.

jlasheras 6 posts Joined 08/12
17 Sep 2015

Thank you for your prompt reply, Francine
I checked the log as you suggested and the reported missing access right is SEL on DBC.DBCInfo. (?)
I didn't think the app uses this view in order to report the DBS version for the connection.
I'm going to grant this right to the user and ask him to try again, to see if his problem is solved.
This is strange, no other user has SEL on that DBC view, what I grant them is access to DBC.DatabasesV, DBC.TablesV, DBC.ColumnsV, DBC.IndicesV and DBC.FunctionsV.
Perhaps this user set an option within Studio Express and that makes the difference.
I don't remeber if the user had the Object Viewer opened, I´ll check that, too.
Thank you again and best regards

jlasheras 6 posts Joined 08/12
06 Nov 2015

I wanted to report that according to our users the problem was solved in version, i.e. once they upgrade the error never occurs again, while their access rights remain the same they had for previous versions

You must sign in to leave a comment.