All Forums Teradata Studio
rohitbeth 32 posts Joined 10/07
09 Feb 2014
Unable to connect to the database using Teradata Studio Express.

I have installed the Teradata express 14 edition using vmware. I was able to setup the connection using Gnome Terminal, however I am unable to connect to the database using the Teradata Studio Express. 
I have tried using the same creditials as used in the Gnome Terminal for bteq which is :

  • logon
  • username: dbc
  • pwd: dbc

can you please help me with what credentials can i use to connect from the studio express to the database ??
Also, which user can i use to create tables and other database objects ? Dbc currently does not allow me to create tables in teradata.

fgrimmer 553 posts Joined 04/09
10 Feb 2014

Rohit, I assume you are trying to run Studio Express inside the VM? You should be able to provide the same IP address ( without the /dbc, then username dbc and password dbc. User DBC should have the permissions to create database objects or to give permission to other users to create objects.

Prakash101 1 post Joined 11/13
13 Jul 2014

I have installed the virtual machine in windows. The IP address of did not work for me as well. BUT recollecting that the LOOPBACK Adapter for windows is I tried it and it worked successfully for me.

juvenita 1 post Joined 11/15
12 Nov 2015

Hi i installed teradata studio in my windows and tried to connect to teradata database in VM machine but the ping failed i tried which is the ip of local host it didnt work out.can anyone please help out what iam doing wrong

fgrimmer 553 posts Joined 04/09
12 Nov 2015

@juvenita, If you are running Studio outside the VM, you need to find the IP address of the VM. You can open a DOS window in your VM and run ifconfig to see the IP address, eth0. Here is a comment from someone posted on Cloud Computing Forum:
run the virtual machine and open a commandline and execute:
ifconfig eth0 | sed -n '/inet addr:/s/.*inet addr:\([^ ]\+\)\s.*/\1/p'
that is the ip address you need to provide on your host computer to connect to the VM's db instance.
username/password for db is dbc/dbc

sakthikrr 53 posts Joined 07/12
05 Dec 2015

Dear @fgrimmer,
I have installed VM but I'm unable to ping local host in it (both and; During the first launch I was able to successfully connect it with; But now its failed. Please help.


sakthikrr 53 posts Joined 07/12
05 Dec 2015

Adding more details.. Its TDExpress14.0.3_Sles10_4GB, 64 bit


sakthikrr 53 posts Joined 07/12
05 Dec 2015

I'm getting a warning message like DB is crashed.


DaveWellman 66 posts Joined 01/06
05 Dec 2015

Hi Sakthi,
First, make sure that the dbms is running.
From a Gnome terminal window try the following command:
pdestate -a
This will give you the status of both pde and the dbms. I don't have a system to try this on right now, but if everything is ok then the final message will say (something like) "system is operational - users are logged on" or "system is quiesced" (no users are logged on.
Start with that and see what happens.

Ward Analytics Ltd - information in motion

sakthikrr 53 posts Joined 07/12
05 Dec 2015

Dear Dave,
Its DOWN/HARDSTOP status. But when I'm trying to start the dbms its saying rdbms is crashed or session reset. Recovery in progress. Its in the same state for almost more than a hour.


sajjad.mubashar 1 post Joined 04/16
05 Apr 2016

1. Run your virtual machine
2. Lower Left corner click on computer
3. Click Network Wired
4. Assign some IP to machine like I assigned
5. Subnet Mask
6. Finish
7. Now place this IP in database server name and user is dbc password is dbc.

Kbos 20 posts Joined 04/13
14 Jul 2016

The way how it worked for me:
1. Run your VM.
2. Click on Computer (look at the low corner left)
3. Click on Network Wired
4. Choose Traditional Method with ifup
5. Verify the option that says "VMWare Abstract PRO/1000 MT Single Port Adaptar " has set up DHCP value. If not,  go to Address tab, click on HostName and Name Server and then assign eth10 on Hostname. Save changes and try again.

Akshay_Inp 1 post Joined 08/16
01 Sep 2016

I am new to teradata:
I have installed the Tearadata VM Player 14.10, I am using studio express inside the VM but not getting the options inside tools (ex. create,modify, security, administer).
Thanks in advance for help.

fgrimmer 553 posts Joined 04/09
02 Sep 2016

Akshay, Teradata Studio Express is meant for running queries and exporting result data. You will want to download our Teradata Studio product. It includes all the functionality of Studio Express, plus administration dialogs and forms for creating and administering database objects.

You must sign in to leave a comment.