All Forums Teradata Studio
ianrobertson85 2 posts Joined 03/15
07 Apr 2015
Teradata Studio Express 15 (mac) slow & laggy

Just recently moved from a windows machine with sql assistant to a mac with studio express, and I'm running into some issues with studio express:

  • Keypresses are laggy - e.g. I've typed a whole line and the editor is still chunking along character-by-character from the previous line
  • Executing statements is laggy - progress window won't show up after submitting statements for a few seconds
  • Hover-text in the SQL history seems to be a bit buggy - sometimes it'll repeatedly pop up and remove the hover text, so I can't really read things

Any thoughts on whether there's either a) another option for mac for just submitting "end-user" queries - insert/update/select/etc., or b) some sets of options that I can set up in studio express to performance-tune it to limit the lagginess?  The keypress lag is particularly difficult to work around.

dnoeth 4628 posts Joined 11/04
07 Apr 2015

On my system this was mainly related to low memory assigned to Java.
There's a TeradataStudio.ini file within the app folder:
Try increasing minimum and maximum memory, my settings are



ianrobertson85 2 posts Joined 03/15
09 Apr 2015

That seems to help somewhat, thanks Dieter!

astocks 22 posts Joined 03/11
13 May 2015

This definitely seems to help.  Any idea what the below setting is, and should it be changed to 2048 as well?

fgrimmer 553 posts Joined 04/09
13 May 2015

Adam, MaxPermSize refers to the size needed by the permanent generation of objects in the VM (Class names, internalized strings, objects that will never get garbage-collected). If you see java.lang.OutOfMemoryError: PermGen space errors, you need to increase the permanent generation space available to Studio.  

egillen 4 posts Joined 01/16
04 Feb 2016

Hi. When I open the terdataStudioExpress.ini file in TextEdit on Mac, I'm able to see the text but when I try to edit the setting I get this warning;
"You don’t own the file “TeradataStudioExpress.ini” and don’t have permission to write to it."
Any advice on how i can change these settings?

fgrimmer 553 posts Joined 04/09
04 Feb 2016

@egillen, The TeradataStudioExpress.ini is located in the install directory. You will need admin privileges to modify it. 

egillen 4 posts Joined 01/16
10 Feb 2016

Hi Francine, I've been able to carry out the update and i've already seen a performance improvement.  :-)  
I'm just wondering, how high can I update these memory settings... is there a point of diminishing returns?

fgrimmer 553 posts Joined 04/09
10 Feb 2016

@egillen, You can increase the memory arguments in the .ini file. The current settings are at 512m:





It probably depends on how much memory you have on your desktop system.

listoni 5 posts Joined 02/11
18 Feb 2016

I had the same problem. I switched off all the syntax checking and it was still slow. 
Closing studio and restarting it did the job. (Apparently, even though you change the settings, the program needs to be closed and reopened before the new settings take effect. 

fgrimmer 553 posts Joined 04/09
22 Feb 2016

@Moo, We have fixed a bug loading data into a table that involves a Java Memory issue. Can you see if you are hitting this error in the error logs?

egillen 4 posts Joined 01/16
22 Feb 2016

Hi,  I updated my setting to this;






And Teradata Studio Express is still running slow on my very powerful MacBook Pro...  In my Windows VM, TD Studio Express is working much better.  I think TD need to focus on developing TD Studio Express to work better on Macs. I know it seems like big ask, but there are lots of Mac users out there.  This is a good SQL Editor and it would be sad to let it go just cause its not developed well for Mac OS as opposed to Windows.




fgrimmer 553 posts Joined 04/09
21 Mar 2016

We have noticed an issue with Teradata Studio on Mac OSx when installed remotely by the administrator. The user did not have Administrator premission and thus an administrator had to log in remotely to install Studio on his Mac machine. The user noticed the slow response and posted the following:
"I ended up uninstalling and reinstalling.  I believe something got messed up during the install.  I am not sure what happened, but at the time, I did not have Admin rights on my laptop/Mac.  My install was done remotely over VPN and Webex, and I am not sure if some configuration files or Workspace files may have been set for a shared drive or something.
It is early yet, but Studio is responding much better now and the issue seems to have gone away.  I do need to use it longer to be sure, but that will come.  I increased the parameters in the .ini file as well.  It may be a good idea to document that process of unlocking the directory and files on the Mac Finder and updating the file.  This is definitely not intuitive on the Mac."
Not sure if this is your situation?
Another option we to check the Java Control Panel system preference and the Temporary Internet Files setting for Java. Change the setting from 32GB to 5 GB and use "Delete files..." for the Trace and Log Files and Cached Application and Applets. 

You must sign in to leave a comment.