All Forums Teradata Studio
schloegl 2 posts Joined 11/09
09 Mar 2016
Teradata Studio 15.10- connected in Data Source Explorer but not in SQL

I just installed Teradata Studio 15.10 on Windows7 and want to access our Teradata 14.10 machine.
I can connect without problems to the machine and I see 'connected' in the status line at the bottom when I click on the machine in Data Source Explorer.
But when I want to execute a SQL-statement and select the connection profile of the machine I am connected to, I see 'not connected' in the status line at the bottom.
The execute-button is green but when I press it, nothing happens.
Please help.
Thank you!

DaniGn 4 posts Joined 12/15
09 Mar 2016

It may be that the version of Teradata studio giving you problems, try to install a previous version.
If this don´t resolve your problem i have some questions.
do you try t use teradata sql assistant ? it give you problems too? i can be problems with odbc driver.
other functions of teradata studio give you problems?



I hope it helped you


fgrimmer 553 posts Joined 04/09
09 Mar 2016

Thomas, What SQL Editor is being opened with your SQL statement? Make sure that you are using the Teradata SQL Editor instead of the SQL File Editor to execute your query. Locate your SQL file in the Project Explorer, right click and choose Open With>Teradata SQL Editor. The Teradata SQL Editor will attempt to open the connection when you select it in the Connection Profile drop down, if it is closed. 
I have attached a screen image of the Teradata SQL Editor.

schloegl 2 posts Joined 11/09
14 Mar 2016

Thank you Francine, with the Teradata SQL Editor it works.
Until now it didn't care about the editor - it just worked with the default settings. The Teradata SQL editor should be set as default I guess...

fgrimmer 553 posts Joined 04/09
14 Mar 2016

Thomas, Yes, it should be. There is a File Association preference (General>Editors>File Associations> for .sql files that should be set to Teradata SQL Editor as the default.

You must sign in to leave a comment.