All Forums Teradata Studio
Mark Whitehead 0 posts Joined 08/12
26 May 2013
Studio refuses to accept I have Java 1.6 installed

The installer refuses to see that I have JRE 1.6 and JDK 1.6 installed...
Not sure how it can fail to spot this...never seen this error before...
Windows 7 x64 with Teradata Studio 14.02 32 bit (tried 64 bit as well)...
Have both JRE and JDK 1.6.37 32 and 64 installed.
Can I point Studio to the JRE post installation (like you can with most well designed products)? 
No obvious way to do this in Studio.  Not Help given by the useless installer or the useless application - unlike every other product on the planet that uses Java!
Quite frankly whomever wrote this should be embarrassed by just how crap it is!

fgrimmer 553 posts Joined 04/09
29 May 2013

The install will attempt to get the Java version by running java -version command. Can you verify that this is returned the correct version? Also make sure that your PATH is pointing to the correct version of Java.

MRW 0 posts Joined 05/13
29 May 2013

Hi there
my Path variable equates to :
PATH=C:\Program Files (x86)\Teradata\Client\13.10\ODBC Driver for Teradata\Lib\;
C:\Program Files (x86)\Teradata\Client\13.10\Shared ICU Libraries for Teradata\l
ib\;C:\Oracle\product\11.2.0.3_32\client\jdk\bin;C:\Oracle\product\11.2.0.3_32\C
lient\bin;C:\Program Files (x86)\Business Objects\common\3.5\bin\NOTES\;C:\Progr
am Files (x86)\Business Objects\common\3.5\bin\NOTES\DATA\;C:\Windows\system32;C
:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C
:\Program Files (x86)\SSH Communications Security\SSH Tectia\SSH Tectia AUX;C:\P
rogram Files (x86)\SSH Communications Security\SSH Tectia\SSH Tectia AUX\Support
 binaries;C:\Program Files (x86)\SSH Communications Security\SSH Tectia\SSH Tect
ia Broker;C:\Program Files (x86)\SSH Communications Security\SSH Tectia\SSH Tect
ia Client;C:\Windows\SysWOW64\;C:\Windows\;C:\Windows\SysWOW64\Wbem;C:\Program F
iles (x86)\IDM Computer Solutions\UltraEdit-32;C:\Program Files\SASHome\Secure;C
:\Program Files\SASHome\x86\Secure;C:\Progra~1\SASHome\Platform Process Manager\
8.1\bin;C:\Program Files (x86)\IDM Computer Solutions\UltraEdit\
The issue would be that it is finding the Java directory under the Oracle Client - which isnt actually part of the Installed Javas as shown in the Add/Remove Programs list.
I have java 1.6.0_37 installed - the fact the installer cant find that is poor...the fact the application refuses to run and provides no option to point to this is even worse...
Note SQL Developer 3.1 from Oracle didnt have a problem like this...neither did SAP Business Objects 4.0 - both heavily reliant of the correct version of Java being installed. 
I suggest you speak to your developers and get them to improve this side of things for the next bug fix...
However I have managed to change my PATH variable (fortunitely I have Local Admin access at the moment and can do this)...and this has solved the problem...
 

fgrimmer 553 posts Joined 04/09
30 May 2013

In our next release, we are improving the Install to better resolve the issue of finding the correct version of the JRE.

You must sign in to leave a comment.