All Forums Teradata Studio
todddube 6 posts Joined 01/15
08 Jun 2015
Studio Mac OSX Export hangs for a long time

I'm running the latest  TeradataStudio__mac_x86. on OSX 10.10 and when pulling resusage from customer site I get the data back in the results window, but then if I want to export it to disk I click on this and get the black/white ball and studio goes off into a spin for about 5 muntes then eventually comes back with nothing.  Tried twice and same issue.  ?  Is this a bug?
BTW works just fine on RazorSQL (prefere Studio) 

hl186018 8 posts Joined 08/14
09 Jun 2015

Which resusage marco/table/view are you using?
When you say to export the data to disk, are you setting the SQL Handling under Preferences to have Teradata Export Wizard (File Export) ? or you are using the icon in Teradata Result Set Viewer "Export the result set to external file." ?

jni 1 post Joined 03/15
29 Jul 2015

I am having the same issue. I am using the "Export the result set to external file" option to try to save the results, but nothing pops up, I was expecting a dialogue box for me to choose file format just as in Windows.

hl186018 8 posts Joined 08/14
29 Jul 2015

Hi jni,
Can you tell me the detail of your issue ? what did you try to do? when it happened, did you see any error in the log?
I have tried Studio on Mac OSX . I run a simple SELECT query and export the data in 2 ways (Teradata Export Wizard and Teradata Result Set Viewer) and both are working fine.
Thank you.

rpausch 1 post Joined 08/14
06 Aug 2015

I'm having a similar problem with, Windows 7 and Java 1.8.  When I click on the export results button in the results window.  The button stays pressed and the application hangs for more than a minute.  Eventually the application responds, although the export dialog window doesn't open.
When I try a simple query of 2000 results I don't have this issue.  When I have results greater than 20,000 it does happen.  These are fairly complex queries.
Thank you 

fgrimmer 553 posts Joined 04/09
06 Aug 2015

Richard, What database is your result set from, Aster, Teradata, or Hadoop?

fgrimmer 553 posts Joined 04/09
10 Aug 2015

Richard, I am wondering if you are running out of memory. You would see this in the error log. Can you increase the heap for Studio. You can increase the -vmargs parameters in the Studio .ini file (located in the install directory).







magalielaniel 2 posts Joined 02/15
10 Sep 2015

Hi, Have this been solved?
I have the same issue now that I got a new PC. Windows 7 64 bits, just downloaded Studio 15.10.4, on Java 1.8_45. "Export the result set to external file" leads nowhere. I tried modifying the .ini file as mentioned above, but my access is denied. 
Any idea what else I can try?
Thank you very much!!! Magalie

fgrimmer 553 posts Joined 04/09
10 Sep 2015

Magalie, We are working on a resolution. But in the mean time, please try to export the results using Export Mode. Export Mode will bypass displaying the results in the Result Set Viewer and send the results directly to an external file. To turn on Export Mode, go to Window>Preferences>Teradata Datatools Preferences>SQL Handling and change the Results Handler to 'Teradata Export Wizard (File Export).

magalielaniel 2 posts Joined 02/15
15 Sep 2015

Thank you for your detailed explanation, it works perfectly that way :-)

todddube 6 posts Joined 01/15
27 Oct 2015

I'm running the latest .004 build and this is still an issue with the export button. Going to try the Export under SQL Handling above. 

You must sign in to leave a comment.