All Forums Teradata Studio
tgattone 11 posts Joined 11/10
07 Mar 2014
Studio Express 14.10 Startup Error

I was able to run 14.01 on my Windows 7 laptop but after installing 14.10 today, I just get a popup window saying "Java was started but returned exit code=1".
I have both Java 1.6 and 1.7 installed if that matters.

fgrimmer 553 posts Joined 04/09
07 Mar 2014

Can you verify that you have the correct 32-bit or 64-bit version of Studio Express and JRE.  Is there an error log in your configuration directory?

tgattone 11 posts Joined 11/10
11 Mar 2014

32 bit version.  What is the path to the configuration directory?

fgrimmer 553 posts Joined 04/09
11 Mar 2014

If you have installed the 32-bit version of Studio Express, run the java -version command and verify that the 32-bit version of JRE is returned.
The configuration directory is located in the install location, default is: C:\Program Files (x86)\Teradata\Client\14.10\Teradata Studio Express\configuration

tgattone 11 posts Joined 11/10
11 Mar 2014

No error log in that location.  I do have Java installed as it was used in my 14.01 version of Studio Express.
 

1.7

1.7.0_51

http://java.sun.com/products/autodl/j2se

C:\Program Files (x86)\Java\jre7\bin\javaw.exe

 

true

1.6

1.6.0_23

http://java.sun.com/products/autodl/j2se

C:\Program Files (x86)\Java\jre6\bin\javaw.exe

 

true

A startup error window pops up when I try to run 14.10.  Is this information logged somewhere?  I cannot copy the text out of it but that info may be helpful.

fgrimmer 553 posts Joined 04/09
11 Mar 2014

Also look for log file in the .eclipse/<installInstance>/configuration which is located in your <USER> directory.
Open a DOS window and run: java -version command. For example, 

C:\Windows\System32>java -version

java version "1.6.0_20"

Java(TM) SE Runtime Environment (build 1.6.0_20-b02)

Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)

 

Both 1.6 and 1.7 are supported. 

tgattone 11 posts Joined 11/10
11 Mar 2014

If I go to Control Panel...(Java 32-bit), the Java Control Panel shows me info on version 1.6 and 1.7, but the DOS window method yields the below.
c:\Windows\System32>java -version
'java' is not recognized as an internal or external command,
operable program or batch file.

tgattone 11 posts Joined 11/10
12 Mar 2014

FYI, I have uninstalled Java 1.6 and now only have 1.7.  My other Java software seems to be working fine.  I did notice this on the popup window from Studio Express when I try and run it:
Java was started but returned exit code=1
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Dosgi.requiredJavaVersion=1.6
 

fgrimmer 553 posts Joined 04/09
12 Mar 2014

When you installed Studio Express 14.10.01 it should ask you for the location of your JRE. Can you uninstall Studio Express and try to re-install. It should find your JRE 1.7 version.

tgattone 11 posts Joined 11/10
13 Mar 2014

Just did an uninstall and re-install where it found the JRE 1.7, but I still get the popup with the same startup error info:
Java was started but returned exit code=1
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Dosgi.requiredJavaVersion=1.6
 
There is a lot of other info in this popup error message box. Is this info logged anywhere besides what we discussed previously?

fgrimmer 553 posts Joined 04/09
13 Mar 2014

Try adding the location of your JRE to the TeradataStudioExpress.ini file

-vm

C:\Program Files (x86)\Java\jre7\bin\javaw.exe

 

tgattone 11 posts Joined 11/10
13 Mar 2014

Hmm, this is what the file has already:
-vm
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Xms256m
-Xmx256m
-XX:MaxPermSize=256m
-Djava.util.Arrays.useLegacyMergeSort=true

fgrimmer 553 posts Joined 04/09
13 Mar 2014

Can you send me the file path to the TeradataStudioExpress.exe. For example, my system shows:
C:\Program Files (x86)\Teradata\Client\14.10\Teradata Studio Express

tgattone 11 posts Joined 11/10
13 Mar 2014

Sure, I have the same:
C:\Program Files (x86)\Teradata\Client\14.10\Teradata Studio Express

fgrimmer 553 posts Joined 04/09
13 Mar 2014

Tim, This is a mystery? Just to recap: You have installed JRE 1.7.0_51 and Studio Express 14.10.01  installed successfully. You try to launch Studio Express but it exits with exit code=1. There is no configuration log in your .eclipse directory or the Teradata Studio Express install location / coinfiguration directory?

tgattone 11 posts Joined 11/10
14 Mar 2014

Yep, Francine.  Even more of a mystery when 14.01 version ran fine.  I did a screen capture of the popup message box whenever I try and run 14.10. Can I email it to you since I do not see a way I can attach a ".PNG" file to this thread?

fgrimmer 553 posts Joined 04/09
17 Mar 2014

Tim, We have tested with this version of the JRE and did not have any problems. But we did have problems with the JRE 1.7.0_51 install in that it did not set the PATH correctly. Can you make sure that your PATH is set to point to the location of the running JRE. This can be verified by running the 'java -version' command that I asked about earlier in the thread.  Running the java -version command should return the correct version of the JRE that will be run.

tgattone 11 posts Joined 11/10
18 Mar 2014

That command still does not work for me:
c:\Windows\System32>java -version
'java' is not recognized as an internal or external command,
operable program or batch file.

fgrimmer 553 posts Joined 04/09
18 Mar 2014

Can you add the location of your JRE to your PATH variable?

tgattone 11 posts Joined 11/10
18 Mar 2014

Wow, updating the PATH manually fixed the entire install and 14.10 runs fine now!  A simple fix for all of this...go figure.
 
Thanks for all of the help!

You must sign in to leave a comment.