All Forums Teradata Studio
tbenard 7 posts Joined 03/13
16 Aug 2016
Parameterized Queries result in error (1095 - cannot call a method on closed connection)

Hello, I am using TDS  I have tried both unnamed parameters "?" and named parameters "?\MyParm" however I get the error shown in the subject of this post.  e.g.,:
Select * from MyTable where MyField = ?\MyParm;  (also tried within single quotes)
That does not work... and what I REALLY want is this:
Select * from MyTable where upper(MyField) like upper('%?\MyParm%')
The preceding works just fine in SQL Assistant, but I have colleagues using TDS, so I need to account for them.
I suspect I need to turn comething on in TDS.  Can anyone please tell me how to make this work?

fgrimmer 553 posts Joined 04/09
17 Aug 2016

Thomas, I am trying to recreate this issue but no luck. Are you running the query on Aster or Teradata Database? Can you try reconnecting the connection profile? Also can you try your query on the latest Studio 15.11 release and see if this issue still happens?

You must sign in to leave a comment.