All Forums Teradata Studio
vbdcb 14 posts Joined 12/09
04 Nov 2014
Moving cursor around in large SQL Editor files is sluggish

I've been having a problem when working with my large SQL files in Teradata Studio. It seems that when the file contains a lot of text, especially when it flows off the screen to the right, the cursor is very slow to react and if you hold the cursor down to move several characters it will jump a few or many characters. This makes it somewhat difficult to develop in an environment where there are several large SQL files being worked in a solution. Thoughts?

vbdcb 14 posts Joined 12/09
04 Nov 2014

Well, I gave Teradata Studio the college try, but this is the straw that breaks the camel's back. I'm going back to Queryman, er, SQL Assistant. 

fgrimmer 553 posts Joined 04/09
04 Nov 2014

David, I have a large SQL text file that has lines that extend but do not see a slow down. Do you have Code Assist Autoactivation on? Does it help to turn it off?

vbdcb 14 posts Joined 12/09
04 Nov 2014

I turned Code Assist Autoactivation off almost immediately. I also turned off Enable Syntax Validation and set the undo history size to 20. No luck.

fgrimmer 553 posts Joined 04/09
04 Nov 2014

David, How many lines are in your SQL file? Does it happen only for large SQL files or any SQL file? What Operating System are you running on?

vbdcb 14 posts Joined 12/09
05 Nov 2014

Just opened Studio this morning, went straight to the file that was giving me problems yesterday and it is already slow. There are 101 lines, with a couple of lines being over 3k chars in width (COMPRESS statements).
I am running Win 7 Pro 64 w/Intel i5 and 8 gigs of RAM. Note that I can open the same file in Notepad++ and never experience a problem.  
 

vbdcb 14 posts Joined 12/09
18 Nov 2014

I think it might have to do with the syntax coloring. The cursor in a script for a create table with a lot of compress statements runs sluggish until I comment it out. Then it speeds up. 

fgrimmer 553 posts Joined 04/09
18 Nov 2014

We'll take a look. Thanks.

PaulZhang 1 post Joined 11/13
20 Nov 2014

I am having similar issue.  Everytime when it is slower, I have to close the window and opent it again. Very annoying 

fgrimmer 553 posts Joined 04/09
20 Nov 2014

@yuepeng, Curious if you also have compress statements is the slow SQL and code assist autoactivation turned off?

chillerm 15 posts Joined 04/11
20 Nov 2014

I had the same issue. In teradatastudio.ini (or teradataatudioexpress.ini) you can edit the min and max memory allocation for your Java heap. I just upped the max memory and works like a charm now.

moveout 4 posts Joined 10/14
30 Dec 2014

I wanted to bump this thread and see if there is more information.
I'm having similar problems in that when I first start TDStudio it seems to keep up with my typing (I'm a fairly fast touch-typist), but after just a few minutes it starts to slow down, even with a relatively small file with less than 50 lines.
Here's my config:
-- Running OS X 10.9.5
-- Contents of TeradataStudio.ini (I don't remember if I modified them from the default):

-vmargs

-XstartOnFirstThread

-Dorg.eclipse.swt.internal.carbon.smallFonts

-Dosgi.requiredJavaVersion=1.6

-Xms512m

-Xmx2048m

-XX:MaxPermSize=1024m

-Djava.util.Arrays.useLegacyMergeSort=true

 

If there are some configuration changes you'd like me to try let me know. Thanks.

 

-Todd

 

 

fgrimmer 553 posts Joined 04/09
30 Dec 2014

Todd, Normally the TeradataStudio.ini file looks like:

-vm

C:\Program Files (x86)\Java\jre7\bin\javaw.exe

-vmargs

-Dosgi.requiredJavaVersion=1.6

-Xms512m

-Xmx512m

-XX:MaxPermSize=512m

-Djava.util.Arrays.useLegacyMergeSort=true

 

So it looks like your ini has been modified. You can try to increase the -Xms512m parameter. Also, turn off the 'Code  Autoactivation' option in the top SQL menu to prevent background operations that look up databases, tables, and columns for SQL code completion.

moveout 4 posts Joined 10/14
17 Feb 2015

Thanks for the reply - note that I'm running OS X, not Windows... =)
Wanted to follow-up: I think my problem was some large files - 7K+ lines. Not sure if there is a bug logged against that, but honestly we have more than a few files that large. I have a workaround for now.
Thanks again.
-Todd
 

You must sign in to leave a comment.