All Forums Teradata Studio
mahesh 4 posts Joined 06/04
18 Mar 2013
Location of SQL History in Studio

  I am trying to IMPORT a large (64 MB)  SQL History from a XML file (which was EXPORTed on another machine using Studio) to my local machine and it looks it is not doing anything.  I am trying to figure out where exactly the SQL History is stored in Studio, so that I can probably manually add my entries there. I searched in Workspace and I couldnt find a clue where the SQL History is stored for Studio. Any help?

Thanks, Mahesh Bank of America
ramesh.d 6 posts Joined 11/10
18 Mar 2013

Hello Mahesh,
You need not manually do entries into history.  Is there an error displayed while you are trying to import the History XML? You could check the error log by selecting Window-> Show View -> Other Windows -> Error Log.
Procedure to Import:
1) Click on Import History tool bar button from Teradata SQL History View.
2) Browse the History XML and in the source types select "History (*.xml)" and click on OK.
If still things are working, can you zip the XML file and attached it here.

ramesh.d 6 posts Joined 11/10
19 Mar 2013

Mahesh, looks like you have got java heap out of memory error. Could you increase the heap space by editing the TeradataStudio.ini from the path: C:\Program Files\Teradata\Client\14.00\Teradata Studio , 
and modify below lines,

mahesh 4 posts Joined 06/04
20 Mar 2013

Thanks Ramesh. I tried with 1024 but it failed with a different error now.  here is what I am trying to do, tell me I am doing anything wrong. I have a 64 bit Studio install on my Windows 7 PC and I am trying to import my SQL Assistant history MDB file into the Studio.  Then I saw the limitation of 32 bit MDB file importing into 64 bit Studio in the documentation, I tried a different route. I used a 32 bit Windows XP with 32 bit Studio install, and exported my SQL Assistant MB file into a XML file and hoping I would able to import that XML file into the 64 bit Studio and that is where I ran into this issue. I noticed the heap error and tried increasing the size to 512 and failed. Now I increased to 1024 based on your suggestion and it failed with a different error "Character reference "#x19" is an invalid XML character". I found a SQL with x19 tag and removed the entire HistoryItem for that entry, but now a different error. So my question, Is there a easy way to Import the SQL Assistant MDB file into 64 bit Studio? Appreciate your response.

Bank of America

ramesh.d 6 posts Joined 11/10
02 Apr 2013

Mahesh, Looks like becuase of invalid XML characters in the history SQL, the java SAXParser is thowing out error while loading the XML.
As you have mentioned that you are successful in importing the history from SQL Assistant using Teradata Studio 32 bit on Windows XP machine, could you try below to copy the history db from Studio 32 bit to Studio 64 bit.
Back up or rename your history folder on destination machine before trying this.
Copy history folder from Windows XP (Studio 32 bit) whose path is: C:\Documents and Settings\Mahesh\workspace-studio\.metadata\.plugins\com.teradata.datatools.sqldev.history\History
To Windows 7 (Studio 64 bit) folder: C:\Users\Mahesh\workspace-studio\.metadata\.plugins\com.teradata.datatools.sqldev.history\History
Replace bolded username with appropriate logged on user names from the above path.

lucasfilm 10 posts Joined 05/09
30 Oct 2014

I encountered the same problem, and this post helped me to get a workaround. So thanks Guys! On my 64Bit Citrix machine nothing happend. No errors, and no SQL History fil was imported from the .mdb version. Hmmm.... I went back to the 32Bit machine and started importing everything. Then a meassage box popped up showing "Row X of Y imported". Perfect! Since we are running Citrix, both my machines shared the same workspace. So i just closed down the 32Bit version and opened the 64Bit version, and there all my old SQL Assistant history showed up!

You must sign in to leave a comment.