All Forums Teradata Studio
hkratzer 2 posts Joined 10/12
21 Aug 2013
jre 1.6 is required for TS application warning, failed TS install

I can't seem to get past the the JRE 1.6 is required warning when installing TS on a Mac with Mountain Lion. I was not able to find JRE 1.6 so I installed the latest from Oracle...version 7 update 25. Any MBP users out there for a little help?
Thanks.
Hank

ramesh.d 6 posts Joined 11/10
22 Aug 2013

Can you submit below ls -l command to check whether there is 1.6.0 folder. The current installer checks this folder for required JRE version.
ls -l /System/Library/Frameworks/JavaVM.framework/Versions
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.4 -> CurrentJDK
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.4.2 -> CurrentJDK
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.5 -> CurrentJDK
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.5.0 -> CurrentJDK
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.6 -> CurrentJDK
lrwxr-xr-x  1 root  wheel   10 Aug 22 03:24 1.6.0 -> CurrentJDK
drwxr-xr-x  7 root  wheel  238 Aug 22 03:26 A
lrwxr-xr-x  1 root  wheel    1 Aug 22 03:24 Current -> A
lrwxr-xr-x  1 root  wheel   59 Aug 22 03:24 CurrentJDK -> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents

hkratzer 2 posts Joined 10/12
22 Aug 2013

Thanks, Ramesh. This is all I have. Like I said, I cannot find 1.6 install package...only the update packages for 1.6 which require 1.6 already installed. Besides, I thought TS worked with 1.6 AND ABOVE...
 

drwxr-xr-x  7 root  wheel  238 Mar 23 12:06 A

lrwxr-xr-x  1 root  wheel    1 Mar 23 12:06 Current -> A

ramesh.d 6 posts Joined 11/10
22 Aug 2013

Hank, can you try updating java from Apple Menu -> Software update, and check if the 1.6.0 directories are created.
If above doesn't work out, you could try below workaround to create a soft link by running below commands. But this assumes that you have already installed 1.7 JRE and from oracle site and it has updated the current jre version.
1) cd /System/Library/Frameworks/JavaVM.framework/Versions
2) ln -s /System/Library/Frameworks/JavaVM.framework/Versions/Current 1.6.0
 

LBL_TERADATA 1 post Joined 03/14
19 Mar 2014

sam issue here. I have a higher version of JRE (1.7) on my mac but the installization keep giving me the JRE 1.6.0 error. 

Baolei Li

fgrimmer 553 posts Joined 04/09
19 Mar 2014

Baoki, We have seen a problem where the latest 1.7 JRE (JRE 1.7.0_51) install is not updating the PATH. Can you bring up a Terminal window and try the java -version command to see if it recognizes Java JRE that you installed.

BerkeleyMalagon 1 post Joined 10/13
04 Apr 2014

I'm having the same issue. Has anyone found a resolution?

fgrimmer 553 posts Joined 04/09
07 Apr 2014

Berkeley, Are you able to verify the active JRE using the java -version command?

davidpracy 22 posts Joined 09/05
08 Apr 2014

To get around the install failure referring to JRE 1.6 install the following
http://support.apple.com/kb/DL1572?viewlocale=en_US
 
davidpracy

aloklal99 1 post Joined 04/14
28 Apr 2014

I have similar issue.  Here is the output for the question that ramesh.d asked:

$ ls -l /System/Library/Frameworks/JavaVM.framework/Versions
total 8
drwxr-xr-x  9 root  wheel   306B Mar 27 18:19 A/
lrwxr-xr-x  1 root  wheel     1B Feb 25 15:14 Current@ -> A

And here is the output of the question fgrimmer asked

$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)

I am hesitent to try the install of JRE 1.6 as I already have 1.7 installed and the install page (http://downloads.teradata.com/download/tools/teradata-studio) says 1.6 or higher is required -- which I do have installed.
Not sure if it matters but here are some additional pieces of information.
 
I use macports.  I have the following as the first line in my bash profile (which is the one from where I got the above output of java -version).

# path for macports
PATH=~/bin:/opt/local/bin:/opt/local/sbin:${PATH}; export PATH

Also I manually set the JAVA_HOME in my bash profile as follows:

# development stuff
JAVA_HOME=$(/usr/libexec/java_home); export JAVA_HOME

 

fgrimmer 553 posts Joined 04/09
08 May 2014

Alok, We are investigating this issue. We have found a reference that suggests there is a problem with applications using Oracle JRE 1.7 (instead of Apple JRE 1.6) on Mac OSx. We are trying to find a work around for this. 

fgrimmer 553 posts Joined 04/09
09 May 2014

Alok, From what we can determine, the Eclipse launcher that is built into Studio supports the Apple JRE 1.6 location. It appears that the only option may be to install the Apple JRE 1.6.

jon-teradata 2 posts Joined 06/14
30 Jun 2014

When will this issue be resolved?
If you are planning not to resolve this issue, please update your web page to indicate that the JRE 1.6 is required and that later versions are NOT excpeptable! Stating that "JRE 1.6 or later" is very mis-leading and frustrating for those attempting to install on Mac OS. A lot of time is wasted unless you happen to find this thread and scroll to the bottom.
https://downloads.teradata.com/download/tools/teradata-studio-express
 

fgrimmer 553 posts Joined 04/09
30 Jun 2014

Jon, we plan to resolve this issue in our next release.  I will update the download page for now.

jon-teradata 2 posts Joined 06/14
30 Jun 2014

Thanks much! I really appreciate the response.
Any timetable for the next release?

fgrimmer 553 posts Joined 04/09
30 Jun 2014

Current plans show 4th quarter this year.

Thorkil 3 posts Joined 07/14
03 Aug 2014

I am very new to Teradata. I had problems on this Win8 64bit laptop.
Problems with the JRE 1.6 Path.. when trying to install Express Studio
Problem was solved after manually installation of 64bit java:
http://java.com/en/download/manual.jsp
My guess it that my 32bit browsers installs the 32bit java...
But I am not quite sure...
Anyway... Now Studio is installed  :-)
Regards
/T

 

romank 1 post Joined 10/14
24 Oct 2014

Hi, I was able to install Teradata Studio on Mac OS X 10.9.5. Steps:
1. the restriction on java version is in the file /Teradata Studio.pkg/Contents/Resources/preflight:
$javafile = '/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/java';
so I just created folder:
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/
and copied "java" file into it.
after that installation went well.
 
2. I'd also added 1 line into 
/Applications/TeradataStudio/Teradata Studio.app/Contents/Info.plist
<string>-vm</string><string>/System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java</string>
but I'm not sure it was necessary. 
2. When starting (newly installed) Teradata Studio application there was a warning that java 1.6 was required, but the application itself suggested to download and install the correct java from Apple (using software update) and after that it started successfully.
 

fgrimmer 553 posts Joined 04/09
26 Oct 2014

Roman, Thanks for the information. We have resolved this issue in our next release.

KeithRose 3 posts Joined 10/11
08 Dec 2014

Hi Francine. Are you able to provide a date yet on when the version that fixes the V1.6 issue for Macs will be available?  Thanks Keith.

fgrimmer 553 posts Joined 04/09
08 Dec 2014

Keith, It is looking like some time in April 2015.

KeithRose 3 posts Joined 10/11
08 Dec 2014

Thanks Francine, probably not the best answer I was hoping for.  We're a Teradata Partner and I'm trying to get all our consultants to run their own version of Teradata, Astor, and tools etc on their own laptops, whatever that may be, so they can experiment to their hearts content with no limitations on what they can do.  I've worked with Teradata for over 23 years, 15 actually with Teradata in Australia, I started with the original Teradata Corp, pre AT&T, and I've found having my own version of Teradata that I can try anything on, just so useful.
I'm sure you'll keep us up to date on progress.
Again, thanks for your reply.
Keith.

ryang1234 1 post Joined 04/15
27 Apr 2015

Hi Francine, are we still looking at this month for this to be resolved?
Thanks,
Ryan

You must sign in to leave a comment.