All Forums Teradata Studio
k1ng 16 posts Joined 06/08
07 Oct 2014
can't see tables in data source explorer

for some reason, I can't see tables in teradata studio's data source explorer but I can see them in teradata sql assistant. I can run the queries against the table fine in teradata studio but for some reason I can't see the tables or views that I can see via teradata sql assistant. I also tried turning on the USEXVIEWS parameter in the jdbc connection properties but still no luck...


in the database explorer all I see is:




-->A folder called Databases (seems like only system stuff in here)


why can't I see the same tree layout in Studio that I see in SQL Assistant?

fgrimmer 553 posts Joined 04/09
07 Oct 2014

Ronak, To see the list of tables, you need to locate the database or user they are in, and since Teradata Databases or Users can be nested, you may need to locate ancestors first. If you're not sure about the ancestry of your database, you can change the display to not show the hierarchical display and all databases and users in a flat list. (Go to Preferences>Teradata Datatools Preferences>Data Source Explorer Load Preferences and uncheck 'Show Databases and Users in Hierarchical Display'. Once you've located the database or user, click the Tables folder to see the list of tables.

You must sign in to leave a comment.