All Forums

Topics cover the Teradata Studio product family. This includes Teradata Studio, Teradata Studio Express, and Teradata Plug-in for Eclipse. For articles, blogs and more, see the Tools section of the site.

You must login to post to the forums.
Getting row counts Topic by bmcclernan 17 Jan 2014

When you get a result set with more than 2000 rows (or whatever you have your limit set to), the prompt doesn’t tell you how many rows you are going to get if you click OK to continue.  This makes it difficult to decide if you want to bypass the limit.

13 replies, 5 years ago
Teradata 15.1 Error when trying to execute query Topic by slemmer 07 May 2015

Had Teradata Studio 15.0 loaded on Windows 7.0.  Then upgraded to Studio 15.1.  I now get the error below when trying to execute a query.
java.lang.ClassCastException: org.eclipse.datatools.sqltools.db.generic.service.GenericSQLService cannot be cast to

17 replies, 5 years ago
Teradata Studio on Mac OS X -- Hangs Topic by astocks 19 Feb 2016 teradata studio, mac

For some reason Studio has started freezing up over the last day.  I will be working in Studio and then suddenly I will get the pinwheel spinning forever and the application stops responding.  I have updated to the most recent version of studio and still experience the same behavior.  Nothing has changed on my system in the last couple of weeks.  Any ideas on what I can try?

25 replies, 5 years ago
Studio Express severe keyboard lag Topic by SNguyenWF 22 Jun 2016

I am experiencing severe keyboard lag with Studio Express ever since I installed it couple months ago.  It started with the previous version ( and still exists with 15.11.
My laptop: Windows 7, Intel Core i5 @ 1.90Ghz, 8 GB RAM, 64-bit.

18 replies, 5 years ago
Why is the first dynamic result set in a procedure is empty? Topic by sharonn 11 Aug 2016 dynamic result set, empty result set

I have a procedure that has 1 dynamic result set defined in it.
When i call the procedure from TD studio i get 2 result sets:
1) Empty - no rows and no columns
2) My result set
When i call it from c# application i get only 1 - my result set.

3 replies, 5 years ago
Terdata Studio Express laggy on mac Topic by jingguo 04 Sep 2016

Hi ,
I am using Teradata studio on mac and the typeing on the tool can be very laggy.
my OS version El Capitan 10.11.6
Teradata Studo Express 15.11
I searched on the this webiste and applied following setting and it improved a little bit, the laggy time reduced from 4 seconds to 2 seconds - still bad experience when using this product

6 replies, 5 years ago
Option "User Choice (includes DBC)" not available in Teradata Studio 15.11 Topic by xinyuzhang 02 Sep 2016 teradata studio, Data Source Explorer Load Preference

I installed Teradata Studio 15.11. For Data Source Explorer to list less objects, from Windows--Perferences--Teradata Datatool Preferences -- Data Source Explorer Load Preference, I try to select User Choice (includes DBC) for What to load. However, this option is grayed out.
I don't have the problem with the version 15.10.
Any idea?

2 replies, 5 years ago
Unable to connect to the database using Teradata Studio Express. Topic by rohitbeth 09 Feb 2014 connectivity, create user, access rights of existing user, access teradata

I have installed the Teradata express 14 edition using vmware. I was able to setup the connection using Gnome Terminal, however I am unable to connect to the database using the Teradata Studio Express. 
I have tried using the same creditials as used in the Gnome Terminal for bteq which is :

13 replies, 5 years ago
Teradata preferences for new connection profile type missing Topic by danisusb 19 Aug 2015 teradata studio, oracle, connection profile

I'd like to connect to a Oracle database using Teradata Studio 15.0.01 but I'm missing the tab "New Profile Connection Types" in "Window" - "Preferences" - "Teradata Datatools Preferences".
Any ideas?

12 replies, 5 years ago
Views the rows being transferred over Topic by fomer 29 Aug 2016 datatransfer

Once a Teradata Studio Job Transfer has been started(migrating from pipe delimited flat file into Teradata), is it possible for me to view how many rows have been moved? I am trying to transfer a 70 million row file.

5 replies, 5 years ago
Need to reinstall Studio Express 15.10.1 (last working version): where to find it? Topic by romanoww 31 Aug 2016

I've read about the Teradata Patch Server but have no idea how to reach it.
Could anyone tell me where to find a version of Studio Express 15.10.1?

1 reply, 5 years ago
Configurer Data Transfer Error Files Topic by Sean_Kelly 24 Feb 2016 Teradata Studios, Error File, data transfer

Hello All,
I'm new to Teradata Studio's, is there a way of changing the error files generated by the data transfer process to a dedicated folder?

4 replies, 5 years ago
Tools > Create > Database, User etc. dialogs missing in Teradata Studio Express 15 Topic by Loped123 03 Oct 2014

Is there a possibility to get the Create database, user etc. dialogs into Teradata Studio Express 15 the same way as they were (in Tools tab) in version 14.10? Or are they somewhere else?
If not, is version 14.10 able to access TD database version 15 and do the job? Is there a possibility to downgrade to version 14.10?

4 replies, 5 years ago
TDStudio stopped working after Java update Topic by HenryJing 28 Apr 2016

My TD studio (15.10) worked perfectly till 2 days ago, when I got prompt for updating Java.  But after the Java update ( Version 8 Update 91), when i opened the Studio, an error window showing below:
"A Java Runtime En(JRE) or ...(JDK) must be available in order to run TeradataStudio.  No Java virtual machine was found after serching the following locaitons:

8 replies, 5 years ago
Looking for a TD Studio 14.10 install package Topic by BB160003 21 Aug 2016

Preparing collateral for a customer that uses Studio 14.10. I skipped the 14.10 versions of all utilities and went straight to 15.10. Looks like the interfaces have changed a bit and I now need a 14.10 version ASAP. Have not found it in downloads. Can anyone help?

2 replies, 5 years ago
Parameterized Queries result in error (1095 - cannot call a method on closed connection) Topic by tbenard 16 Aug 2016 parameter, 1095, Parameterized

Hello, I am using TDS  I have tried both unnamed parameters "?" and named parameters "?\MyParm" however I get the error shown in the subject of this post.  e.g.,:
Select * from MyTable where MyField = ?\MyParm;  (also tried within single quotes)
That does not work... and what I REALLY want is this:

1 reply, 5 years ago
How to solve the error "Creating connections to local Teradata Database has encountered a problem" ? Topic by tanmayku 17 Aug 2016

I'm a new Teradata user. I just installed Teradata Express VM edtion. When I open Teradata Express Studio, I get the error mentioned above in the title. 
Further I get following details regarding the error:

Could not connect to Local Teradata Database.

5 replies, 5 years ago
Teradata Studio does not show all of my authorized tables- Topic by mhussey 20 Jun 2016

I started working on a new project a few weeks ago, which requires me to use Teradata, Hadoop, and Aster. That being the case, I want to use Teradata Studio instead of Teradata SQL Assistant. Connections to Hadoop and Aster were created perfectly and are working fine.

15 replies, 5 years ago
Code Assist functionality questions Topic by gloxton 15 Jun 2016 code assist

I have been asked a number of questions about Code Assist, and wanted to know if anyone knows of any additional insight into its functionality before I respond with the results of my testing:
1. Does the user have to code "DatabaseName." to get a list of tables?
    - from my testing the answer is Yes apart from tables in the default schema

5 replies, 5 years ago
Teradata session for volatile tables Topic by SNguyenWF 04 Aug 2016

What constitutes a session for volatile tables.  I would naturally have thought that when opening multiple tabs that are connected to the same connection profile, volatile tables would be shared among them all.  However, that doesn't always seem to be the case.  If I create a volatile table in one tab (editor window), it's not always accessible in another tab.

3 replies, 5 years ago
Not working: Default connection for new SQL files Topic by SNguyenWF 04 Aug 2016 connection profile, SQL Editor

Under Preferences > Data Management > SQL Development > SQL Editor > SQL Files/Scrapbooks, there's a setting for "Default connection information for new SQL files/scrapbooks".  From here, the user selects the database type and name.  This setting doesn't seem to be working for me.  I have it set for a particular Teradata connection.

3 replies, 5 years ago
DB2 JDBC connections not showing in SQL Editor Connection Profile: dropdown Topic by dafydh 24 Jun 2015 studio, SQL Editor, DB2 connection, connection profile

Good Morning,
I am using Teradata Studio, on Win 7, with the IBM JDBC drivers.
I can create a connection to our DB2 z/os database, and see all our schemas and tables.  I cam right click a table and sample the data. I can even see the SQL that the sample data produces.

11 replies, 5 years ago
Teradata Studio Express - OLD Versions Topic by MONCALIERI 26 Jul 2016 teradata studio express, #database #teradata express #support utilities

Hi all,
Where I can find the Old version of TD Studio Express.
I mean the version 15.00 or 15.10 , because I have problems with Data Lab view, so I need to try the old version.
Anyone could help me ?
Thank you

2 replies, 5 years ago
Kerberos Authentication Topic by rob_watson 28 Apr 2016 kerberos

has anyone managed to connect to Teradata in Teradata Studio using Kerberos (KRB5) authentication successfully ? It works fine for me in BTEQ and SQL Assistant , but the result from Studio is always ping failed. I can connect from Studio using other authentcation methods , it is just KRB5 I am having problems with.

5 replies, 5 years ago
TD Studio data transfer unexpected token Topic by 12 Jul 2016

I'm creating a test for transfering data using TD Studio 15.10.11 running on an iMac OS X 10.11.5 with lots of memory and disk.
On the same machine, I have a TD VM Express 1TB version 14.10

12 replies, 5 years ago