All Forums

Covers Teradata-developed applications such as TRM, DCM, etc. For articles, blogs and more, see the Applications section of the site.

You must login to post to the forums.
Substring Function in Teradata Studio Topic by aniyash2006 07 Nov 2014 substring, error, substr, teradata studio

SUBSTING function is giving error in Teradata Studio which was working fine in Teradata SQL Assistant.
My Query is like this : SEL SUBSTRING('ABC',1,2)
I do not want to use SUBSTR instead of SUBSTRING as it involves making changes in a lot of Queries. Please suggest a work around for this issue.
 
Thanks!
Anirudh

14761 views
1 reply, 4 years ago
1597 views
1 reply, 4 years ago
FASTEXPORT - Sorted order two further distribution between amps. But Why? Topic by Sankalp.C 04 Sep 2014

In fast Exprot If we order SORTed way two further Distribution between amps will be required. But Why?

1161 views
4 replies, 4 years ago
FASTLOAD / MLOAD Data Parcel How to See what inside? Topic by Sankalp.C 02 Sep 2014

Hi,
In FLOAD and even MLOAD in ET_TARGET_TABLE, in case off error we get data Parcel. But How to analyse it? How to see what inside?
 
Thanks!
Sankalp

1339 views
2 replies, 4 years ago
diff between volatile and GTT table with ON PRESERVE COMMIT statement Topic by sammath7 02 Sep 2014 #Volatile tables

Hi,
I am a newbie in Teradata and trying to know the basic concepts. I was able to understand the basic difference between Volatile table and GTT
Volatile table - exists only during the session and table structure and row contents deletes after the session

963 views
1 reply, 4 years ago
Partitions on Existing TD 14.10 table Topic by rohit.lalwani1 28 Aug 2014

Hi
I have a table which has approx 7.8 million records there is no partition on table as o now.
We have to create a partition on date column (posting date). Is that possible to create on existing table or we have to create a new table with patitions on it and then copy data or rename it ?
Please advice

1012 views
1 reply, 4 years ago
Easyloader data transfer issue Topic by firstj 22 May 2014 Easyloader

Has anyone experienced issues with using Easyloader to transfer data between servers?
When attempting to copy data from one server to another (on the same version of Teradata) to Arctic a column with data type Decimal(38,20) through up an error relating to field length.  Below is a log of the commands / responses: -
 
$ LANG=en_GB
$ export LANG

1929 views
5 replies, 5 years ago
How to handle failure statement in Bteq ? Topic by rohit.lalwani1 13 Aug 2013

Hi ,
I am trying to create a bteq  script which run multiple Insert statements through sql file. 
Supose i i have a file like abc.sql, In that i hv 10 Insert statements like
(Insert .... ;
Insert... ;)
now i run this file in Bteq using .RUN FILE abc.sql

4211 views
5 replies, 5 years ago
Is anyone actual using Unity Source Link to read Oracle from Teradata? Topic by jharvat 04 Jun 2014 unity source link, oracle, teradata

Hi -
For certain use cases, Unity Source Link seems like just the thing to get us out of the ETL business.  We are just now rolling out 14.10 and installing and configuring our Unity servers.  My question - is anyone out there actually using Unity to read Oracel databases from Teradata?  If so, what are your impressions - ease of use - performance - etc.?

1476 views
3 replies, 5 years ago
Converting TimeStamp into Date Topic by rohit.lalwani1 18 Jun 2014 #teradata

Hi 
I have two timestamp fields which i'm using in joining condition but values are slight different in it like below.
Posting Date   : value(2014-01-09 00:00:00)
Eff_from          : value(2014-01-09 15:08:29.000000)
Join condition  : Posting date >=  Eff_from   { this shuld be true in my code for above values but it's failing because of time}

1226 views
3 replies, 5 years ago
How to Pass mutliple values from text file to parametrized bteq Topic by gbansal 18 Jun 2014 bteq, Pass Values to SQL Parameter

Hi ,
i have extracted below two records in a file
Start_Date     End_Date
2014-01-01    2014-06-30
2014-07-01    2014-12-31
 
i am pasing this a query now
select * from tablename where Start_Date = {Start_Date}
and End_date = {End_Date}
Earlier i was passing only one row but now i am passing two values

1695 views
3 replies, 5 years ago
Change UPI column Topic by rohit.lalwani1 26 May 2014

Please Guide how can i change UPI column without creating a new table and copy data & rename method ?

968 views
2 replies, 5 years ago
Shared ICU Libraries.. Topic by moizzoaib 01 Oct 2013 oledb

hello,
 
I am Installing Teradata OLEDB Provider For .Net when I run the Setup I get the Following Message.
"A compatable version Of Shared ICU Libraries For Teradata is not Installed. OLEDB Provider For Teradata requies Shared ICU Libraries for Teradata 14.00."
 
 Regards
Moiz Zoaib
 

4087 views
2 replies, 5 years ago
Query banding & TWM Topic by IM520011 13 Nov 2013 ADS banding

Does anyone have experience implementing "Query Banding" on "ADS Generator" or "TWM"?
ADS Generator uses ODBC Connections and every analysis executed by users are executed in a different session.
Any ideas will be appreciated.

1699 views
2 replies, 5 years ago
PPI Topic by pavanvarma4858 15 May 2014

What is a PPI and how does it help increase the performance while retriving data

882 views
1 reply, 5 years ago
protect table from being deleted Topic by wangguojie2006 08 May 2014

Hi all,
we are using data lab to store some tables. so accedentally people can drop other people's table. Is there any solution that prevent that from happening? Can i create a table that only myself can delete?
many thanks.

993 views
3 replies, 5 years ago
Table properties and utilities to load data Topic by keets_teradata 27 Mar 2014 teradata Utilities, Physical Implementation of tables

How Data Block size, checksum & Perm DB size of a target table play a role when loading Bulk data using Fast Load and Transactional Loading like TPUMP or BTEQ file load?
Basically I am trying to understand, How a table should be designed based on the Load utilities that is going to be used.

1322 views
4 replies, 5 years ago
Nexus Query Chameleon Topic by deep717 12 Feb 2014 Nexus, sql, error, Query Chameleon, TeraTom, Coffing, syntax error

Is there any way we can specifically identify the error line number in Nexus Query Chameleon?
If not, can we somehow code this in or run a statement before running our actual code?
I know SQL Assistant can do it.

1722 views
2 replies, 5 years ago
Error Code: 2796 MLoad MARK MISSING DELETE Topic by jujeedeeda 18 Mar 2014

Hi all,
I have problem when mload is processing. I found error in error tables error code 2796; however, data are still loaded to taget table but it is quite slow because of this error.
Could you please suggest me what is the cause of this error?
Thank you

1363 views
1 reply, 5 years ago
Use TD Utilties through SAS Base Topic by gb_teradata 21 Mar 2014

Hi All,
I am a beginner is Teradata. I wanted to know how can we use TD Utilities like FLOAD, MLOAD etc through SAS Base to insert/update rows in TD tables
Thanks,
Garima

799 views
0 replies
Teradata Index Wizard Installation - Error Topic by Teradata_SA 19 Mar 2014

Hi,
After filling in the required fields on the "Setup QCD" screen I have clicked create to be returned with an error.
I have the create Database Permissions and create table permissions required.
[Teradata][ODBC Teradata Driver][Teradata Database] Object 'SystemFe.CreateQCFVer' does not exist.
Does anyone have any idea how to resolve this ?

868 views
0 replies
Fast Export for tables having more than 600 Columns Topic by LearnTD14 12 Mar 2014

Hi,
I am facing an issue with fast export. I am extracting data using Fast export on unix environment from table which is having more than 600 columns. Now after extraction, one record is broken into multiple lines. For e.g,
col1|col2|col3....|col10
|col11
|col12|col13|col14
|col15|col16|col17....|col650
 

1117 views
3 replies, 5 years ago
[Teradata][ODBC Teradata Driver][Teradata Database] Table/view/trigger name 'item' is ambiguous Topic by taiho 12 Mar 2014

Hi there,
I ran a VBA to fetch data from Terada but got this error message.
[Teradata][ODBC Teradata Driver][Teradata Database] Table/view/trigger name 'item' is ambiguous.
But when I ran the SQL manually, it worked. Do you know why? Many thanks. Tai
 

1203 views
2 replies, 5 years ago
Error code 2656 in TPT Load Topic by rragavn 21 Feb 2014 teradata paralled transporter

we are using TPT connection to load a table in informatica , session was runing for long time and load got failled due to this error.

TPTWR_2656 [ERROR] Type:(Teradata DBS Error), Error: (AUDIT_HISTORY Load error: bad internal status - LSN not found.)

Can someone please tell what caused this error and remedy for this

1302 views
0 replies
Issues with Teradata 14.10 jars Topic by sandeep569 20 Feb 2014

Hi all I am using Teradata 13.10 database and we are migrating to 14.10 and when I tried to test my application with latest jars I am getting follwing execptions
Here is the code and follwing query 

private Map getReclaimsBetweenIDIR(String applicationName) {

HashMap queryMap = new HashMap();

queryMap.put("applicationName", applicationName);

1023 views
0 replies

Pages