All Forums Teradata Applications
jdliau 10 posts Joined 09/13
29 Sep 2014
FastLoad process hang with concurrent sessions

Hi,
We have an application spawns multiple FastLoad sessions to move data from Microsoft SQL server to Teradata concurrently. We are running the application on Microsoft Windows Server 2012 R2 and have been observed random errors where some FastLoad sessions in hung state. 
When the process hangs, in the FastLoad generated log file, it always stops at AXSMOD command, "0009 AXSMOD Oledb_Axsmod "noprompt jobid=1”;".
We tried to add "-v" option to FastLoad command but no usefaul information in FastLoad log file. Looks like there is an issue for multiple FastLoad sessions connect to OleDB driver at the same time but we are not sure. Is there anyway we can troubleshoot the issue other than adding "-v" option to FastLoad command?
Best,
J.D.
 
 
 
 

Raja_KT 1246 posts Joined 07/09
30 Sep 2014

I have never loaded from SQL Server and do not have much idea. My opinion -----Anyone monitoring viewpoint? The link below gives an explanation on AXSMOD too if it helps.
http://www.info.teradata.com/HTMLPubs/DB_TTU_14_00/index.html#page/Load_and_Unload_Utilities/B035_2411_071A/2411Ch03.026.010.html

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

jdliau 10 posts Joined 09/13
30 Sep 2014

Thanks for the reply! The information does not really help. Maybe I should rephrase my question...
Is there any limitation about running miltiple concurrent FastLoad sessions on Windows Server 2012?
 
 

Raja_KT 1246 posts Joined 07/09
30 Sep 2014

 I am bad in Windows env :) to be honest.

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

frnewbrough 41 posts Joined 03/08
30 Sep 2014

How many concurrent processes are you running? What I'd do is run load tests with varying levels of concurrency to see how reliably I can reproduce the error and to see if lower levels of concurrency mediates the error. 

jdliau 10 posts Joined 09/13
30 Sep 2014

The concurrency is 5 but we observed the same issue even at 3. We are wonering if this only happens on "Windows 2012 R2" because we have another machine running "Windows Server 2008 R2" and it seems to be handling 5 concurrent FastLoad sessions without any problem. If TD can identify the issue, will be very helpful to other customers using Windows Server 2012 as FastLoad platform.
We are using td-ttu-14.10.
 

frnewbrough 41 posts Joined 03/08
01 Oct 2014

Thats good info. Concurrency of 5 is fairly low. If you aren't having the problem on another machine then I think we can be fairly certain its localized to your "Windows 2012 R2". The next test I'd do is to find another "Windows 2012 R2" server to run the test on and see if you have the same issue. If you don't have another server I'd try uninstalling the TTU and reinstalling it. You might also run a full diagnostic on the "Windows 2012 R2" server to see if there are any other problems. The other option is to submit a ticket with TAYS (Teradata At Your Service) or call  the Teradata GTS(Global Teradata Support)  877-698-3282 to submit a ticket. I've never seen this problem before myself. 

jdliau 10 posts Joined 09/13
06 Oct 2014

We tried this on four different Windows Server 2102 R2 machines and they all have the same issue. Another data point is our ETL servers are on AWS and accessing the Teradata Server in our data center. We have direct connect between AWS and our data center so the latency is very small.
We will open a ticket at TAYS.
 

raj786 23 posts Joined 04/14
14 Oct 2014

hi 
can any one tell me is it compolsoury that datatype of source file in informatica should be match with datatype of table in teradata  
if i use fastload.
i am loading file to teradata table through informatica by using fastload.

Raja_KT 1246 posts Joined 07/09
14 Oct 2014

You could have created a new topic :).
With Td 14 onwards most of the datatypes are available/compatible with almost all ETL tools or interfaces.eg Char , varchar may work. But it may fail in certain scenarios. Why to give chance for an error to creep in.

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

pback 1 post Joined 09/14
06 Nov 2014

Hi,
I'm new in FastLoad scripting but I have to use it :)
I would like to load a file like this:
1000001,
1000002,
1000003
and as I see have to use the SET RECORD TEXT ","; in my script. But in runtime I got this message:
 

0003 SET RECORD TEXT ",";

 

**** 17:43:31 Now set to read 'TEXT' records

**** 17:43:31 Command completed successfully

**** 17:43:31 Warning: Extra text after command found.

              The text '',';' not processed.

 

I tired to search a solution for my problem in other topic but the last message was 1 years old :)

 

Thank You.

raj786 23 posts Joined 04/14
19 Jan 2015

Hi 
 
i am using fast export.when i running in dev server its running fine but when i am running in SIT server the informatica session is in only running condition.
 
i saw the log file in that it shown that log table restarted in progress. what can i do now so that it will succesful.
please send some detail docuent about fast export and how to use this
 
 
Ragards
raj

You must sign in to leave a comment.