All Forums General
escueta 4 posts Joined 05/14
25 Aug 2014
Using Liquibase

Has anyone been able to use Liquibase with Teradata 14?
I keep on getting this error:

SEVERE 8/25/14 12:52 PM:liquibase: Connection could not be created to jdbc.terad

ata://wdstddbdev1 with driver com.teradata.jdbc.TeraDriver.  Possibly the wrong

driver for the given database URL

liquibase.exception.DatabaseException: liquibase.exception.DatabaseException: Co

nnection could not be created to jdbc.teradata://wdstddbdev1 with driver com.ter

adata.jdbc.TeraDriver.  Possibly the wrong driver for the given database URL

tomnolan 594 posts Joined 01/08
26 Aug 2014

I have never used Liquibase, but the error message indicates that the JDBC URL is incorrect.
Your error message shows a period (.) between "jdbc" and "teradata", but that is incorrect.
You need a colon (:) between "jdbc" and "teradata" in the URL.
For example:
jdbc:teradata://wdstddbdev1

itche_scratche 4 posts Joined 03/07
23 Jul 2015

Hi escueta,
Did you ever get your liquibase going? I was able to run the quickStart.
But when i tried to generateChangeLog for my database i got an error.
Unexpected error running Liquibase: liquibase.exception.DatabaseException: com.t
eradata.jdbc.jdbc_4.util.JDBCException: [Teradata Database] [TeraJDBC 15.00.00.0
9] [Error 3802] [SQLState 42S02] Database 'information_schema' does not exist.
I checked my database connection everything look correct.  But somehow it still think the schema is not there.

You must sign in to leave a comment.