All Forums General
04 Oct 2011
Problem with Timestamp in SQL assistant

I have  a column with datatype time(6). When i try to retrieve data, i get data with timestamp but millisecs part missing.

Whereas when i run the same script in Bteq, i get the complete timestamp(millisecs part included).

Can ny1 plse help me with it.

Teradata NooB.
dnoeth 4628 posts Joined 11/04
05 Oct 2011

Which release of SQLA?
ODBC or .NET connection?

Dieter

Dieter

10 Oct 2011

ODBC.

Teradata NooB.

Adeel Chaudhry 773 posts Joined 04/08
13 Oct 2011

Have you tried .NET connection?

 

And can you provide example including DDL, sample data and SELECT statement you are using?

 

Regards, Adeel

-- If you are stuck at something .... consider it an opportunity to think anew.

robpaller 159 posts Joined 05/09
13 Oct 2011

It may be helpful to know which version of ODCB and SQL Assistant you are using as well. 

Have you tried CAST(MyTimestamp6 AS CHAR(26)) in SQL Assistant to see if when returned to SQL Assistant as a CHAR() data type the Answerset grid control behaves differently? (Sounds crazy but I have my reservations about that grid.)

gotuchintu 32 posts Joined 12/05
31 Oct 2011

yes..even i hav also obeserved the same thing with SQLA. Try with BTEQ. You will get the exact data.

Somnath Roy

You must sign in to leave a comment.