All Forums General
rakeshsapbo 36 posts Joined 04/13
12 Sep 2014
Oracle Data used as Input for BTEQ

Hi All,
Greetings!!
I have tried to run a simple BTEQ Export data using Report Mode ,my source is Oracle.
i am facing an issue logging into BTEQ with Oracle credentials.
Quick Checks
verified the ODBC connection
User-->Scott
Pswd--> abcd
when i normally login to the SQL Asst it's connecting easily ,but when i tried to connect to BTEQ i am having the issue.
Observations
Normally when we connect using TD db 
.logon <TDDID>/<user>,<paswd>
***Login will be successful
when it comes to connecting to oracle i have tried to login using the same procedure
.logon 127.0.0.1/scott,abcd
Error Description

Microsoft Windows [Version 6.1.7601]

Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

 

C:\Users\rgopidi>bteq

 

 Teradata BTEQ 15.00.00.00 for WIN32. PID: 6808

 Copyright 1984-2014, Teradata Corporation. ALL RIGHTS RESERVED.

 Enter your logon or BTEQ command:

.logon 127.0.0.1/scott

 

.logon 127.0.0.1/scott

Password:

 *** Failure 8017 The UserId, Password or Account is invalid.

 *** Error: Logon failed!

 

 *** Total elapsed time was 6 seconds.

 

 Teradata BTEQ 15.00.00.00 for WIN32. Enter your logon or BTEQ command:

 
how do we resolve this issue or am i following the wrong procedure ,suggestions......???

Rakesh Reddy G
Raja_KT 1246 posts Joined 07/09
12 Sep 2014

Did you try with .logon 127.0.0.1/dbc and password dbc?

Raja K Thaw
My wiki: http://en.wikipedia.org/wiki/User:Kt_raj1
Street Children suffer not by their fault. We can help them if we want.

CarlosAL 512 posts Joined 04/08
12 Sep 2014

It seems you are a bit confused:
You cannot use bteq with ODBC connection (only Cli)
And most important: You cannot acces Oracle DB with bteq. You must use Oracle sql*plus or another compaible tool.
Cheers.
Carlos.

rakeshsapbo 36 posts Joined 04/13
12 Sep 2014

Thanks for the clarification...i get it now.

Rakesh Reddy G

You must sign in to leave a comment.