All Forums

Covers Teradata database extensibility, including UDFs, Geospatial and Hadoop / Map-Reduce. For articles, blogs and more, see the Extensibility section of the site.

You must login to post to the forums.
Geospatial data into Teradata Database Topic by bramhanaidu 03 Mar 2013

Hi

I am new to GeoSpatial data, I need to load Shape files into Teradata database. Could you please let me know what all the pre requisite softwares/utilities needs to be installed for loading this shape files into database.

Also suggest me on how the (.SHP, .SHX & .DBF) files are related to derive the geospacial data

4160 views
6 replies, 7 years ago
Queue to Queue Topic by RandiPedigo 07 Nov 2014

Hi,
 
I was wondering if anybody has or knows where I can find an example of a stored procedure that writes from a queue table in TD to an external queue (say activeMQ) via a stored procedure (JDBC connection). Anything would be helpful!
 
Thanks,
Randi

1085 views
1 reply, 7 years ago
SQL-H: Teradata to HDP: License Required? Topic by tluthra@att.net 23 Apr 2014

Hello,
I'm trying to run a SQL-H from Teradata 14.10 VM Image to a Apache Hadoop 2.2.0 single node cluster but it fails.

2029 views
3 replies, 7 years ago
Return a Concatenated string from User defined Funtion through Cursor Topic by Anantha 11 Sep 2014 udf, cursor

Hi,
 
   I want to get the list of employee names when i pass in the deptno as the input parameter in the user defined function. Below is the function Logic currently i have. I am getting the syntax error to use the for loop inside the case statement. Please correct me if am wrong in using the same and suggest any alternatives solution if possible.
 

1614 views
4 replies, 7 years ago
1058 views
1 reply, 7 years ago
process AL3 XML (insurance standard xml) in td Topic by Sayandeep 16 Sep 2014

Using XML service its possible to load xml file into tables and represent data in xml format. But is it possible to do the same for AL3 XML formatted data . If not possible then probable solution would be to convert it into normal XML file .
Please reply soon as I need to revert back.
PFB the sample AL3 file ,
 

1257 views
1 reply, 7 years ago
Import from Teradata to Hadoop error Topic by sj186043 09 Sep 2014

I am getting the following error while importing data from Teradata to Hadoop. Can anybody help please?

1119 views
1 reply, 7 years ago
urgent : teradata xml service installation Topic by Sayandeep 08 Sep 2014

Hi,
I am having teradata 14 vmware express edition 4gb linux version and I am trying to install teradata xml service 14 into it . have done following till now,
home/tdatuser # mkdir xml
:/home/tdatuser # chmod 777 xml
:/home/tdatuser # cd xml
:/home/tdatuser/xml # mkdir TeradataXML.14.00.00.00
:/home/tdatuser/xml # chmod 777 TeradataXML.14.00.00.00

1024 views
0 replies
REGEXP_SUBSTR in Teradata 13.10 Topic by StevenSchmid 07 Sep 2014 regexp_substr

Hi

1733 views
3 replies, 7 years ago
Projecting A 3D Sphere Topic by newton1965 14 Jul 2014 Geospacial Sphere Coordinates

I'm very new to this, so I know very little about how I need to achieve my goal using the Teradata geospatial functions.

1094 views
2 replies, 7 years ago
SQL-H - new install Topic by bakster 09 Jul 2014

We just had SQL-H installed on our dev/test appliance 2750 and we are having an issue using the COLUMNS('*') parm in SYSLIB.load_from_hcatalog.  We receive the following error:
 SELECT Failed.  [7827] Java SQL Exception SQLSTATE 39001: Invalid SQL state ([TD-SQLH]: java.net.UnknownHostException: hdp2dev).

1396 views
0 replies
Teradata R - create table based on a data frame using JDBC Topic by hock 29 Nov 2012 teradatar, rjdbc

Hi All,

6626 views
5 replies, 7 years ago
About Teradata Hadoop Connectors Topic by josephmichael.navarro 05 Jun 2014 tdch, hadoop, teradata hadoop connectors, connectors, etl, informatica, powercenter, talend, sandbox

Hi,
I have a couple of questions regarding the Hadoop connectors:

  • What connector do I need to integrate the Hadoop and Teradata using an ETL tool like Talend or Informatica PowerCenter?
  • Can I use all of the 3 connectors side-by-side and deploy it in a sandbox environment?

 Regards,
Joseph

1466 views
0 replies
XML Service - publishing special characters Topic by banda27 30 May 2014 XML Service, special characters, publish_lob_ref

Hi
I am using publish_lob_ref to publish a resultset. The data has some special characters ( &, >, < ). In the published results these special characters are not getting escaped. Is there something I have to set in xst to make this happen?
 
P.S: I have see the similar question in the forum from 2010 and there was no comment. 

1015 views
0 replies
always got failure 7980 when try to create Java External store procedure. Topic by emilwu 29 Apr 2010 java external store procedure 7980

Teradata release: 13.00.00.00
Version 13.00.00.00
(Express version)

Tried both eclipse and manual process. both throw such here. Here are the steps that I did..

public class jxsp1{
public static void myproc(int[] parm){
parms[0] +=1;
}
}

javac jxsp1.java
jar -cf jar1.jar jxsp1.class

bteq

DATABASE DB1;
CALL SQLJ.INSTALL_JAR('CJ!jar1.jar','jar1','0');

*** procedure has been executed
*** warning: 5241 check output for possible warning encountered in installaing or replacing a jar
*** total elapsed time was 1 second
Check output for possible warnings.

8115 views
5 replies, 7 years ago
SQL-H: Aster to HDP: Unable to access program: ${env.PYTHON_CMD} Topic by tluthra@att.net 23 Apr 2014 aster, sql-h, hadoop, load_from_hcatalog

Hello,
I downloaded Aster v5 and v6 VM Images available from the download section and have been able to replicate the error on both. I'm logged in as aster
I have a single node hadoop cluster 2.2.0 with hive 0.12 (webhcat running on 50111). I can ping both machines and connectivity is good.

1546 views
0 replies
Hadoop configuration Topic by umerbaig 14 Apr 2014 hadoop configuration

I am at beginner level in Hadoop. I want to know best configuration of hadoop components on multiple nodes i-e in my case there are 4 nodes.
Also want to know the multiple instance of some components ie zookeper and other components in hadoop. 
If I switch off one data node will my data be saved ? 
If I switched off namenode will I transfer to Secondary namenode?

890 views
0 replies
upgrading from 13.10 to 14.10 any issues with UDF's in 14.10 Topic by wambli 26 Mar 2014

We are getting ready to upgrade from 13.10 to 14.10 in the next months.  I was looking for any issues with UDF's in 14.10 after the upgrade.  Please let me know if you had any issues with your UDF's.  We plan on deploying ours again after the upgrade.  Thank you....  

1136 views
0 replies
Unable to load ESRI shape files using TDGeoImport - Validating layers failed Topic by srinivas.csn 14 Mar 2014 tdgeoimport, geo, spatial, shape, esri

Hi,

 

I am trying to load ESRI shape files in to Teradata using TDGeoImportExport utility. However, I am facing the below issue "Validating layers failed" and not able to resolve it.

 

I am using the following configuration - Teradata 14.10, TDGeoImportExport 1.6 for windows 7, 32-bit.

 

Thanks in advance!

 

1127 views
0 replies
Can't export Teradata Geospatial ST_Geometry to KML Topic by ayman.guc 12 Jan 2012 geospatial, tdgeoexport 1.6, un-supported data types, teradata express 13

I have a problem using the TDGeoExport tool V1.6 with Teradata express 13.0. I am trying to export some locations (ST_Geometry points) from a Teradata database to KML format for visualising on Google Earth.

The TDGeoExport running script is as follows:-

8757 views
3 replies, 7 years ago
Teradata connector for Hadoop 2.06 Topic by sourabhpotnis 27 Jan 2014 Hadoop 2.0, teradata connector for hadoop, version compatibility

Hi,
I am trying to export data from HDFS (HDP 2.06) into Teradata(version 13) using td-connector-for-hadoop-1.0.9a-hdp1.3-linux-x86-64-sqoop-integration-edition.
 
Its giving following error while exporting:

2227 views
3 replies, 7 years ago
Giraph Exports - Best Practices on Teradata Topic by ldey 29 Jan 2014 Giraph, big data hadoop, Apache

We are about to jump on the Graph train by implementing Giraph on Hadoop with the plan to export the results back to our Teradata RDBMS for consumption and integration with the rest of our TD warehouse data.   Has anyone thoughts or ideas about best practices on how to do this, or experience?

1051 views
1 reply, 7 years ago
Classpath in Java Table UDF Topic by kw 14 Jan 2014

Hi all,
I'm prototyping a Java table UDF and have worked my way through various issues using th TD 14.10 Express VM.
I have the UDF functioning, and returning some rows as I expect.
I now want to instantiate a class using Reflection, and have tried following the section describing how to set the JVM class path in the SQL External Routine Programming Manual.

1189 views
1 reply, 8 years ago
Hive Topic by Raja_KT 08 Jan 2014

I have data like :

empid name salary.....

123    Joseph 1900

435     James 2000

675     Perez 6999

......

1 million records.

 

How do I achieve in query using hive to get sequence number like 

 

seqno empid name salary.....

1       123 Joseph 1900

2       435 James 2000

1040 views
0 replies
Teradata Integration with Salesforce Topic by nehachaudhary 05 Aug 2012

Hi ,

I am Working as Salesforce.com Developer and my  requirement is to connect Salesforce with TeraData . Kindly, let me know the steps that I need to follow in order to make Salesforce and Teradata integration .

 

Regards,

Neha

5860 views
3 replies, 8 years ago

Pages