All Forums Extensibility
sourabhpotnis 3 posts Joined 01/14
27 Jan 2014
Teradata connector for Hadoop 2.06

Hi,
I am trying to export data from HDFS (HDP 2.06) into Teradata(version 13) using td-connector-for-hadoop-1.0.9a-hdp1.3-linux-x86-64- sqoop-integration-edition.
 
Its giving following error while exporting:

14/01/27 07:43:26 ERROR tool.TeradataExportTool: java.lang.IncompatibleClassChangeError: Found interface org.apache.hadoop.mapreduce.JobContext, but class was expected

        at com.teradata.hadoop.mapreduce.TeradataOutputFormat.che ckOutputSpecs(TeradataOutputFormat.java:74)

        at org.apache.hadoop.mapreduce.JobSubmitter.checkSpecs(Jo bSubmitter.java:456)

        at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInte rnal(JobSubmitter.java:342)

        at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1268)

        at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1265)

        at java.security.AccessController.doPrivileged(Native Method)

        at javax.security.auth.Subject.doAs(Subject.java:396)

        at org.apache.hadoop.security.UserGroupInformation.doAs(U serGroupInformation.java:1491)

        at org.apache.hadoop.mapreduce.Job.submit(Job.java:1265)

        at org.apache.hadoop.mapreduce.Job.waitForCompletion(Job. java:1286)

        at com.teradata.hadoop.mapreduce.TeradataOutputProcessor. run(TeradataOutputProcessor.java:78)

        at com.teradata.hadoop.mapreduce.TeradataBatchInsertOutpu tProcessor.run(TeradataBatchInsertOutputProcessor.java :66)

        at com.teradata.hadoop.job.TeradataExportJob.runJob(Terad ataExportJob.java:75)

        at com.teradata.hadoop.tool.TeradataJobRunner.runExportJo b(TeradataJobRunner.java:192)

        at com.teradata.hadoop.tool.TeradataExportTool.run(Terada taExportTool.java:41)

        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java: 70)

        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java: 84)

        at com.teradata.hadoop.tool.TeradataExportTool.main(Terad ataExportTool.java:439)

 

14/01/27 07:43:26 INFO tool.TeradataExportTool: job completed with exit code 10000

 

 

Command:

 

hadoop com.teradata.hadoop.tool.TeradataExportTool -url jdbc:teradata://server_name/database=DB_TAB  -username user-password pwd -jobtype hdfs -sourcepaths /user/example2_hdfs/01 -nummappers 1 -separator ',' -targettable test1

 

 

Is connector available for Hadoop 2.06? Which version and download link?

 

Thanks.

Mark_tdch 1 post Joined 06/13
27 Jan 2014

Hi,
HDP2.0 is supported on TDCH1.1+. The following is the download link.
http://downloads.teradata.com/download/connectivity/teradata-connector-for-hadoop-command-line-edition
Thanks.

sourabhpotnis 3 posts Joined 01/14
31 Jan 2014

Hi,
Thanks Mark_tdch for the answer.
TDCH1.1 connector is working with HDP 2.06.
But with batch.insert export I am getting following error :

Error: com.teradata.hadoop.exception.TeradataHadoopSQLException: java.sql.BatchUpdateException: [Teradata JDBC Driver] [TeraJDBC 13.10.00.35] [Error 1338] [SQLState HY000] A failure occurred while executing a PreparedStatement batch request. Details of the failure can be found in the exception chain that is accessible with getNextException.

        at com.teradata.jdbc.jdbc_4.util.ErrorFactory.makeBatchUpdateException(ErrorFactory.java:147)

        at com.teradata.jdbc.jdbc_4.util.ErrorFactory.makeBatchUpdateException(ErrorFactory.java:136)

 

while its running fine with multiple.fastload.

 

Command: hadoop com.teradata.hadoop.tool.TeradataExportTool -url jdbc:teradata://Server/database=DB_TAB  -username user -password hadoop -jobtype hdfs  -sourcepaths /user/example2_hdfs/TDCSVsample -nummappers 1 -separator ',' -targettable test1

 

Tried with different number of mappers 1/2/10, but getting same error.

 

Any thoughts?

 

Thanks.

amala 1 post Joined 02/10
14 Feb 2014

Hi
This is my first time using Teradata Import Tool. I downloaded the jar file and put it in sqoop folder and tried to import a teradata table to hadoop as given below but I get  "[SQLState 28000] The UserId, Password or Account is invalid" error eventhough everything I gave is correct and I'm able to login to SQL Assistant using the same credentials. Can anyone please advise how to fix this? Could it be something related to LDAP issue? How do I mention that this is LDAP in the command below?
export USERLIBTDCH=/usr/lib/sqoop/teradata-connector-1.1.1-hadoop200.jar
hadoop jar $USERLIBTDCH com.teradata.hadoop.tool.TeradataImportTool -classname com.teradata.jdbc.TeraDriver -url jdbc:teradata://a.b.c.net/DATABASE=XYZ-username ROOT -password XXXX -jobtype hdfs -fileformat textfile -method split.by.hash -separator "," -sourcetable ICDW_REG_QRY -targetpaths /user/ABC/TD_REG_QRY
 
14/02/13 00:36:28 ERROR tool.TeradataImportTool: com.teradata.hadoop.exception.TeradataHadoopException: com.teradata.jdbc.jdbc_4.util.JDBCException: [Teradata Database] [TeraJDBC 14.00.00.39] [Error 8017] [SQLState 28000] The UserId, Password or Account is invalid.
Thanks
 

You must sign in to leave a comment.