All Forums UDA
Rao 9 posts Joined 09/06
04 Oct 2006
Compiling Stored Proc - VC++ not installed error

HI,while compiling the stored proc I get the following error.5547:Internal error VC++ compiler not installed.I installed Visual C++ 2005 Express edition. But still the error. Could some one help me in resolving. Is there any configuration required for the VC++ with respect to Teradata.Thanks in advanceRao

Jim Chapman 449 posts Joined 09/04
04 Oct 2006

If you installed the C++ compiler after you installed Teradata, you will need to update the "CompilerPath" and "LinkerPath" settings in the Teradata UDF/TSP configuration record. The simplest way to do this by entering the command "cufconfig -i" in the Teradata Command Prompt window. This will cause cufconfig to identify the directories containing the CL.EXE and LINK.EXE commands by looking in the registry and re-initialize the configuration accordingly.You can use the command "cufconfig -o" to list the current configuration settings. See the Teradata Utilities manual for other options.

Rao 9 posts Joined 09/06
05 Oct 2006

Hi,Thanks for the reply. I tried the utility 'cufconfig'. But I donot find that command it self. Just for ur info, I am using the Demo version of Teradata on Win2K OS. Could you please give me an alternative solution for this.Thanks in advanceRao

Jim Chapman 449 posts Joined 09/04
06 Oct 2006

I am not familiar with the demo. It may not have the same features as the regular product. Try opening the Database Window program, then go to the supervisor command window and enter "start cufconfig -i". If that doesn't work, try reinstalling Teradata from the demo CD.

jpg 7 posts Joined 09/07
15 Sep 2007

If you installed VC Express into the default location, create a text file with the following contents:CompilerPath:C:\Program Files\Microsoft Visual Studio 8\VC\bin\LinkerPath:C:\Program Files\Microsoft Visual Studio 8\VC\bin\The file should contain only the text shown. Assume it is saved at c:\cufvc.datEnsure the TD demo is running. Then run, from the TD Command prompt:cufconfig -i -f c:\cufvc.dat -oThe output should show something like this:Version: 4ModTime: 1189876140SWDistNodeID: 33SourceDirectoryPath: C:\Program Files\NCR\TDAT\tdconfig\Teradata\tdbs_udf\usr\CompilerTempDirectory: C:\Program Files\NCR\TDAT\tdconfig\UDFTemp\UDFLibraryPath: C:\Program Files\NCR\TDAT\tdconfig\udflib\CompilerPath: C:\Program Files\Microsoft Visual Studio 8\VC\bin\LinkerPath: C:\Program Files\Microsoft Visual Studio 8\VC\bin\UDFServerMemPath: C:\Program Files\NCR\TDAT\tdconfig\udfsrv\MaximumCompilations: 10UDFServerTasks: 2SecureServerAMPs: 20ParallelUserServerAMPs: 2SecureServerPEs: 20ParallelUserServerPEs: 2TDSPLibBase: C:\Program Files\NCR\TDAT\tdconfig\tdsplib\SecureGroupMembership: tdatudfExiting cufconfig...Note the updated values of Compiler and Linker paths.This will update the UDF GDO, and hopefully will allow you to build your UDFs successfully.

rajivgupta1107 14 posts Joined 12/09
17 Dec 2009

hi,i am also facing the same issue. I installed MVC++ express edition and executed the commands for compiler and link path (as described in above post).Still i am getting the error 'C\C++ compiler not installed'.Please help me ...Regards

sunilsaw 3 posts Joined 01/10
28 Sep 2010

Hi,

I am using Teradata 13 Express (Version 13.00.00.12) in Widows XP Service Pack 3

Comiler - Microsoft Visual C++ 2010 Express - ENU

I am getting error like " no compiler found " while compiling UDFs

Compiler and linker path is set as -

CompilerPath: C:\Program Files\Microsoft Visual Studio 10.0\VC\bin\cl.exe
LinkerPath: C:\Program Files\Microsoft Visual Studio 10.0\VC\bin\link.exe

Please help

Thanks

singleamp 8 posts Joined 11/05
09 Oct 2010

Followed all the instructions in the above posts about installing C++ compiler, but still same error (*** C/C++ compiler is not installed. Code= 5862 Info=0 Function= 5). Why are we not able to debug this?

robpaller 159 posts Joined 05/09
12 Oct 2010

I found that I was not able to get VC++ 2010 Express to work with TD Express 12.

I downloaded and installed VC++ 2008 Express, ran the cufconfig command from the Teradata Command Line, and then restarted Teradata. After the restart of Teradata all was well.

HP185016 1 post Joined 04/10
09 Oct 2011

I wanted to create a stored procedure with Teradata 13 and wanted to use Visual 2010 C++ Express Edition with it to compile it. I was constantly getting the "PROCEDURE Failed. 5862: C/C++ compiler IS NOT installed." error.

I uninstalled the visual 2010 Express edition and installed VC++ 8 express edition with SP1. And then followed the commands as mentioned above and got it to work. I have summerized all the steps below for quick access and follow up:

1. Uninstall visual studio 2010 express edition installation and then install visual studio 2008 express edition with SP1 from link http://www.microsoft.com/download/en/details.aspx?id=14597

2. Ensuring Teradata demo is running, open the Teradata database window, go to supervisor command.

3. Type "start cufconfig -i" and enter

4. Then create a text file on C: and name it as cufvc.dat and copy in it the paths to the VC\bin folder as below:

CompilerPath:C:\Program Files\Microsoft Visual Studio 9.0\VC\bin
LinkerPath:C:\Program Files\Microsoft Visual Studio 9.0\VC\bin

5. Then go to Teradata command prompt and ensuring that the TD demo is running type the following command without double quotations on the Teradata command prompt

"cufconfig -i -f c:\cufvc.dat -o"

Some log like would be displayed. The the values for the CompilerPath and LinkerPath variables. They should have been updated correctly now.

6. Then restart the teradata demo and try creating the stored procedure. You should be successfully able to create the stored procedure now.

Regards, Harshal Pandit
Associate Lead Technical Consultant
TERADATA

Adeel Chaudhry 773 posts Joined 04/08
11 Oct 2011

Hi,

 

Thanks for sharing the piece of information .... from TD version 12 and above .... simple installation (no renaming or changing of registry manually) of VC++ 2005 Express edition should work perfectly fine.

 

Regards, MAC

-- If you are stuck at something .... consider it an opportunity to think anew.

ayman.guc 27 posts Joined 10/11
14 Jan 2012

I've found the VC++ 2008 express SP1 recommended by the poster HP185016 (above) to be working fine with my Teradata Express 13.0 on Windows XP SP3. I've tried the 2005 and 2010 versions of VC++ but they didn't yield desired results (I still got a failure message in SQL assistant while compiling the stored procedures like "...the C compiler has problems..."). However, I must say I only followed all the steps listed by HP185016 and the points I'm mentioning here with the VC++ 2008 (Version 9) only...so versions 10 and 8 (2010 and 2005) of VC++ express might have not worked because I didn't follow correct procedures.

To install and configure the C/C++ compilers I've followed the post by HP185016 above...but take care of the following points:-

1. Uninstall any versions of visual studio express before going through the process

2. VERY IMPORTANT TO MAKE SURE to run the Visual studio to initialise the environment variables first (only for first-time use after installation) before starting Teradata and creating your procedures...this is very important to complete the environment installations for the C compilers. When you start both the Microsoft Visual C++ 2008 Express Edition and the Visual Studio 2008 Command Prompt applications you will see initialization messages (the applications can be found under start >> all programs >> Microsoft Visual C++ 2008 Express Edition). When the initialization is done then you are ready to use the C compilers with Teradata

3. I didn't have to do any .dat files or any "cufconfig -f" commands (no need for steps 4 and 5 from HP185016...only need to do the command in step 3) . I only needed to enter the command "cufconfig -i" in the Teradata Command Prompt window (start >> all programs >> Teradata Database Express 13.0 >> Teradata Command Prompt).

OR

Database Window program, then go to the supervisor command window and enter "start cufconfig -i" (start >> all programs >> Teradata Database Express 13.0 >> Database Window).

 

You can then use the command "cufconfig -o" to list the current configuration settings. Check the CL.EXE and LINK.EXE in CompilerPath and LinkerPAth respectively.

Now Teradata will be ready to compile stored procedures and UDFs (no extra steps required like editing environment variables or adding/editing registry keys as I've found in other forum posts). BTW, this procedure is documented in the Teradata Express Help (under the Advanced issues section). This Help can be accessed from the Teradata Express installation menu.

Hope this helps a little bit.

toyo2009 2 posts Joined 05/12
22 May 2012

I've tried the last post above but didn't worked for me.

Internal error: Can not find mt.exe

Adeel Chaudhry 773 posts Joined 04/08
29 Jun 2012

Which verison of TD you are using?

 

Regards, Adeel

 

-- If you are stuck at something .... consider it an opportunity to think anew.

ke186006 3 posts Joined 07/13
16 Jul 2013

Hi all,
I have followed the steps provided by HP185016 for creating procedures.
Now I am not facing any Complier issues. But i am facing the below issue.
1) After creating a procedure it gives me the below output:
   CREATE PROCEDURE completed. 2 rows processed. Elapsed time = 00:00:00
   Output directed to Answer window

2) But when i do show procedure it gives me the below output:
    SHOW Failed. 5495: Stored Procedure '<DBname>.<proc name>' does not exist.
 
Please help me

m.tahoon 43 posts Joined 09/11
21 Aug 2013

Had this error with TD Express 13.10 on wondows 7:
CREATE PROCEDURE Failed.  [5862] C/C++ compiler is not installed.
problem solved after  Installing vc++ 2012 redistributable and restart

DineshSubbaiah 4 posts Joined 05/14
20 May 2014

Hi
I tried to create stored procedure in teradata,used Visual Studio 2010 C++ to compile it.but it throws out error stating VC++ compiler not installed.When i tried uninstalling Visual Studio 2010 C++ and installed VC++ 8.In Teradata Command Prompt ran command cufconfig -i.Compiler path and Linker Path updated successfully.And it worked.
There are two ways to run stored procedure
1, Install VC++ first and then followed by teradata installer.
                    or
2,If you installed teradata first.Then linker path and compiler path needs to be updated.So follow below mentioned steps.
    > Install VC++ 8 and run cufconfig -i in teradata command prompt.It will update linker path and compiler path.
  > To verify it,type cufconfig -o.It will list the linker path,compiler path and many informations.
 > Restart Teradata and execute procedure
 
 
Harshal Pandit post helped me..Thanks harshal
 
 
Regards
Dinesh.S

You must sign in to leave a comment.