All Forums Database
Mike 7 posts Joined 08/05
10 Apr 2006
weird issue importing from excel to TD.....

Hi All,I am encountering an issue trying while I am trying to Import data from Excel to a TD table that is driving me a bit nutty. I keep getting the 'Wrong number of data values in Import file' error, even though my .csv file has the same number of data-values as my TD table. I've even tried doing the import with just one column in the TD table and one column of .csv data, and I STILL get that error. This is really stumping me. Anyone ever encounter this issue?TIA,myk

10 Apr 2006

I guess the delimeter that is used as default in your import/export option is set to something other than comma.In queryman check this (click on the follwing menu option)Tools -> Options -> Export (tab)now change the Use this delimiter between columns in export/import filesfrom the dropdown choose ,click okNow try the Import Data.Let me know if that does not work.

rajgowda 3 posts Joined 11/04
13 Apr 2006

Hi,Also Some time it throws same error if there is a date column.In the excel sheet you need to format the date column to yyyy-mm-dd.Thanks,Gowda C H

BBR2 96 posts Joined 12/04
19 Apr 2006

Mike,You may want to remove all column header information from the export report file. This should help.For the date issue, you will need to change the format to match the date format (for the column) in the table.Hope this helps.Vinay

atulverma 1 post Joined 11/07
03 Jan 2008

I am getting an error "Data Values Missing in Record #' though the excel has rows for the record and more.It has started happening recently on a couple of files that I started loading.

You must sign in to leave a comment.