All Forums Database
sunni1221 7 posts Joined 11/07
02 Jan 2013
Time Data Type

 
Hi 
I have created a table with column as TIME(0) data type.
When I look at the table DDL, through SHOW TABLE, it shows the column data type as 'Integet Format '99:99:99'.
Time data type are stored as integer internally. But, I need the column to be as TIME(0) in DDL insted of Integer.
 
Any thoughts ?
 
Thanks,
Suneel

m.tahoon 43 posts Joined 09/11
03 Jan 2013

i recall Dieter had replied same querion before:
let me recall his point:
- you are using SQLA, odbc connection method
- what you need to change is the DateTime format in the ODBC options from III  to AAA.
 
- you can change odbc options from:
- Start menu/odbc/32-bit ODBC Administrator
or:
- run: C:\Windows\System32\odbcad32.exe
 
Then:
select you system/user DSN > configure > options >
set Date Time format = AAA
 
Regards

sunni1221 7 posts Joined 11/07
03 Jan 2013

Thank you Tahoon. It worked.
I am trying to change to ANSI mode, without trying to modify the ODBC setting.
Can it be over written for only specific session.
I tried 'SET SESSION DATEFORM=ANSIDATE' in SQLA, but works for only DATE. 
Anything similar for time available ? Through queryband ?
 
Thanks,
Suneel
 
(ODBC Driver for Teradata User Guide has details for III and AAA)

You must sign in to leave a comment.